LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Unable to start X after installing FGLRX (http://www.linuxquestions.org/questions/slackware-14/unable-to-start-x-after-installing-fglrx-669163/)

acheong87 09-11-2008 05:37 AM

Unable to start X after installing FGLRX
 
Hello. I've spent several hours on this problem. I've searched Google and looked through Phoronix, ATI CCHTML, UbuntuForums, as well as LinuxQuestions, but to no avail. The problem is simple - I can't start X.

I did a clean install of Slackware 12.1. At that time, I could startx just fine.

Afterward, I obtained the latest ATI proprietary drivers, built the *.tgz packages, and used installpkg to install fglrx. (I followed the guide at http://wiki.cchtml.com/index.php/ATI...uild_%28ENG%29 exactly.) Once I rebooted, I was no longer able to startx - the screen turns black, then returns, saying that it failed to start X. I tried various modifications to xorg.conf but nothing helped. The end of my /var/log/Xorg.0.log is as follows:

Code:

(EE) fglrx(0): Invalid video BIOS signature!
(EE) fglrx(0): GetBIOSParameter failed
(EE) fglrx(0): PreInitConfig failed

Backtrace:
0: X(xf86SigHandler+0x80) [0x80dbde0]
1: [0xffffe420]
2: /usr/lib/xorg/modules/drivers//fglrx_drv.so(amdPcsFree+0x36) [0xb787f356]
3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0x2c6) [0xb7858d16]
4: X(InitOutput+0x9be) [0x80a2443e]
5: X(main+0x286) [0x806dba6]
6: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7d26390]
7: X(FontFileCompleteXLFD+0x20d) [0x806d0e1]

Can anyone provide any hints or thoughts? Thank you. By the way, I backed up my original xorg.conf (right after the clean install); when I restore that original, I can startx just fine.

(I am running Slackware 12.1 on a Lenovo ThinkPad T500. The graphics card is ATI Mobility Radeon 3650 with 256MB. Please ask for my xorg.conf file if you would like to see it. Also, if you think a stack trace may help, please let me know as well.)

Alien Bob 09-11-2008 05:46 AM

Quote:

(EE) fglrx(0): Invalid video BIOS signature
Sounds like your card is not yet supported by the fglrx driver? Just guessing here.

Eric

symatic 09-11-2008 08:00 AM

I don't see that series listed in the 8.8 supported list. Have you tried adjusting some of your bios settings. ie( the pre-init vga settings). Most likely it will say something like pci, agp/pci and agp. I would try switching those around and see if that does the trick.

Well, good luck.

acheong87 09-11-2008 05:47 PM

Problem Solved!
 
In the BIOS settings, I went to [Config], [Display], [Graphics Device], where the options were "Integrated", "Discrete", or "Switchable". I had it on "Switchable", which uses Discrete for maximum performance and Integrated for battery-saving. I switched this option to "Discrete", and everything started working fine! Also, for those others having the same problem, make sure to disable [OS Detection for Switchable Graphics] in your BIOS, else BIOS will revert to "Switchable" every time you reboot.

I am now running at 1680x1050 resolution. If anyone wants me to post/send them my xorg.conf or would like assistance, please send me a message or email. I'm going to try Compiz/Beryl now.

Code:

bash-3.1# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3650
OpenGL version string: 2.1.7873 Release

Thank you!

symatic 09-11-2008 07:46 PM

Good to hear..

You should add to the wiki under trouble shooting. The fglrx driver seems to be a pain for many people.

nedyar 02-01-2009 04:18 AM

I have the same problem but i cannot modify the bios settoing, what can i do? The driver work perfectly with ubuntu 8.04 but it doesn't work with Ubuntu 8.10 and i need the last one because it support linux kernel 2.27 that is usefull to use wireless

Daedra 02-01-2009 05:08 AM

Quote:

Originally Posted by nedyar (Post 3427951)
I have the same problem but i cannot modify the bios settoing, what can i do? The driver work perfectly with ubuntu 8.04 but it doesn't work with Ubuntu 8.10 and i need the last one because it support linux kernel 2.27 that is usefull to use wireless

I also had this problem and like you my bios on my laptop has extremely limited options, the only fix I found was to downgrade to ATI catalyst 8.11 for now.

nedyar 02-02-2009 08:17 AM

I have found support for my wireless card with Ubuntu 8.04 so i not urge to solve this problem with new xorg. However to downgrade to ati catalyst 8.11 need only to remove the newest, download and install precedent version?

acummings 02-03-2009 01:03 AM

Yep, there's an uninstall.sh somewhere (that, as root, I ran it).

Forgot exactly where, /lib/something_or_other (ati?)

Then DL the 8.12 Catalyst (9.1 wouldn't work for me).

I started another thread, shared my success with fglrx and also IRQ (plug and play)

http://www.linuxquestions.org/questi...el-p45-701821/

Alan.

Daedra 02-03-2009 01:53 AM

the uninstall script is in /usr/share/ati

trent1980 08-07-2009 02:43 PM

Quote:

Originally Posted by acheong87 (Post 3277660)
In the BIOS settings, I went to [Config], [Display], [Graphics Device], where the options were "Integrated", "Discrete", or "Switchable". I had it on "Switchable", which uses Discrete for maximum performance and Integrated for battery-saving. I switched this option to "Discrete", and everything started working fine! Also, for those others having the same problem, make sure to disable [OS Detection for Switchable Graphics] in your BIOS, else BIOS will revert to "Switchable" every time you reboot.

I love you. This was driving me nuts. FIXED

trent@t-ubu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3650
OpenGL version string: 2.1.8787 FireGL


Running 1920x1200


All times are GMT -5. The time now is 02:55 PM.