LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-05-2014, 08:19 PM   #16
Pinonoir
Member
 
Registered: May 2014
Posts: 163

Original Poster
Rep: Reputation: 0

Yes I did. I also tried running as root and still received the same error.
 
Old 06-05-2014, 08:34 PM   #17
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 228

Rep: Reputation: 54
Try running, modified of course, the script below... maybe aqemu is just bugging out? Other than loading the kernel module... not sure what else would give that error.. esp as root so thinking it is just a catch all message for something in aqemu.

export QEMU_AUDIO_DRV=sdl
export SDL_AUDIODRIVER=alsa
qemu-kvm --enable-kvm -localtime -m 2G -sdl -display sdl -vga vmware -usbdevice tablet -smp 2 -net nic,model=virtio -net user -drive file=VirtualDrives/slackware64-14.1-ansaldo.img,cache=none,if=ide &

#-cdrom VirtualDrives/slackware64-14.1-install-dvd.iso
 
Old 06-06-2014, 02:00 AM   #18
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware64
Posts: 85

Rep: Reputation: 50
Try this

Code:
ls -l /dev/kvm
crw-rw---- 1 root kvm 10, 232 jun  3 15:27 /dev/kvm

------------------^^^
On this machine to use kvm is required membership in "kvm" group!

Enjoy
 
Old 06-06-2014, 09:52 AM   #19
Pinonoir
Member
 
Registered: May 2014
Posts: 163

Original Poster
Rep: Reputation: 0
I checked using getent group, and I don't see a kvm group. Would I just create it?
 
Old 06-06-2014, 10:00 AM   #20
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 228

Rep: Reputation: 54
odd.. mine is just this;

crw-rw---- 1 root users 10, 232 Jun 6 10:09 /dev/kvm


no kvm group, but works fine.
 
Old 06-06-2014, 10:09 AM   #21
Pinonoir
Member
 
Registered: May 2014
Posts: 163

Original Poster
Rep: Reputation: 0
Ah, then perhaps this will help.

crw-rw---- 1 root root 10, 232 Jun 6 09:26 /dev/kvm
 
Old 06-06-2014, 10:18 AM   #22
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 228

Rep: Reputation: 54
Did you install qemu with the slackbuilds.org script? It has some bits aobut the udev rules that should have setup these permissions properly on your system.
 
Old 06-06-2014, 10:18 AM   #23
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,460

Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
so it seems you haven't installed qemu from SlackBuilds.org (the recommended way)

http://slackbuilds.org/repository/14.1/system/qemu/

there an udev rule is attached that lets you specify which group you want the /dev/kvm device to be associated (see the README).

EDIT: WhiteWolf beated me by seconds
 
Old 06-06-2014, 10:21 AM   #24
Pinonoir
Member
 
Registered: May 2014
Posts: 163

Original Poster
Rep: Reputation: 0
Good. So I would just recompile it and reinstall the package, correct?
 
Old 06-06-2014, 10:27 AM   #25
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,460

Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
- first you have to read the README and the *.info of the SlackBuilds.org's SlackBuild script;

- then you decide if you want to change anything form the default (if not necessary stick with the default);

- as last step, you build the qemu package using that script (and eventual dependencies) following the HOWTO and use "upgradepkg --install-new" to update the one you have already installed.

In this specific case you will have also to reboot (restarting udev is not recommended).
 
Old 06-06-2014, 10:40 AM   #26
Pinonoir
Member
 
Registered: May 2014
Posts: 163

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ponce View Post
- first you have to read the README and the *.info of the SlackBuilds.org's SlackBuild script;

- then you decide if you want to change anything form the default (if not necessary stick with the default);

- as last step, you build the qemu package using that script (and eventual dependencies) following the HOWTO and use "upgradepkg --install-new" to update the one you have already installed.

In this specific case you will have also to reboot (restarting udev is not recommended).
In the readme, it has several things you can enable when running the compile-
TARGETS=all ./qemu.SlackBuild

VNC_ENABLE=yes ./qemu.SlackBuild

KVMGROUP=group ./qemu.SlackBuild

Would I run one at a time and upgrade the package after?
 
Old 06-06-2014, 11:14 AM   #27
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,460

Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
Quote:
Originally Posted by Pinonoir View Post
In the readme, it has several things you can enable when running the compile-
TARGETS=all ./qemu.SlackBuild

VNC_ENABLE=yes ./qemu.SlackBuild

KVMGROUP=group ./qemu.SlackBuild

Would I run one at a time and upgrade the package after?
no, the options (variables that you pass to the bash script) must be specified all together, but just if you need them: I usually specify only VNC_ENABLE=yes because I use the vnc display (sometimes), I don't need all targets (x86, x86_64 and arm are enough for me) and the default group "users" it's what I want.
as I said, if you don't understand/need the options, stick with the default.

Last edited by ponce; 06-06-2014 at 11:17 AM.
 
Old 06-07-2014, 05:43 PM   #28
Pinonoir
Member
 
Registered: May 2014
Posts: 163

Original Poster
Rep: Reputation: 0
I just removed it and started over. Modified the source to include the options. That worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware64 14.0 and aqemu/qemu: KVM module: permission denied Totoro-kun Slackware 1 10-01-2012 05:41 AM
Unable to set time : Permission denied dipuasks Linux - General 7 04-10-2010 05:10 PM
Unable to run program, Permission denied smartgupta Solaris / OpenSolaris 3 08-11-2009 01:49 AM
make execvp : /home/taowuwen/openmoko/qemu-neo1973/texi2pod.pl: permission denied twwwater Ubuntu 0 01-07-2009 11:55 AM
/etc/init.d/apache2 start ---> permission denied david008 Linux - Newbie 4 11-12-2008 11:13 AM


All times are GMT -5. The time now is 04:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration