LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-01-2009, 03:16 PM   #1
gellb
LQ Newbie
 
Registered: Jan 2009
Posts: 5

Rep: Reputation: 0
Unable to load any home page


Hi Slackers,
I am unable to load any home page in my browser, nor ping any site. Althoug apparently I managed to setup the pppoe service properly because after pppoe-start, it connects.
What should be the problem?
(I have ADSL modem and an active Realtek ethernet PCI card. I also have a built-in ethernet card on the motherboad but I don't use it.)
Now I am writing from PuppyLinux because net works in Puppy.

Any help is welcome!
 
Old 01-01-2009, 03:46 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 4,008

Rep: Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961
Please send the output of following commands, typed as root, when you suppose the connected is active:
Code:
ifconfig -a
then:
Code:
route
 
Old 01-01-2009, 04:30 PM   #3
gellb
LQ Newbie
 
Registered: Jan 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Answers and some more

# ifconfig -a

Quote:
eth0 Link encap:Ethernet HWaddr 00:0e:2e:f0:d1:8f
inet6 addr: fe80::20e:2eff:fef0:d18f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:66 errors:0 dropped:0 overruns:0 frame:0
TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4406 (4.3 KiB) TX bytes:7165 (6.9 KiB)
Interrupt:17 Base address:0xc800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:672 (672.0 B) TX bytes:672 (672.0 B)

ppp0 Link encap:Point-to-Point Protocol
inet addr:213.181.216.107 P-t-P:213.181.206.9 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:22 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:1198 (1.1 KiB) TX bytes:1213 (1.1 KiB)
# route

Quote:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
213.181.206.9 * 255.255.255.255 UH 0 0 0 ppp0
loopback * 255.0.0.0 U 0 0 0 lo
default * 0.0.0.0 U 0 0 0 ppp0
# lspci

Quote:
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:00.0 Ethernet controller: Attansic Technology Corp. L2 100 Mbit Ethernet Adapter (rev a0)
# dmesg | grep eth

Quote:
Driver 'st' needs updating - please use bus_type methods
Driver 'sd' needs updating - please use bus_type methods
Driver 'sr' needs updating - please use bus_type methods
eth0: RealTek RTL8139 at 0xc800, 00:0e:2e:f0:d1:8f, IRQ 17
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
eth0: no IPv6 routers present
I am suspicious with this last line about IPv6 routers.

Any help is appricated!
 
Old 01-02-2009, 05:36 AM   #4
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Try pinging your gateway first:
Code:
213.181.206.9
If it works, resolving DNS addresses is broken.

There is a problem with your eth0 interface. It has only IPv6 address (inet6 addr) and therefore is missing traditional IPv4 one (inet addr). As well, no routing for this interface was specified in kernel routing table. I am not sure which card eth0 was bound to. It might be bound to the card you're not using.

However, ppp0 should work as it is labeled as default. So I suggest to solve this problem first and later concentrate on fixing ethernet.
 
Old 01-02-2009, 03:14 PM   #5
gellb
LQ Newbie
 
Registered: Jan 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Resolving DNS has been fixed but ethernet is zet an issue

Thanks, Alien for your help!

Meanwhile I managed to fix the DNS resolving problem. The solution was to edit /etc/resolv.conf and /etc/ppp/resolv.conf with the proper IP values. Therefore right now I am writing this reply from Slackware!

Although the IPv6 issue has remained.
Code:
bash-3.1# dmesg | grep eth
Driver 'st' needs updating - please use bus_type methods
Driver 'sd' needs updating - please use bus_type methods
Driver 'sr' needs updating - please use bus_type methods
eth0: RealTek RTL8139 at 0xc800, 00:0e:2e:f0:d1:8f, IRQ 17
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
eth0: no IPv6 routers present
Remark: RealTek is my active ethernet card. I put the driver of the other eth card to the blacklist.

Any help is welcome concerning
Quote:
eth0: no IPv6 routers present
.
 
Old 01-02-2009, 03:30 PM   #6
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,656

Rep: Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570
Disable IPV6

The easy way to disable IPV6, edit /etc/modprobe.d/modprobe.conf and add the lines...
Code:
#Disable ipv6 the old way...
alias net-pf-10 off
...and edit /etc/modprobe.d/blacklist and add...
Code:
blacklist ipv6
You also need to modprobe -r ipv6 and restart your network daemons. Easy way is of course reboot (cringe).
 
Old 01-05-2009, 03:44 PM   #7
gellb
LQ Newbie
 
Registered: Jan 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I managed to disable ipv6 but...

Thanks, Astrogeek! With your codes I managed to disable ipv6 however I don't have ipv4 address for my eth0 yet. Anyhow my net connection is OK.

Code:
bash-3.1# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:0e:2e:f0:d1:8f  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:491 errors:0 dropped:0 overruns:0 frame:0
          TX packets:516 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:160503 (156.7 KiB)  TX bytes:110007 (107.4 KiB)
          Interrupt:17 Base address:0xc800
 
Old 01-05-2009, 04:25 PM   #8
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Do you mean that you can connect with your eth0 card only (not using ppp)?
 
Old 01-06-2009, 01:41 AM   #9
gellb
LQ Newbie
 
Registered: Jan 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Unhappy Connect internet by ppp only

No, Alien. I need ppp, unfortunately. Any suggestion?
 
Old 01-06-2009, 10:39 AM   #10
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Code:
ifconfig eth0 your_ip_address netmask 255.255.255.0
 
  


Reply

Tags
adsl, ethernet, net, pppoe


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i am unable to load mappingtable by using dmsetup and unable to create vitualdevice varunsharma35 Linux - Software 0 12-20-2008 08:52 AM
page load time ygloo LQ Suggestions & Feedback 5 10-04-2006 11:03 AM
lost start page (home page?) multiplaone Linux - Newbie 1 05-29-2005 06:10 PM
ipw2200 - Unable to load ucode, unable to load firmware blizinsk Linux - Wireless Networking 2 10-10-2004 08:28 AM
linux doesn't load page with - jizzyjesus Linux - General 17 09-25-2004 02:17 AM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration