LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-14-2007, 08:04 PM   #1
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Unable to install NVIDIA drivers due to missing version.h


Hi all, I'm having problems trying to install the NVIDIA graphics drivers. I am running Slack 11.0 with my own compiled kernel, version 2.6.20.3. The error message when I run the installer is as follows:

The kernel header file '/usr/src/linux/include/linux/version.h' does not exist. The most likely reason for this is that the kernel source files in '/usr/src/linux' have not been configured.

My kernel source is in /usr/src/linux-2.6.20.3 (/usr/src/linux is a symlink pointing to that) and per the README in the kernel tarball, I set an output directory when running make to build the kernel modules. This directory is ~/kernel and /lib/modules/2.6.20.3/build is a symlink to there (this was set up automatically).

I tried to point the installer to my source code with the --kernel-source-path option, but that didn't help. I've searched both here and nvnews.net's forum and haven't found anything that can help.

It shouldn't really matter, but video card info is as follows:

01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600/GeForce 6600 GT] (rev a2)

Any ideas?

Thanks!
 
Old 04-14-2007, 08:55 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
run 'make prepare' on the kernel source and try again. Also, make sure all the symlinks are right.
 
Old 04-14-2007, 08:58 PM   #3
drumz
Member
 
Registered: Apr 2005
Location: Scottsdale, AZ, USA
Distribution: Slackware
Posts: 188

Rep: Reputation: 33
What driver version are you trying to install? I think the most recent ones (current and 2 legacy) have this fix. Currently I'm using 9631, and I'm pretty sure it worked without that error.

The version.h file was removed from the kernel tree a few releases back, so the third party modules are taking a while to get this fixed.
 
Old 04-15-2007, 02:42 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by H_TeXMeX_H
run 'make prepare' on the kernel source and try again. Also, make sure all the symlinks are right.
Running "make prepare" seemed to do it (though I had to recompile my kernel again to remove some things!).

Quote:
Originally Posted by drumz
What driver version are you trying to install? I think the most recent ones (current and 2 legacy) have this fix. Currently I'm using 9631, and I'm pretty sure it worked without that error.

The version.h file was removed from the kernel tree a few releases back, so the third party modules are taking a while to get this fixed.
I was trying to install the latest version of the drivers, 1.0-9755. As above, I've got them installed now and have edited my xorg.conf.

New problem though: the screen just goes black when I try to start X again. Lines from my xorg.conf:

(EE) NVIDIA(0): Error recovery failed.
(EE) NVIDIA(0): *** Aborting ***
(II) NVIDIA(0): Setting mode "1024x768"
(WW) NVIDIA(0): The NVIDIA X driver has encountered too many errors. Falling
(WW) NVIDIA(0): back to legacy PCI mode.

There aren't any error messages above or below or above that in my log (well, there's a "Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!" at the end, but that's it). The entire log can be found here.
 
Old 04-15-2007, 07:41 AM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Have you tried running the nVidia script with the options from this thread?

http://www.linuxquestions.org/questi...d.php?t=541473
 
Old 04-15-2007, 11:39 AM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
That's odd. It may be a problem with the drivers themselves. Two things you could do:

1) run 'xorgsetup', and it will detect everything right and likely use the 'nv' driver. After that, go in the new 'xorg.conf' and change 'nv' to 'nvidia'.

2) try some other driver versions. I don't like the proprietary nvidia drivers because they are so messed up. You never know if it's gonna work or not.
 
Old 04-15-2007, 12:41 PM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend
Have you tried running the nVidia script with the options from this thread?

http://www.linuxquestions.org/questi...d.php?t=541473
That link's broken (but easily fixed). No, I haven't. I can't use the second option anyway because I'm running Slack 11, rather than current so X is set up differently (i.e. /usr/lib/xorg doesn't exist).


Quote:
Originally Posted by H_TeXMeX_H
That's odd. It may be a problem with the drivers themselves. Two things you could do:

1) run 'xorgsetup', and it will detect everything right and likely use the 'nv' driver. After that, go in the new 'xorg.conf' and change 'nv' to 'nvidia'.

2) try some other driver versions. I don't like the proprietary nvidia drivers because they are so messed up. You never know if it's gonna work or not.
I'll try those a bit later. I usually don't bother installing the NVIDIA drivers, but I've read that installing them may help in making TV watching smoother.
 
Old 04-15-2007, 01:29 PM   #8
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
This is turning out to be a pain. I generated a new xorg.conf using xorgsetup but it appears that my nvidia.ko is missing :/. I did have to recompile my kernel earlier for something, but it was for something unrelated. When I tried to reinstall the driver again, I had errors. I might just give up :/. All I really want to be able to do is watch TV smoothly!
 
Old 04-15-2007, 04:33 PM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Then use the 'nv' driver. It should work just fine for just watching tv. It gives you 2D acceleration, so unless you're running 3D games, the 'nv' driver is the way to go. It's better (more stable) anyway.

If you used 'xorgsetup' it should have chosen the best driver options anyway ... this would be 'nv' driver.

Last edited by H_TeXMeX_H; 04-15-2007 at 04:34 PM.
 
Old 04-15-2007, 04:39 PM   #10
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Indeed, xorgsetup did choose nv. I'll have to change the config it made though, as it wasn't working. I don't think I've ever had success with nv, but I'll try again .
 
Old 04-15-2007, 04:42 PM   #11
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Well, post if you have problems ... it's usually something trivial that keeps it from working ...
 
Old 04-15-2007, 05:13 PM   #12
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Quote:
That link's broken (but easily fixed). No, I haven't. I can't use the second option anyway because I'm running Slack 11, rather than current so X is set up differently (i.e. /usr/lib/xorg doesn't exist).
I am also running Slackware-current and I have a /usr/lib/xorg directory. There is a single subdirectory ./modules and this is where my libnvidia-wfb.so.1.0.9755 library was placed after I compiled and installed nVidia 1.0-9755. Also in this subdirectory is libwfb.so which is a symlink to this library.

Other things to check are:
That symlinks /lib/modules/`uname -r`/build and /lib/modules/`uname -r`/source point to the kernel source for your kernel.
That you do have the kernel headers and kernel source for your kernel installed and that the symlink /usr/src/linux is correct.

Sorry about the symlink.
It should be:
http://www.linuxquestions.org/questi...d.php?t=541473

Last edited by allend; 04-15-2007 at 05:28 PM.
 
Old 04-16-2007, 12:29 PM   #13
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend
I am also running Slackware-current and I have a /usr/lib/xorg directory.
I'm not running current. I've given up on the NVIDIA drivers now.

As for using nv, I'm having problems getting that to work. The default config that xorgsetup generated didn't work and I've edited it with some of the things from my working config (which uses the vesa driver, though) like modes. When I start X, well, it's not displaying properly. I get a mostly black screen with some multi-coloured "patches" at the bottom. Config is here.
 
Old 04-16-2007, 05:33 PM   #14
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Try uncommenting out Viewport.

Module loading should be more like this:
Code:
Section "Module"
	Load  "dbe"
	Load  "dri"
	Load  "extmod"
	Load  "glx"
	Load  "record"
	Load  "xtrap"
	Load  "freetype"
	Load  "type1"
EndSection
Were these set automatically ?
Code:
	HorizSync    30-70
	VertRefresh  50-160
might wanna use a lower refresh rate range ... more like:

Code:
	HorizSync    28.0 - 65.0
	VertRefresh  57.0 - 63.0
(these are my numbers, but you can just lower 160 to say 60 or 70)

Also, if that don't work, can you post '/var/log/Xorg.0.log' ?

What kind of monitor do you have ? is it LCD ? is it on a laptop ?

Last edited by H_TeXMeX_H; 04-16-2007 at 05:35 PM.
 
Old 04-19-2007, 01:10 PM   #15
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
I have decided to give up on getting the nv/NVIDIA drivers to work. The reason being is that watching TV is quite smooth now, so I'd rather leave my setup as it is. I don't know why it was all jerky before. Having said that, thanks everyone for trying to help .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install nvidia-drivers on 2.6.19-rc4-mm2 timonvo Linux - Kernel 4 11-09-2006 09:35 AM
Testing Basicsysstem unable to install due to initrd-tools? Kapriel Debian 3 10-21-2005 08:35 AM
nvidia drivers not installing due to problems with the kernel source bcf2 Mandriva 1 01-16-2005 04:33 PM
system locking up due to nvidia drivers? bbioman85 Mandriva 5 12-18-2004 05:15 PM
Unable to install nvidia drivers (by all means) Paul Sernine Linux - Hardware 5 10-30-2004 10:36 AM


All times are GMT -5. The time now is 01:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration