LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   unable to get mplayer working (http://www.linuxquestions.org/questions/slackware-14/unable-to-get-mplayer-working-526315/)

riodeuno 02-07-2007 02:53 AM

unable to get mplayer working
 
hello,
i installed the package named
MPlayer-1.0rc1-i686-1jto.tgz
and also put the essential codecs into the folder /usr/lib/codecs
but when i try to run any file with mplayer
"mplayer <filename>"
i get the following error
Quote:

mplayer: error while loading shared libraries: libdvdnav.so.4: cannot open shared object file: No such file or directory

MS3FGX 02-07-2007 03:07 AM

The problem here, and the problem you have with any pre-compiled software really, is that MPlayer has been built against a package that is not installed on your system. I would also hazard to guess that there are likely a number of other programs it is going to want which you do not have.

dvdnav is used to handle DVD menus. Even if you are not looking for DVD playback, that is what it was compiled with, so that is what you need to make it run now.

Your only choices are to go onto Linuxpackages.net and start installing all the packages MPlayer asks for until it will work properly, or compiling your own build of MPlayer including only the features you want.

Daedra 02-07-2007 03:08 AM

it wont start because it's looking for the libdvdnav package, download and install it. Get the package here

http://www.linuxpackages.net/pkg_details.php?id=10083

simcox1 02-07-2007 04:53 AM

Also you can get it from http://www.slackbuilds.org/ . There are packages for mplayer and the mplayer codecs. There are no dependency problems.

monsm 02-07-2007 06:26 AM

Or, for a bit more work, you can compile your own from the source.
When you follow the provided install instructions you run './configure --enable-gui'
To make it run under X, then 'make' and 'make isntall'. It will tell you which packages are needed on your system. Only problem I had was that when it asks for X support, it actually needed the libxext package..

Probably better to try with the Slackware builds that simcox1 point to first if you are completely new to Linux.

simcox1 02-07-2007 06:32 AM

The beauty of slackbuilds.org is that you are actually building the software from source, by using the slackBuild script. Just remember to read all the instructions on the site so you know what you're doing. But it's so simple, and very reliable.

Basslord1124 02-07-2007 08:41 AM

If I remember right, MPlayer involved a lot of different codecs, libraries, and things. So I'd suggest camping out at linuxpackages to see which one it's gonna spit at you next that it can't find. Once you get it all though it's worth it. I haven't found a video yet that it won't play.

simcox1 02-07-2007 10:00 AM

Like I said. The package at slackbuilds.org includes everything. You don't need libdvdcss, and the codecs package is the -all one. If you do have libdvdcss already installed, either uninstall it, or I think erics got a package to deal with it.

swampdog2002 02-07-2007 07:29 PM

Make certain that you read the Slackbuild script before compiling MPlayer for your system, especially with the location of the codecs. Also, I found that you will need to visit http://www.mplayerhq.hu in order to download the two skins, Quicksilver (default) and plastik for this particular Slackbuild script in order to get a GUI by default. Once the package has been installed, you will receive a message about not being able to locate subfont.ttf in ~/.mplayer directory. To resolve this, choose a font from the /usr/X11R6/lib/X11/fonts/TTF and perform the following:

ln -s /usr/X11R6/lib/X11/fonts/TTF/{font name} ~/.mplayer/subfont.ttf

After this, you should be ready to enjoy some multimedia files!

H_TeXMeX_H 02-07-2007 07:34 PM

Quote:

Originally Posted by Daedra
it wont start because it's looking for the libdvdnav package, download and install it. Get the package here

http://www.linuxpackages.net/pkg_details.php?id=10083

yeah, if you don't do a slackbuild (often a better option), you gotta install all the dependencies ... they will all be located at linuxpackages ... same place you got mplayer ... just search for them. (there's plenty to install)

Alien Bob 02-07-2007 11:32 PM

If you don't want to hunt all those dependencies and don't want to compile the package yourself, you can download a version of MPlayer that is able to play encrypted DVD's (i.e. almost all you can buy) from http://www.alienbase.nl/slackware/re...uilds/MPlayer/ . It needs no other packages than what you find in a full Slackware 11.0 installation.
The package with additional Windows codecs is here: http://www.alienbase.nl/slackware/re...player-codecs/

Eric

riodeuno 02-09-2007 04:00 AM

hey thanks for helping me out!!
i finally got mplayer installed using source
still i dont know why, any file wont go to full screen!!
i mean the window in which the video is showing will goto full screen mode but the area in which the video is showing will remain of the same size.
please help me out here!

H_TeXMeX_H 02-09-2007 02:07 PM

Go to the preferences and choose a different video driver (assuming you have a decent one available).

glsen_az 02-25-2007 01:30 AM

Mplayer Fix
 
Quote:

Originally Posted by swampdog2002
Once the package has been installed, you will receive a message about not being able to locate subfont.ttf in ~/.mplayer directory. To resolve this, choose a font from the /usr/X11R6/lib/X11/fonts/TTF and perform the following:

ln -s /usr/X11R6/lib/X11/fonts/TTF/{font name} ~/.mplayer/subfont.ttf

The above link worked great on my SuSE 10 installation. I did a similar command on my system because of a different path for TTF fonts:

Code:

ln -s /usr/X11R6/lib/X11/fonts/truetype/SUSESans-Roman.ttf ~/.mplayer/subfont.ttf
SuSE has the TTF fonts living in the "truetype" directory. I chose the SUSESans-Roman face because I figured it was more of a system font and would probably be the most compatible. Works OK for me. I don't know how my system lost the settings for MPLayer - it used to work great. No matter, it's working again, thanks to the above link command. Thanks so much for your suggestion/fix!

-*-Bill


All times are GMT -5. The time now is 05:14 AM.