LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-18-2012, 10:47 PM   #1
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 59

Rep: Reputation: Disabled
unable to establish network interface at boot with wlan using dhcp


I can connect to my ISP from a gui but not at boot or from command line. My efforts have centered around the configuration of rc.inet1.conf primarily using Alien Bob's network configuration guide. I must be missing some detail. I will attach outputs for iwconfig, /etc/rc.d/rc.inet1 wlan0_start, and iwconfig from within gui with connection established. Any suggestions would be most welcome. Thank you for your help. below is my rc.inet1.conf:

# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout. Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="yes"

# Example of how to configure a bridge:
# Note the added "BRNICS" variable which contains a space-separated list
# of the physical network interfaces you want to add to the bridge.
#IFNAME[0]="br0"
#BRNICS[0]="eth0"
#IPADDR[0]="192.168.0.1"
#NETMASK[0]="255.255.255.0"
#USE_DHCP[0]=""
#DHCP_HOSTNAME[0]=""

## Example config information for wlan0. Uncomment the lines you need and fill
## in your info. (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="Athens"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=PoplarHouse
WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="[2] s:mysecretpassword key [2]"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0" # Use a different interface name nstead of
# the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89" # Overrule the card's hardware MAC address
#MTU[4]="" # The default MTU is 1500, but you might need
# 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes" # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes" # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes" # If you don't want the DHCP server to change
# your default gateway
#DHCP_IPADDR[4]="" # Request a specific IP address from the DHCP
# server
#WLAN_ESSID[4]=DARKSTAR # Here, you can override _any_ parameter
# defined in rc.wireless.conf, by prepending
# 'WLAN_' to the parameter's name. Useful for
# those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
# Some drivers require a private ioctl to be
# set through the iwpriv command. If more than
# one is required, you can place them in the
# IWPRIV parameter (separated with the pipe (|)
# character, see the example).
Attached Files
File Type: log iwconfig.log (255 Bytes, 3 views)
File Type: log iwconfig-gui.log (487 Bytes, 0 views)
File Type: log wlan0_start.log (96 Bytes, 0 views)

Last edited by Laertiades; 11-18-2012 at 11:07 PM.
 
Old 11-19-2012, 08:33 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
From http://docs.slackware.com/slackware:...e_your_network
Quote:
Note that WPA/WPA2 encryption is not configured just in /etc/rc.d/rc.inet1.conf, you will also need to edit /etc/wpa_supplicant.conf and add an encryption key there.
If you are using a GUI tool to handle network connections (e.g. NetworkManager), then it is suggested that you leave /etc/rc.d/rc.inet1.conf in the default state.
 
Old 11-19-2012, 08:48 AM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Quote:
Originally Posted by Laertiades View Post
I can connect to my ISP from a gui but not at boot or from command line.
In that case I would recommend using wicd or Network manager.
 
Old 11-19-2012, 09:44 AM   #4
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 59

Original Poster
Rep: Reputation: Disabled
Thank you for response

Thank you Allend and H_TeXMeX_H for your suggestions. My goal is to have the network interface created at boot and continue regardless of whether I am in a gui or not. I hope to first figure out how to make an unencrypted connection before I try to implement WPA/WPA2. Thanks again. Would appreciate any tips.
 
Old 11-19-2012, 10:23 AM   #5
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
wicd has a cli interface as well as a gui one.
 
Old 11-19-2012, 06:59 PM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
It is very likely that the device you are trying to connect to will only accept WPA/WPA2 connections. You will need to use 'wpa_supplicant' directly from the command line if you are using NetworkManager. The 'nmcli' command line tool does not handle the secrets needed for WPA/WPA2.
 
Old 11-20-2012, 11:22 AM   #7
lkraemer
Member
 
Registered: Aug 2008
Posts: 111

Rep: Reputation: 10
Laertiades,
What if you were to modify your file as follows:
Use ifconfig as root, to detect what ethernet port is available. Assume eth0:

Code:
USE_DHCP[0]="yes"
Then make the following changes to /etc/rc.d/rc.inet1.conf:
Code:
#WLAN_KEY[4]="[2] s:mysecretpassword key [2]"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set
#WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
Then do the following as root:
Code:
cat /etc/wpa_supplicant.conf
Most likely the file will contain nothing.

Code:
wpa_passphrase 'yourRouterESSID' 'yourpasswordforwpa2' >>/etc/wpa_supplicant.conf
Or, you could have used:
Code:
nano /etc/wpa_supplicant.conf
Then do the following as root:
Code:
/etc/rc.d/rc.inet1 wlan0_stop
/etc/rc.d/rc.inet1 wlan0_start
If your Ethernet cable is plugged into your Computer, you can start those communications with:
Code:
/etc/rc.d/rc.inet1 eth0_stop
/etc/rc.d/rc.inet1 eth0_start
That should work.

Larry
 
Old 11-20-2012, 03:10 PM   #8
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 350

Rep: Reputation: 56
Quote:
Originally Posted by Laertiades View Post
Any suggestions would be most welcome.
I've written down my config some time ago, maybe it gives you some inspiration.

http://www.frogge.de/pepper/p50ij/p50ij.html#wlan
 
Old 11-22-2012, 09:39 AM   #9
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 59

Original Poster
Rep: Reputation: Disabled
It was WPA

Thank you all for your help. You were right, my connection required WPA encryption.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to automatically connect to network on boot (DHCP) Economicus Linux - Networking 2 12-11-2011 06:43 AM
system is unable to establish network with other system Suman yuvraj Linux - Networking 3 03-27-2008 10:30 AM
system is unable to establish network with other system Suman yuvraj Linux - Newbie 1 03-25-2008 02:48 AM
Different default gateways for wlan depending on network (essid) using DHCP jimisola Suse/Novell 1 03-05-2006 12:49 AM
Urgent : How to find whether the Network Interface is DHCP enabled or not ? abha_shrimal Linux - Networking 3 12-15-2005 02:50 PM


All times are GMT -5. The time now is 01:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration