LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   unable to establish network interface at boot with wlan using dhcp (http://www.linuxquestions.org/questions/slackware-14/unable-to-establish-network-interface-at-boot-with-wlan-using-dhcp-4175437740/)

Laertiades 11-18-2012 09:47 PM

unable to establish network interface at boot with wlan using dhcp
 
3 Attachment(s)
I can connect to my ISP from a gui but not at boot or from command line. My efforts have centered around the configuration of rc.inet1.conf primarily using Alien Bob's network configuration guide. I must be missing some detail. I will attach outputs for iwconfig, /etc/rc.d/rc.inet1 wlan0_start, and iwconfig from within gui with connection established. Any suggestions would be most welcome. Thank you for your help. below is my rc.inet1.conf:

# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout. Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="yes"

# Example of how to configure a bridge:
# Note the added "BRNICS" variable which contains a space-separated list
# of the physical network interfaces you want to add to the bridge.
#IFNAME[0]="br0"
#BRNICS[0]="eth0"
#IPADDR[0]="192.168.0.1"
#NETMASK[0]="255.255.255.0"
#USE_DHCP[0]=""
#DHCP_HOSTNAME[0]=""

## Example config information for wlan0. Uncomment the lines you need and fill
## in your info. (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="Athens"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=PoplarHouse
WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="[2] s:mysecretpassword key [2]"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0" # Use a different interface name nstead of
# the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89" # Overrule the card's hardware MAC address
#MTU[4]="" # The default MTU is 1500, but you might need
# 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes" # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes" # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes" # If you don't want the DHCP server to change
# your default gateway
#DHCP_IPADDR[4]="" # Request a specific IP address from the DHCP
# server
#WLAN_ESSID[4]=DARKSTAR # Here, you can override _any_ parameter
# defined in rc.wireless.conf, by prepending
# 'WLAN_' to the parameter's name. Useful for
# those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
# Some drivers require a private ioctl to be
# set through the iwpriv command. If more than
# one is required, you can place them in the
# IWPRIV parameter (separated with the pipe (|)
# character, see the example).

allend 11-19-2012 07:33 AM

From http://docs.slackware.com/slackware:...e_your_network
Quote:

Note that WPA/WPA2 encryption is not configured just in /etc/rc.d/rc.inet1.conf, you will also need to edit /etc/wpa_supplicant.conf and add an encryption key there.
If you are using a GUI tool to handle network connections (e.g. NetworkManager), then it is suggested that you leave /etc/rc.d/rc.inet1.conf in the default state.

H_TeXMeX_H 11-19-2012 07:48 AM

Quote:

Originally Posted by Laertiades (Post 4832313)
I can connect to my ISP from a gui but not at boot or from command line.

In that case I would recommend using wicd or Network manager.

Laertiades 11-19-2012 08:44 AM

Thank you for response
 
Thank you Allend and H_TeXMeX_H for your suggestions. My goal is to have the network interface created at boot and continue regardless of whether I am in a gui or not. I hope to first figure out how to make an unencrypted connection before I try to implement WPA/WPA2. Thanks again. Would appreciate any tips.

H_TeXMeX_H 11-19-2012 09:23 AM

wicd has a cli interface as well as a gui one.

allend 11-19-2012 05:59 PM

It is very likely that the device you are trying to connect to will only accept WPA/WPA2 connections. You will need to use 'wpa_supplicant' directly from the command line if you are using NetworkManager. The 'nmcli' command line tool does not handle the secrets needed for WPA/WPA2.

lkraemer 11-20-2012 10:22 AM

Laertiades,
What if you were to modify your file as follows:
Use ifconfig as root, to detect what ethernet port is available. Assume eth0:

Code:

USE_DHCP[0]="yes"
Then make the following changes to /etc/rc.d/rc.inet1.conf:
Code:

#WLAN_KEY[4]="[2] s:mysecretpassword key [2]"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set
#WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"

Then do the following as root:
Code:

cat /etc/wpa_supplicant.conf
Most likely the file will contain nothing.

Code:

wpa_passphrase 'yourRouterESSID' 'yourpasswordforwpa2' >>/etc/wpa_supplicant.conf
Or, you could have used:
Code:

nano /etc/wpa_supplicant.conf
Then do the following as root:
Code:

/etc/rc.d/rc.inet1 wlan0_stop
/etc/rc.d/rc.inet1 wlan0_start

If your Ethernet cable is plugged into your Computer, you can start those communications with:
Code:

/etc/rc.d/rc.inet1 eth0_stop
/etc/rc.d/rc.inet1 eth0_start

That should work.

Larry

Martinus2u 11-20-2012 02:10 PM

Quote:

Originally Posted by Laertiades (Post 4832313)
Any suggestions would be most welcome.

I've written down my config some time ago, maybe it gives you some inspiration.

http://www.frogge.de/pepper/p50ij/p50ij.html#wlan

Laertiades 11-22-2012 08:39 AM

It was WPA
 
Thank you all for your help. You were right, my connection required WPA encryption.


All times are GMT -5. The time now is 04:45 AM.