LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-04-2013, 09:13 AM   #1
tonestyle
LQ Newbie
 
Registered: Sep 2007
Location: Connecticut
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
Unable to connect to wireless networks using a Netgear WN311B


I have been trying for over a week to get my Netgear WN311B wireless N card to work in Slackware 14. I tried using B43, Ndiswrapper and the Broadcom STA (wl) drivers, with mixed results but none of them worked.

At first, I was running with b43. I followed the instructions on http://linuxwireless.org/en/users/Drivers/b43 to install the firmware for the 3.2 kernel. My PCI-ID is 14e4:4329. I loaded up WICD and my AP popped up. I entered the password and it got hung up on the authentication process. So, I removed the encryption from my AP for testing purposes and it wouldn't get an IP address. I figured it was a driver issue at this point.

Next, I tried the Broadcom STA driver. iwconfig listed the wireless interface as eth1. Wicd didn't list any AP's.

Next I tried ndiswrapper. I downloaded the 64bit windows drivers. I was able to load the driver into ndiswrapper but iwconfig didn't list any wireless interfaces.

So I don't know where to go from here or if this card is even going to work. I read that people have been able to get this card working on other distros so I have some hope but if any one has any suggestions, it would be appreciated.
 
Old 03-04-2013, 12:42 PM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
b43 appears to be the correct driver for that card.

In order to use WICD, on my system, I had to edit /etc/rc.d/inet1.conf. Look at the section at the bottom for the fourth adapter. The first line of this section was commented out. I had to remove the # sign, so the name of the wireless card becomes wlan0, then I could use WICD to configure the adapter. With '#IFNAME[4]="wlan0"' the interface gets a name like eth1, and WICD seems to ignore the fact it is a wireless adapter.

I can't be sure there isn't some other problem, give the B43 driver another try with WICD and the # removed. ifconfig should then list the wireless card as wlan0.

Hope this helps.
 
Old 03-04-2013, 01:34 PM   #3
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, FreeBSD
Posts: 1,243

Rep: Reputation: 385Reputation: 385Reputation: 385Reputation: 385
The best driver to use is b43. You only need the firmware from wl driver. Ensure that you extract it with b43-fwcutter and put it in the right place which is (usually) /lib/firmware/b43

Then verify that the firmware is actually being picked up - otherwise trying to configure with wicd, networkmanager, etc is largely pointless. I usually do this as follows:


Code:
# modprobe -r b43 && modprobe b43 && sleep 5 && dmesg | tail
[ 1367.422831] Registered led device: b43-phy0::rx
[ 1367.422876] Registered led device: b43-phy0::assoc
[ 1367.422918] Registered led device: b43-phy0::radio
[ 1367.422947] Broadcom 43xx driver loaded [ Features: PMNLS ]
[ 1367.562051] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 1370.093071] wlan0: authenticate with 00:21:29:75:d2:ca (try 1)
[ 1370.102073] wlan0: authenticated
[ 1370.120056] wlan0: associate with 00:21:29:75:d2:ca (try 1)
[ 1370.122402] wlan0: RX AssocResp from 00:21:29:75:d2:ca (capab=0x431 status=0 aid=5)
[ 1370.122408] wlan0: associated
#
If the firmware is being loaded you can try to establish a connection. The name of the device should not matter - eth1 should work as well as wlan0


For wicd: just go into wicd preferences and enter "eth1" as the wireless interface and try to connect up.

If you still get bad password, you may need to enter the password hash instead of the plain text passphrase to discover this use the wpa_passphrase program e.g:

Code:
# wpa_passphrase "myessid" "mypassphrase"
network={
        ssid="myessid"
        #psk="mypassphrase"
        psk=2a264c5e1a4313cfd4d2d262882cb4587d02235411bd234987a12bf0b150821a
}
The hash directly after the "psk=" part can be copied into wicd's password field. You will need to fiddle with the authentication type, it's one of two which works - can't remember which.

Or you could save yourself all the bother and just use networkmanager. (enable the daemon and add the applet to your DE/WM's startup configuration).
 
Old 03-04-2013, 01:36 PM   #4
ahlr
LQ Newbie
 
Registered: Jun 2012
Posts: 12

Rep: Reputation: Disabled
Test whith networkmanager.

#chmod +x /etc/rc.d/rc.networkmanager
 
Old 03-04-2013, 04:59 PM   #5
tonestyle
LQ Newbie
 
Registered: Sep 2007
Location: Connecticut
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
@camorri, I had wlan0 uncommented, it made no difference.

@ caravel, This is the output of the command you asked me to try:

Code:
[  187.895729] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  187.895730] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  187.895732] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  187.895733] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  187.896868] b43-phy0: Broadcom 4321 WLAN found (core revision 11)
[  187.918171] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[  187.918324] Registered led device: b43-phy0::tx
[  187.918340] Registered led device: b43-phy0::rx
[  187.918406] Registered led device: b43-phy0::radio
[  187.918618] Broadcom 43xx driver loaded [ Features: PMNLS ]
Here is the output of iwconfig:

Code:
root@Misty:/etc/rc.d# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"MY_ESSID(edit)"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
          Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
eth0      no wireless extensions.
This is the wireless section of my rc.inet1.conf

Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=MY_ESSID(edit)
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"
This is an excerpt from dmesg:

Code:
[ 2050.193061] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 2050.232104] b43-phy0 warning: Forced PIO by use_pio module parameter. This should not be needed and will result in lower performance.
[ 2050.251141] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 2053.426056] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 2053.465097] b43-phy0 warning: Forced PIO by use_pio module parameter. This should not be needed and will result in lower performance.
[ 2053.484109] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 2053.675261] wlan0: authenticate with c0:3f:0e:be:10:ba (try 1)
[ 2053.676825] wlan0: authenticated
[ 2053.677165] wlan0: associate with c0:3f:0e:be:10:ba (try 1)
[ 2053.679621] wlan0: RX AssocResp from c0:3f:0e:be:10:ba (capab=0x411 status=0 aid=1)
[ 2053.679624] wlan0: associated
[ 2053.680819] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2057.205049] ieee80211 phy0: wlan0: No probe response from AP c0:3f:0e:be:10:ba after 500ms, disconnecting.
[ 2057.217151] cfg80211: Calling CRDA to update world regulatory domain
[ 2057.218355] cfg80211: World regulatory domain updated:
[ 2057.218357] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2057.218359] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2057.218361] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2057.218362] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2057.218364] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2057.218365] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2058.617204] wlan0: authenticate with c0:3f:0e:be:10:ba (try 1)
[ 2058.817053] wlan0: authenticate with c0:3f:0e:be:10:ba (try 2)
[ 2059.017047] wlan0: authenticate with c0:3f:0e:be:10:ba (try 3)
[ 2059.217039] wlan0: authentication with c0:3f:0e:be:10:ba timed out
[ 2064.482045] wlan0: no IPv6 routers present
-I decided to disable the wicd daemon to troubleshoot, to remove one more variable.
-The wpa_supplicant.conf file is just the output of wpa_passphrase.
-All of the above was done with the b43 driver.
-I also tried to enable rc.networkmanager, which changed nothing.
 
Old 03-05-2013, 05:16 AM   #6
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, FreeBSD
Posts: 1,243

Rep: Reputation: 385Reputation: 385Reputation: 385Reputation: 385
Can you next try the wl driver. Build it using the slackbuild: http://slackbuilds.org/repository/14.../broadcom-sta/

Ensure you blacklist the b43 module and related modules (as advised on the page).
 
Old 03-05-2013, 07:33 PM   #7
tonestyle
LQ Newbie
 
Registered: Sep 2007
Location: Connecticut
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
I already tried that, it didn't work. I ordered an Intel Centrino wireless card from Newegg last night. This card has linux support out of the box so I'm going to ditch this netgear card in favor of that one. Thank you all for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Unable to connect to wireless networks on HPG60 running Linux Mint 11 Micheil Linux - Wireless Networking 2 01-03-2012 07:35 AM
Network manager unable to connect to unsecured wireless - WPA networks fine :S phyre-x Ubuntu 8 05-16-2011 10:11 AM
Netgear WN311B wireless PCI adapter and wireless connection redfox6627 Linux - Hardware 5 04-24-2011 05:53 PM
Netgear WN311B wireless PCI adapter and wireless connection redfox6627 Linux - Networking 1 04-24-2011 02:33 PM
Unable to connect to the internet despite wireless networks being detected. RedClouds Linux - Newbie 1 08-11-2009 01:23 PM


All times are GMT -5. The time now is 12:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration