LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-16-2007, 05:25 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Unable To Configure Left-Hand Mouse With KDE 3.5.8 In Current


I've run into an oddball problem with Current.

I use some alternate partitions to mirror my 12.0 partitions and then from those partitions I install/update to Current for testing. I run a script to automate most of the process.

I have KDE configured for a left-handed mouse (swap buttons). When I update to Current I cannot configure KDE to swap the buttons for left-hand use. I can change the Control Center, but with no effect. I temporarily renamed the user .kde directory and created a new directory (temporarily suffering the idiotic bouncing cursor ), but to no avail. Therefore the problem does not seem to be a corrupt KDE configuration file.

I wiped the partitions, re-mirrored my test partitions, and updated everything in Current except X. No issues. I then exited X/KDE, updated all files in X, restarted X/KDE and the problem reappeared.

The problem seems to be X related. However, oddly, the problem does not occur in Xfce, even with all X files from Current installed.

In my 12.0 setup, several weeks ago I updated KDE to 3.5.8 from Current, and have experienced no similar problem.

Any thoughts about where to troubleshoot?
 
Old 12-16-2007, 05:58 PM   #2
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 59
I can confirm this, KDE 3.5.8 on current, xorg-server 1.4.0.90, mouse remains right-handed. XFCE swaps mouse handedness fine. I wonder if is another of those annoying Xorg 7.3/HAL bugs?

EDIT: spelling, etc.

Last edited by Eternal_Newbie; 12-16-2007 at 06:04 PM.
 
Old 12-16-2007, 06:11 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Thanks for confirming!

For additional information, I am not using HAL (older hardware --- very static box). Anybody else have an idea?
 
Old 01-21-2008, 02:20 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
I realize that the Current branch development has slowed the past few weeks, but this past weekend I tried another testing update of Current. The same problem exists with being unable to configure the KDE mouse buttons for left-handed use. The problem does not appear until I update the x/* tree of files and the problem does not exist in Xfce. A fresh copy of the user .kde folder does not solve the problem.

So there appears to be a conflict between KDE 3.5.8 and X 7.3.

I informed PV several weeks ago, although I have no clue where the root cause might be.

I'm adding this post merely to bump the thread in case others experience this same problem.
 
Old 02-21-2008, 08:31 PM   #5
cdrigby
LQ Newbie
 
Registered: Jul 2006
Location: Singapore
Distribution: Ubuntu, ArchLinux, OpenBSD
Posts: 2

Rep: Reputation: 0
Work-around for left-handed mouses in KDE

Greetings All,

I ran across this thread while searching for a solution to the same problem while setting up KDE 3.5.8 under Arch Linux i686. From bits of half-remember X-lore, I cobbled together a work-around:

  1. I created the file ~/.kde/Autostart/LeftHandMouse
  2. Its contents:
    Code:
    #!/bin/sh
    # This command will swap the buttons of ALL mouses under KDE
    
    xmodmap -e "pointer = 3 2 1"
  3. I made it executable:
    Code:
    chmod u+x ~/.kde/Autostart/LeftHandMouse

Then I logged out, restarted Xorg for good measure, and my USB mouse buttons behaved as desired. This is a pretty generic work-around, so it should work for Slackware and other distros, possibly even *BSD if its KDE setup is equivalent.

I also found an explanation of why things work the way they do on the KDE bugtraq list. I cannot post URLs here (golly - my first post!), but go to bugs.kde.org and search for bug 129045 if you are interested.

It appears to be one of those "it's not a bug - it's a feature" situations. My knowledge of Xorg is rather cursory, and my attempts to fiddle with xorg.conf did not yield useful results. I did not try using another mouse to see if I could recreate the situation described in in that bug listing.

Regards
CDRigby
 
Old 02-24-2008, 01:08 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
I tested the latest Current branch as of Thursday Feb 21 (I have not updated with the changes of this past weekend). No more left-hand mouse issues. Perhaps the fix was in KDE 3.5.9. Perhaps something else. I don't know, but all is well.
 
Old 02-26-2008, 07:40 PM   #7
cdrigby
LQ Newbie
 
Registered: Jul 2006
Location: Singapore
Distribution: Ubuntu, ArchLinux, OpenBSD
Posts: 2

Rep: Reputation: 0
Hello Woodsman,

I just checked - my ArchLinux installation is currently at 3.5.8-3. I'll see if the situation changes once the update propagates through to my system.

Thanks for the response.

Cheers
CDR
 
Old 05-09-2008, 11:51 PM   #8
Kerrysl
Member
 
Registered: Oct 2005
Location: Sydney, Australia
Distribution: Fedora 8, (previously FC6, FC5, FC4, FC3, & Mandrake 10)
Posts: 70

Rep: Reputation: 15
I had similar problems with none of the GUI tools correctly setting left handedness of the mouse. I have a Dell laptop 6400/E105 and using the standard Dell mouse. As reported by others Gnome seems to be able to set correct values but KDE does not. I think GNOME intercepts the signals being sent to X server and converts them. Anyway I have found for me on KDE 3.5.9-5.fc8 on obviously Fedora 8 I have found that modifying the Xorg.conf file solves the problem.
One precaution I would suggest is make a copy of Xorg.conf both before and after making the changes suggested below because there are several GUI tools that will write to Xorg.conf and may undo your changes. Here is my Xorg.conf file take note of the USB mouse line in the ServerLayout section and the InputDevice section for "USBMouse"
Quote:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
InputDevice "USB Mouse" "AlwaysCore"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "ButtonMapping" "3 2 1 4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
So far this works for me. Hope it works for you as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSe 9.3 Left hand mouse not working botmund Suse/Novell 1 08-11-2005 03:51 AM
xf86config: how to set mouse to left hand side? ronaldv Linux - Hardware 2 01-11-2005 02:05 AM
I can't set left hand mouse in kde tygk Linux - Software 11 11-25-2004 08:37 AM
I can't set left hand mouse in kde tygk Mandriva 1 11-24-2004 04:58 AM
Mouse goes crazy when switching to left hand mode in FC2 speedbird Fedora 1 06-27-2004 06:28 PM


All times are GMT -5. The time now is 09:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration