LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-18-2013, 01:49 AM   #31
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,313

Rep: Reputation: Disabled

Quote:
Originally Posted by info.latawaz View Post
Eric, I am not using wpa_supplicant at the moment. I am using nm-applet to start the network manager
NetworkManager will use wpa_supplicant eventually to make the encrypted connection. It should accept the 63-character passphrase without surrounding quotes.

You could try some WPA troubleshooting by running "wpa_cli" as root after you enter the passphrase into nm-applet. Then try entering interactive commands like "status" or "reassociate" or "level N" with N an increasing number, to see if you can get any meaningful information out of the association process.

Eric
 
Old 06-18-2013, 12:41 PM   #32
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
I think I have figured out the problem. It is probably with the MAC address. The wifi connection I am trying to connect with has MAC filter enabled with 3 MAC's in that list which it allows to connect to it.

In Linux, after ifconfig wlan0, I found that my MAC address for the wireless card is different.

The first wifi connection didn't have MAC filtering, so it connected with ease. The second wifi however has this filter.

I created a new profile and changed the cloned MAC address field to original address which is allowed but it is not connecting.

Is there a way to change the MAC address to the original?

What do you suggest.
 
Old 06-18-2013, 12:49 PM   #33
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,274
Blog Entries: 1

Rep: Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056
ifconfig wlan0 down
ifconfig wlan0 hw ether 11:22:33:44:55:66
ifconfig wlan0 up
 
Old 06-18-2013, 01:57 PM   #34
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
Post

Quote:
Originally Posted by szboardstretcher View Post
ifconfig wlan0 down
ifconfig wlan0 hw ether 11:22:33:44:55:66
ifconfig wlan0 up
This really does the trick and it introduced other problems. Although I was able to change it for a few seconds to the original MAC by typing, while connecting, it could not. Not even with my first wifi.

Starting nm-applet showed severe error, unable to start and all. I stopped the connection tries, stopped the networkmanager, exited the shell, opened a new shell. Then I clicked on the icon of wifi and tried to connect with my first wifi, it connected, but the MAC again was the previous one.

One fellow linux user too is facing this issue, http://forums.devshed.com/networking...ess-85720.html

I think I'll have to add this MAC to the filter and then check.
 
Old 06-19-2013, 12:37 AM   #35
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
It worked after removing MAC filter. Thanks everyone for their help and support.

But this confuses me. How can the same network adapter have different MAC address when it is used as dual-boot? As in different MAC reported in Linux and different MAC reported in windows.
 
Old 06-19-2013, 03:27 AM   #36
torimus
Member
 
Registered: Apr 2013
Distribution: Slackware
Posts: 81

Rep: Reputation: Disabled
Quote:
Originally Posted by info.latawaz View Post
It worked after removing MAC filter. Thanks everyone for their help and support.

But this confuses me. How can the same network adapter have different MAC address when it is used as dual-boot? As in different MAC reported in Linux and different MAC reported in windows.
either in windows or in linux the link(mac) address has to be set
 
Old 06-19-2013, 07:30 AM   #37
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by torimus View Post
either in windows or in linux the link(mac) address has to be set
I see. But when I started using windows, I didn't set the MAC at all. I used to think that MAC address for an adapter is unique. Are we free to choose whichever address we want then?
 
  


Reply

Tags
b43, b43-legacy, networkmanager, slackware 14, wifi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] WiFi is connected but unable to access internet in RHEL 6 and Fedora 17 aniruddha.jagdale Linux - Wireless Networking 6 04-28-2013 12:30 PM
unable to access wifi INTERNET connection in ubuntu 11.04 naveen_patil Linux - Newbie 5 02-11-2012 06:49 AM
Sporadic internet access on unencrypted wifi FogSwimmer Linux - Wireless Networking 0 09-14-2007 09:23 PM
WIFI WLAN / Cannot access internet but can access the router configuration page?SUSE thomas939 Linux - Wireless Networking 12 12-13-2005 10:28 AM
Internet access through router and wifi connection caudalie Linux - Wireless Networking 3 01-22-2004 03:51 PM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration