LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-14-2013, 04:14 AM   #16
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 150

Rep: Reputation: 23

allend is right.
Build and installpkg the b43-fwcutter before building the b43-firmware.
It's a dependency.

Then you can test it as superuser by running:
sbin/modprobe b43

Hopefully thats all you need to do. If that works you can make the driver load automatically:
append /etc/rc.d/rc.modules-3.2.29 (or rc.modules-3.2.45 if you already upgraded your kernel)
#Wifi Driver
/sbin/modprobe b43

If it doesn't work post back here and you may just have to blacklist something.
I've had Broadcomms load wl after installing the b43.
If it does you can always check it as su:
modprobe -r wl
modprobe b43

Last edited by nick_th_fury; 06-14-2013 at 04:17 AM.
 
Old 06-14-2013, 06:42 AM   #17
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by nick_th_fury View Post
allend is right.
Build and installpkg the b43-fwcutter before building the b43-firmware.
It's a dependency.

Then you can test it as superuser by running:
sbin/modprobe b43

Hopefully thats all you need to do. If that works you can make the driver load automatically:
append /etc/rc.d/rc.modules-3.2.29 (or rc.modules-3.2.45 if you already upgraded your kernel)
#Wifi Driver
/sbin/modprobe b43

If it doesn't work post back here and you may just have to blacklist something.
I've had Broadcomms load wl after installing the b43.
If it does you can always check it as su:
modprobe -r wl
modprobe b43
I have been going through allend's links and instructions on installing them. It's confusing.

You are suggesting me to build and installpkg b43-fwcutter and building the b43-firmware as well. Please guide me as to how to do this. New to linux.

was unable to execute the .SlackBuild file. Unable to add executable permission to file with that extension. What to do?

Last edited by info.latawaz; 06-14-2013 at 07:19 AM.
 
Old 06-14-2013, 09:32 AM   #18
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Passing the SlackBuilds test is a rite of passage to becoming a Slackware user.
As it is a Friday night and I am half cut, here is my attempt at an absolute beginners guide. If it passes the newbie test, it may become a SlackDocs page.
Yeah, I know it looks intimidating, but you asked! The typing involved can be significantly reduced by using bash completion where you type the first few letters of a filename and then hit TAB.

The first four steps can be done from any computer with internet access.
1. From http://slackbuilds.org/repository/14.../b43-fwcutter/ download b43-fwcutter.tar.gz
2. From http://slackbuilds.org/repository/14.../b43-fwcutter/ download b43-fwcutter-015.tar.bz2
3. From http://slackbuilds.org/repository/14.../b43-firmware/ download b43-firmware.tar.gz
4. From http://slackbuilds.org/repository/14.../b43-firmware/ download broadcom-wl-5.100.138.tar.bz2
The next steps need to be done on your Slackware install.
5. Copy b43-fwcutter.tar.gz to a directory of your choice (here /home/user/Desktop/srcpkgs/b43-fwcutter)
6. Copy b43-firmware.tar.gz to a directory of your choice (here /home/user/Desktop/srcpkgs/b43-firmware)
The next steps are done in a terminal window. The commands required are between single quotes.
7. Change to the directory containing the b43-fwcutter.tar.gz file.
'cd /home/user/Desktop/srcpkgs/b43-fwcutter'
8. Extract the compressed download file.
'tar xvf b43-fwcutter.tar.gz'
9. Time out for a sip. :}
10. Change to the b43-fwcutter subdirectory that was created.
'cd ./b43-fwcutter'
11. Copy the b43-fwcutter-015.tar.bz2 file. <sourcepath> needs to be specified.
'cp <sourcepath>/b43-fwcutter-015.tar.bz2 .'
12. Change to the directory containing the b43-firmware.tar.gz file.
'cd /home/user/Desktop/srcpkgs/b43-firmware'
13. Extract the compressed download file.
'tar xvf b43-firmware.tar.gz'
14. Change to the b43-fwcutter subdirectory that was created.
'cd ./b43-firmware'
15. Copy the broadcom-wl-5.100.138.tar.bz2 file. <sourcepath> needs to be specified.
'cp <sourcepath>/broadcom-wl-5.100.138.tar.bz2 .'
16. In a terminal window, become root. (NB- Use 'su -' as SlackBuilds should always use the root environment)
'su -'
17. Change to the directory containing the b43-fwcutter-015.tar.bz2 file.
'cd /home/user/Desktop/srcpkgs/b43-fwcutter/b43-fwcutter'
18. Run the SlackBuild script. (It is already set executable)
'./b43-fwcutter.SlackBuild'
19. Install the resulting package. (The name will be different on a 32-bit system)
'upgradepkg --install-new /tmp/b43-fwcutter-015-x86_64-1_SBo.tgz'
20. Change to the directory containing the broadcom-wl-5.100.138.tar.bz2 file.
'cd /home/user/Desktop/srcpkgs/b43-fwcutter/b43-fwcutter'
21. Run the SlackBuild script. (It is already set executable)
'./b43-firmware.SlackBuild'
22. Install the resulting package
'upgradepkg --install-new /tmp/b43-firmware-5.100.138-fw-1_SBo.tgz'

Last edited by allend; 06-14-2013 at 09:38 AM.
 
Old 06-14-2013, 09:36 AM   #19
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
Thumbs up

allend, thank you so much for these steps. Going to try these on and will let you know the results.
 
Old 06-14-2013, 11:14 AM   #20
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
I followed all the steps provided by allend with success. However, I still think something is wrong. Reason being, I am seeing the same stuff as I was previously seeing. Attaching the screenshot.

sbin/modprobe b43 doesn't exist.
Attached Images
File Type: jpeg still.jpeg (29.7 KB, 20 views)

Last edited by info.latawaz; 06-14-2013 at 11:16 AM.
 
Old 06-14-2013, 12:04 PM   #21
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Your screenshot still.jpeg shows that 'modprobe b43' executed without error. Good!
Configuring wireless connections in Slackware is most easily done by using NetworkManager or wicd from a GUI. You say that you want to use the command line, which is fine, but how about crawling before walking?
At this point I advise that you return /etc/rc.d/rc.inet1.conf to the default (copy from the install media if need be or run 'netconfig' and set localhost). Check that only one of /etc/rc.d/rc.networkmanager or /etc/rc.d/rc.wicd is set executable for either NetworkManager or wicd depending on preference. Also check that /etc/rc.d/rc.wireless is not executable. Reboot your system to ensure that all is initialised from cold. Check that your wireless interface is detected with '/sbin/ifconfig -a'. Start a window manager (KDE supplies a NetworkManager widget and wicd widget). Use one of those to configure a connection.

Once you have have a connection, it can be administered from the command line using 'nmcli' (but not for WPA2) or 'wicd-client' (a much better command line solution).

If you want to connect to a WPA2 access point from the commandline without wicd then you must use 'wpa_supplicant' directly. This requires editing /etc/wpa_supplicant.conf with details of your connection. See 'man wpa_supplicant.conf' for more details, and look at the example file referenced therein.
 
Old 06-14-2013, 03:10 PM   #22
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 150

Rep: Reputation: 23
fyi, the modprobe command loads a module into the running kernel. kind of like temporarily installing a driver in windows. So Congrats. that's about as hard as it gets. Understanding will come with time and reading.
once you follow allend's instructions on running netconfig, you should be able to execute modprobe 43 and then wicd or nm will most likely show your wireless.

I recommend setting it up in the GUI app, then go back and read those config files. I learned howto command line setup my LAN & wifi by reading working examples.
 
Old 06-15-2013, 11:23 PM   #23
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Rep: Reputation: 39
I'm sorry if this maybe unrelated but I have an experience with my laptop having its wifi turned off by default when in Linux. I have to press something like Fn+F5 to activate it (then use wicd/network manager to setup it up).

If not related, kindly ignore this post.

Thanks
 
Old 06-17-2013, 08:59 AM   #24
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
Success!

Good news guys. I am now able to connect to one of my wifis using 'networkmanager'. Now I have to test this with my second wifi connection. Once that is done, I would also like to try 'wicd' and just to know which one is better.

Now comes the next part. 'modprobe b43' must be done manually. What should I do so that this is automatically run at the startup. As in which file should I add this in?

Also, since I am able to connect and you guys are telling me to monitor whats going on in the back, I would like to understand how. I would like to understand and know the commands that nm-applet is running behind the scenes since I am genuinely interested in commandline.
 
Old 06-17-2013, 09:21 AM   #25
schneidz
Senior Member
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 3,849

Rep: Reputation: 592Reputation: 592Reputation: 592Reputation: 592Reputation: 592Reputation: 592
i would put the startup command in /etc/rc.local

or you can put an @reboot declaritive in the users crontab.

else you can add it to the .bash_profile but it will only run when that specific user logs in.

i think the basic commands will be something like
Code:
ifconfig <wifi-adapter> up
iwconfig <wifi-adapter> essid <router-ssid>
wpa-supplicant # new to me
dhcp <wifi-adapter>

Last edited by schneidz; 06-17-2013 at 09:25 AM.
 
Old 06-17-2013, 10:15 AM   #26
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Quote:
Now comes the next part. 'modprobe b43' must be done manually. What should I do so that this is automatically run at the startup. As in which file should I add this in?
I suggest adding that to /etc/rc.d/rc.modules-$(uname -r).

To use my wifi connection to my home AP with WPA2 from the command line, I use
1. wpa_supplicant -B -c/etc/wpa_supplicant.conf -iwlan0 -Dwext # wpa_supplicant.conf has been configured previously
2. dhcpcd wlan0 # My modem/router is set as a DHCP server for my home LAN.
3. /etc/rc.d/rc.firewall_wlan0 # This is my firewall script when using the wireless interface

If I have been using networkmanager previously, then I do this before the above
1. /etc/rc.d/rc.networkmanager stop # kill networkmanager
2. pkill wpa_supplicant # kill the wpa_supplicant instance started by network manager
3. pkill dhcpcd # kill the dhcpcd instance started by network manager
4. rfkill list # Check that wireless interface is not blocked. 'rfkill unblock wlan' to unblock

All the above is done with root privileges.
YMMV
 
Old 06-17-2013, 10:21 AM   #27
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,031

Rep: Reputation: 160Reputation: 160
As per your "behind-the-scenes" request, invoke nm-applet from a terminal/console so that you can view its output (you may also want to redirect/tee stdout to a file....)

cheers,
 
Old 06-17-2013, 03:22 PM   #28
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
I was able to connect with one of my wifi. This wifi has broadcast enabled and uses WPA2-Personal encryption with key length of 8.

However, the next wifi that I have, it is configured in the below ways:
* The broadcast is disabled.
* WPA2-Personal encryption standard with key length of 63 characters including some special characters(no spaces though)
* MAC filtering enabled.

While I am able to connect to the first wifi, the second wifi is giving me a hard time.
I have taken care of the following:
* Ensured that the cloned MAC is the same as the one that is allowed in the filter of the router.
* ESSID has the same name as that of the AP.
* BSSID has the same MAC address as that of the AP.

Should this be sufficient? If yes, then why is it not accepting the password. I get the below error.
Quote:
** Message: No keyring secrets found for point1/802-11-wireless-security; asking user.
I am able to connect to the same AP through windows and with the same password.

I read at some place that I must enable broadcast for successful connection.

What are your suggestions?
 
Old 06-17-2013, 03:36 PM   #29
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,194

Rep: Reputation: Disabled
The only thing I can think of is that in your WPA configuration you are confusing the 64 hexadecimal digits long WPA key with the WPA passphrase which can be anything between 8 and 63 printable ASCII characters.
In wpa_supplicant.conf the 8-63 character passphrase must be enclosed in double quotes "" while the 64-hex-digits key must not be enclosed in quotes.

Eric
 
Old 06-18-2013, 12:21 AM   #30
info.latawaz
Member
 
Registered: Jun 2013
Location: India
Posts: 44

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
The only thing I can think of is that in your WPA configuration you are confusing the 64 hexadecimal digits long WPA key with the WPA passphrase which can be anything between 8 and 63 printable ASCII characters.
In wpa_supplicant.conf the 8-63 character passphrase must be enclosed in double quotes "" while the 64-hex-digits key must not be enclosed in quotes.
Eric, I am not using wpa_supplicant at the moment. I am using nm-applet to start the network manager and then from there, I am configuring it to connect to my wifi which has 63 character passphrase. I have tried enclosing this passphrase in double quotes when nm asks for password but with no luck. Still not able to connect it to the second wifi.

Update
******
Enabled broadcasting, still i am unable to connect to it. What's going on? Can it connect to wifi only configured with a few passphrase characters?

Last edited by info.latawaz; 06-18-2013 at 12:47 AM.
 
  


Reply

Tags
b43, b43-legacy, networkmanager, slackware 14, wifi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] WiFi is connected but unable to access internet in RHEL 6 and Fedora 17 aniruddha.jagdale Linux - Wireless Networking 6 04-28-2013 12:30 PM
unable to access wifi INTERNET connection in ubuntu 11.04 naveen_patil Linux - Newbie 5 02-11-2012 06:49 AM
Sporadic internet access on unencrypted wifi FogSwimmer Linux - Wireless Networking 0 09-14-2007 09:23 PM
WIFI WLAN / Cannot access internet but can access the router configuration page?SUSE thomas939 Linux - Wireless Networking 12 12-13-2005 10:28 AM
Internet access through router and wifi connection caudalie Linux - Wireless Networking 3 01-22-2004 03:51 PM


All times are GMT -5. The time now is 08:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration