LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   umask ignored by GUI applications (http://www.linuxquestions.org/questions/slackware-14/umask-ignored-by-gui-applications-4175448240/)

cyberpatrol 02-01-2013 04:30 PM

umask ignored by GUI applications
 
And I've got another question that is likely to be related to Slackware, too.

I want to keep the default umask 022 global and for root, but want to set umask 077 for unprivileged users. So I set umask 077 in the users' ~/.bashrc. Every console application respects this umask, but not the GUI applications like LibreOffice, Leafpad, etc. Those GUI applications still save new files with umask 022.

So my question is: Where do I have to set umask for those applications or what do I have to change that those applications respect the umask from ~/.bashrc, too?

/etc/profile and /etc/login.defs are out of the question, because they set the global umask, and aren't respected by those GUI applications, too.

Kustom42 02-01-2013 05:02 PM

Are you exporting umask as an environment variable or are you just setting it? If you are just setting it export it so it is an environment variable. Also, .bashrc does not get sourced when xwindows is started unless a session is opened to the terminal and then a startx is run.

You can use your ~/.XDefaults file and set your defaults or you can play with your /etc/x11/xinit/xinitrc to have it source the .bashrc or .bash_profile when started.

cyberpatrol 02-01-2013 06:00 PM

I just added the line "umask 077" to my ~/.bashrc. So I don't export it as an environment variable.

But the advice about /etc/x11/xinit/xinitrc helped, even if it was in fact /etc/xdg/xfce4/xinitrc into which I had to add the line ". $HOME/.bashrc". But now it works. Now the files are created with the right permissions by the GUI applications.

Thanks.


All times are GMT -5. The time now is 12:18 PM.