LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Ugly QT in some apps (http://www.linuxquestions.org/questions/slackware-14/ugly-qt-in-some-apps-4175430827/)

qweasd 10-06-2012 08:05 AM

Ugly QT in some apps
 
1 Attachment(s)
After upgrading 13.37 -> 14.0 I have weird ugly QT interface in transmission-qt when in openbox-session. Other apps, like dolphin and konsole, are fine. The same transmission looks correct when I log in in KDE from the same account. I erased and re-created all KDE settings, and rebuilt transmission, but it did nothing.

Also tried playing with qtconfig, which seems to be buggy, and it seems to have some effect, but there is no option for the default decoration, as in screenshot.

Alien Bob 10-06-2012 08:14 AM

Looks like the first screenshot is using a GTK-2 widget set while the second screenshot is actually using Qt.

Eric

qweasd 10-06-2012 08:15 AM

Quote:

Originally Posted by Alien Bob (Post 4798756)
Looks like the first screenshot is using a GTK-2 widget set while the second screenshot is actually using Qt.

Eric

That's what I thought initially too, but transmission-gtk shows a different, although also incorrect, gtk theme. Moreover, the settings in qtconfig do affect the way transmission-qt looks, although they don't fix the ugly.

dugan 10-06-2012 11:07 AM

symlink /usr/lib64/kde4/plugins/styles to /usr/lib64/qt/plugins/styles.

Source: https://wiki.archlinux.org/index.php...window_manager

kikinovak 10-06-2012 11:21 AM

That's not Qt, that's GTK3. Slackware 14.0 ships with both GTK2 and GTK3. Now if Transmission detects both, it opts for GTK3 as default. Up to Transmission 2.60 - which is the version I use - you can add the following option to ./configure:

Code:

--with-gtk=2
I don't know if you use SBo's SlackBuild. If that is the case, you can simply comment out the part responsible for building the Qt interface, add the option above and only build the GTK interface.

Starting with Transmission 2.61, you won't be able to build against GTK2 anymore.

Cheers,

Niki

qweasd 10-06-2012 07:44 PM

Quote:

Originally Posted by dugan (Post 4798859)
symlink /usr/lib64/kde4/plugins/styles to /usr/lib64/qt/plugins/styles.

Source: https://wiki.archlinux.org/index.php...window_manager

This is it :) I went with export QT_PLUGIN_PATH=/usr/lib64/kde4/plugins in ~/.bash_profile

Once again, I am blown away by the quality of this forum :cool:


All times are GMT -5. The time now is 01:02 PM.