LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   udev start in current provokes kernel crash because (wrong?) boot option (http://www.linuxquestions.org/questions/slackware-14/udev-start-in-current-provokes-kernel-crash-because-wrong-boot-option-852211/)

bonaire 12-24-2010 09:26 AM

udev start in current provokes kernel crash because (wrong?) boot option
 
I switched today to slackware-current on one of my desktops to play with it and ran directly into a problem.

Since ages my lilo.conf has two entries for slackware. One for runlevel 3 and one for runlevel 4.

Code:

lba32
boot = /dev/sda1
compact

bitmap = /boot/slack.bmp
bmp-colors = 255,0,255,0,255,0
bmp-table = 60,6,1,16
bmp-timer = 65,27,0,255

append=" vt.default_utf8=1"
prompt
timeout = 50
vga = 794

image = /boot/vmlinuz
  root = /dev/mapper/crypt-vg-root
  initrd = /boot/initrd.gz
  label = Slackware
  append = "init 4"
  read-only

image = /boot/vmlinuz
  root = /dev/mapper/crypt-vg-root
  initrd = /boot/initrd.gz
  label = Slackware-r3
  append = "init 3"
  read-only

Since the upgrade this is no more possible because I get a kernel panic as soon as udevadm trigger is called. The stack says something about an unknown boot option. Because that i removed the append lines from my lilo.conf and i was able to boot the system. The crash happens when udev is called from within the ramdisk and afterwards. I tried both.

My question is now. Is this a bug in udev or expected? I have this setup since at least 5 years and had never problems with that. What do I have to do to be able to select the runlevel at boot time?

jamesf 12-24-2010 10:13 AM

The init parameter should be used to specifiy the init program, like this
Code:

init=/sbin/init
or this
Code:

init=/bin/bash
. Try specifying the runlevel alone like this
Code:

addappend = " 3"
The addapend syntax adds the section-specific data to the global "append" you have, above. So, you'd use one append = " vt.default_utf8=1" in a global area (as you have) and then addapend = 3 or addappend = 4 in the appropriate section.

adamk75 12-24-2010 10:13 AM

You don't need 'init 3' and/or 'init 4'. Just '3' or '4'. Give that a try.

Adam

bonaire 12-24-2010 10:38 AM

Thanks adamk75 and jamesf,

Code:

image = /boot/vmlinuz
  root = /dev/mapper/crypt-vg-root
  initrd = /boot/initrd.gz
  label = Slackware-r3
  append = " 3"
  read-only

Does the job. But strange that it worked without any issue before. I learned something :)


All times are GMT -5. The time now is 11:05 PM.