LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2005, 08:09 PM   #1
glennt11
LQ Newbie
 
Registered: Aug 2004
Location: NY
Distribution: Ubuntu,Red Hat,Centos 5
Posts: 29

Rep: Reputation: 0
udev not making /dev/sound right in Slackware 10


Good Evening to all,
I don't know what udev does when it first loads during boot. My sound is found fine, the modules are loaded fine, and playing sound through xmms, Mplayer, and Xine is fine(looking at the properties, it looks like they all go directly to the hardware...but back to my problem). I went to play Kohan: Immortal Sovereigns, and it plays, but without sound. Checking the readme, I found out that it looks for /dev/dsp to play sound, which is nonexistent on my machine. The closest I came while googling for an answer(2 days so far) is this:

Not enough posts to post the url

Somehow udev creates my /dev/sound directory as a device, and I did what he did, reinitializing the udevd, and just like him it created my /dev/sound/* nodes and the symlinks to /dev/dsp, but it broke my /proc permissions. If I do it while running a window manager(Gnome, fluxbox so far) I can get the game running with sound, but I'm unable to use any console apps any more. So I have to reboot before I'm able to use my programs again( I am slowly learning to love console apps..)

By the way, trying to cat a file to /dev/sound does not work.

Oh and one more thing, I'm running Slackware 10.0 with kernel 2.6.10 and my audio card is a SoundBlaster Audigy 2
 
Old 01-15-2005, 08:29 PM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well..ther was a thread about that just a week ago or so...
when you run " #/etc/rc.d/rc.udev " , ( after you booted ) ,the devices will appear.

but it's not as it should be ? ( and that's a Q )

egag
 
Old 01-16-2005, 11:12 AM   #3
glennt11
LQ Newbie
 
Registered: Aug 2004
Location: NY
Distribution: Ubuntu,Red Hat,Centos 5
Posts: 29

Original Poster
Rep: Reputation: 0
I'm sorry I forgot to write that in my post. Yes, when I do /etc/rc.d/rc.udev it creates /dev/sound as a directory with all the nodes in it, but my /proc permissions don't work any longer afterwards. Trying to access a console app or virtual terminal spits back an error saying something along the lines of:

rxvt: can't open pseudo-tty
rxvt: can't open

And it's the same for any other console apps I try until I reboot, turning /dev/sound into a node again.
From what I remember of it, the /proc permissions can't be re-initialized without a reboot. So in closing, no, doing /etc/rc.d/rc.udev at a command prompt fixes my problem, but causes others.
 
Old 01-16-2005, 05:26 PM   #4
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Rep: Reputation: 30
Actually, it's /dev/pts that gets screwed (if you dealing with the same issue I posted about). That's why you can't spawn a console. Just remount it after you run the udev script.

I think I may have found the solution to the overall issue. I am testing it right now. I have two systems that are identical, but one has the sound bug with udev and the other does not. Same distro, same kernel version, etc. The difference is the one without the bug has soundcore compiled into the kernel, and NOT as a module. Soundcore is the flaw. According to udev's rules, when it encounters the soundcore module, it creates /dev/sound, and then all of the OSS devices pile up on it. I am recompiling and I will post the outcome.

--Akshun J
 
Old 01-16-2005, 08:00 PM   #5
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Rep: Reputation: 30
My fix works! Recompiled 2.6.10, and compiled soundcore (Basically, the option that says your computer is capable of making sounds, NOT the ALSA or OSS options) directly into the kernel. On next boot, all the alsa-oss sound devices (/dev/dsp, etc) got created correctly. Hope this helps someone!

--Akshun J
 
Old 01-16-2005, 11:23 PM   #6
glennt11
LQ Newbie
 
Registered: Aug 2004
Location: NY
Distribution: Ubuntu,Red Hat,Centos 5
Posts: 29

Original Poster
Rep: Reputation: 0
Talking

Yes, that was the fix i needed for this. I thank you akshunj and egag for helping to solve it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware 10.1 sound dev issues jocool5 Linux - Laptop and Netbook 2 08-19-2005 10:26 AM
/dev/sound/* permissions reset using udev ratman96 Linux - General 0 05-04-2005 01:13 PM
Slackware 10 Creative Soundblaster making weird sound. zwyrbla Slackware 2 09-18-2004 06:05 PM
how to tell udev to make a dev jimdaworm Slackware 10 08-13-2004 07:12 AM
How to use udev to manage /dev on Slackware? JWhitaker1321 Slackware 1 03-13-2004 06:44 PM


All times are GMT -5. The time now is 04:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration