LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2010, 06:29 AM   #1
dguy
Member
 
Registered: Dec 2001
Location: Beckwith Township, Ontario, Canada
Distribution: Slackware 14.0, Slackware-64 14.1
Posts: 115

Rep: Reputation: 16
udev not creating usb/hiddev* nodes


Are there any prerequisites which much be met in order for udev to create /dev/usb/hiddev* nodes?

I have two Slack 13.0 systems, each connected to a APC UPS via USB, one of which creates a hiddev0 node and the other doesn't. apcupsd can't find the UPS unless this node is present.

The "working" system has been stable in its current configuration for so long that I honestly can't remember if I had to tweak anything in this regard. I've verified that it doesn't use any local udev rules to create this node, and to the best of my knowledge there are no external scripts or processes which would create it either.

The non-working system has a similar configuration - no local rules and/or scripts which touch usb devices or nodes.

I'm stumped, to put it plainly.

Any suggestions?
 
Old 12-03-2010, 06:47 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,528
Blog Entries: 27

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Are both kernels identical? udev will only create the files when the kernel reports finding the devices (the information may come via HAL) so any link in that chain could be causing the problem. One possibility is that the system that does not create the /dev/usb/hiddev* files does not have the necessary drivers or modules so the kernel does not identify the device. Have you compared the /var/log/messages and dmesg files on both systems? The hiddev device should be reported during USB bus probing.
 
1 members found this post helpful.
Old 12-03-2010, 06:55 AM   #3
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,458

Rep: Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941
More information here: http://www.apcupsd.com/manual/manual...ion-and-driver.
 
1 members found this post helpful.
Old 12-03-2010, 07:12 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Is the hardware platform the same for the two systems?
It may be that the non-working system needs the ohci-hcd kernel module rather than the default uhci-hcd.
Try 'modprobe -r uhci-hcd' then 'modprobe ohci-hcd'. If it works then change /etc/modprobe.d/usb-controller.conf to make it permanent.
 
Old 12-03-2010, 04:36 PM   #5
dguy
Member
 
Registered: Dec 2001
Location: Beckwith Township, Ontario, Canada
Distribution: Slackware 14.0, Slackware-64 14.1
Posts: 115

Original Poster
Rep: Reputation: 16
[much troubleshooting & exploring later]

I had previous read through the Verify Device Detection and Driver section of the apcupsd manual posted above, but I missed a key item. The non-working system does not have the hiddev driver.

I run a custom build of 2.6.29.6 on the working system, where USB_HIDDEV is enabled. The canned "huge" kernel on the non-working system has USB_HIDDEV disabled. Apparently "huge" could stand to be a little ... huge-er ... in my case.
 
Old 12-03-2010, 05:46 PM   #6
dguy
Member
 
Registered: Dec 2001
Location: Beckwith Township, Ontario, Canada
Distribution: Slackware 14.0, Slackware-64 14.1
Posts: 115

Original Poster
Rep: Reputation: 16
Solved - adding CONFIG_USB_HIDDEV=Y to the kernel's config was all that was needed. Thanks for the input everyone!
 
Old 03-15-2011, 11:05 AM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Hmmm, I remember seeing this thread a while ago. This means re-compiling and installing the kernel. The reason I have not done that, yet, is I have the module loaded. An I to believe the module probed fails, and compiled into the kernel it works???

I did find another issue. In the online doc, it states

Quote:
--enable-usb Turns on generation of the USB driver code. By default this is disabled.
It looks to me as if usb is not the default when you compile the daemon. I have since re-compiled the kernel with this option turned on; ./configure --enable-usb then make, and make install.

I'm testing that now, so far, no difference.
 
  


Reply

Tags
udev, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Creating an udev rule mounting all usb drive as 666 Linux.tar.gz Linux - Hardware 20 11-23-2010 05:56 AM
udev update killed all HDD dev nodes MALDATA Linux - Software 7 08-07-2010 02:26 PM
udev and missing lvm nodes in -current? Slim Backwater Slackware 0 08-08-2006 08:10 PM
nVidia udev nodes in gentoo superkav Linux - Hardware 3 02-08-2006 06:18 PM
udev not creating nodes. for sound, etc. gooball Slackware 1 10-21-2005 01:30 AM


All times are GMT -5. The time now is 09:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration