LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Typing letter "q" quits any application (xfce+compiz+emerald) (http://www.linuxquestions.org/questions/slackware-14/typing-letter-q-quits-any-application-xfce-compiz-emerald-4175461705/)

puru 05-13-2013 01:36 AM

Typing letter "q" quits any application (xfce+compiz+emerald)
 
Two days ago i used compiz with emerald for my slackware 14 installation(I use xfce and i have not installed KDE) Everything is working fine except when i try to choose an option in animations (for min, max, close etc). Doing so freezes everything.

This is not the main problem that worries me. The main problem is whenever i try to type the letter "q", any focused window closes as if I have pressed ctrl+q (although pressing ctrl+q does nothing). While choosing various settings/effect i must have done something wrong. This has been pestering me.

Where can i check any key-bindings that must be causing it?
Does it really has anything to do with my switching to (compiz+emerald)?
I tried to switch back to xfwm4 (xfwm4 --replace and removed startup entries for compiz and emerald) but it is not working and at reboot compiz takes over. Do i need to uninstall / reinstall compiz and related packages?

I tried to search the web for "typing q quits application" but was not able to find anything useful.

Any help will be greatly appreciated. Thanks in advance for your precious help and support.

pan64 05-13-2013 01:41 AM

you can try xev to check x events.

commandlinegamer 05-13-2013 04:05 AM

FWIW, certain applications use 'Q' to quit - XPDF is one that springs to mind.

I wish there were a bit more consistency sometimes. For examples, if I'm using XFE as filemanager Ctrl-Q closes it, but thunar requires Ctrl-W.

ReaperX7 05-13-2013 08:19 PM

Check and see if your CTRL key might be stuck.

Diantre 05-14-2013 12:18 AM

Quote:

Originally Posted by puru (Post 4949920)
Where can i check any key-bindings that must be causing it?

Open ccsm and go to General Options, you'll see the Key Bindings tab there. The first option is the "Close Window" key binding.

Quote:

Does it really has anything to do with my switching to (compiz+emerald)?
I wouldn't think so. I also use xfce+compiz+emerald and everything is fine here. But follow the advice others have given in this thread, check the key bindings and report back.

Good luck!

puru 05-16-2013 11:34 AM

Thank you everybody. The problem with changing the keybinding for close window to ctrl+q doesnot work. It actually binds the key q for close window instead of ctrl+q. Sorry, for inconvenience i may have caused. As i did too many changes i was unable to trace which action must have caused this weird behavior. I still don't understand why ctrl+q cannot be set for close-window action? The problem of freezing everything on changing the animations still persists.

Diantre 05-17-2013 01:08 PM

Quote:

Originally Posted by puru (Post 4952575)
The problem with changing the keybinding for close window to ctrl+q doesnot work. It actually binds the key q for close window instead of ctrl+q.

I was testing the key bindings and just observed this behavior. Changing the "close window" key binding to Ctrl+Q has unexpected effects. In my case some programs close, others don't. When I reopened ccsm, the key binding was changed to the letter "q", instead of "<Primary>q" as it was before. A bug in compiz? It could be related to the fact that many programs actually use Ctrl+Q by default to close, but that's just a guess.

Anyway, I always use Super+C to close windows, so I've never noticed this before. As a matter of fact, I mostly use the Super key (the windows key) with window manager actions, since most GUI programs use the Ctrl, Ctrl+Shift and Alt combinations as shortcuts.

Quote:

The problem of freezing everything on changing the animations still persists.
That's harder to find out because it involves many things, the video card you use, driver versions, plugins used, etc. For instance, the Magnifier plugin still crashes my X session, luckily I don't actually use it, but I blame this on my very old and obsolete video card.

My suggestion is to use compiz profiles to isolate your problem. The profiles let you enable some plugins and/or change some settings and save them to a profile (a text file, which can be loaded later). In this way you can systematically enable/disable things to see if it's caused by a combination of settings or plugins. I know, trial and error may not be the best advice, but I'm out of ideas at the moment.

You'll find the profiles in the "Preferences" section in ccsm.

puru 05-23-2013 07:17 AM

Thanks Diantre. I never thought of harnessing the win key for close window task. Although i used it replace Alt+F2 by win+R, win+E to open file manager, win+L to lock screen (habits die hard. The windows shortcut i use at workplace.) As for the animations, i don't want many. The one i set currently seems ok. But i will give a try to combinations of setting thing to find the culprit, hopefully.


All times are GMT -5. The time now is 08:41 PM.