LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-25-2009, 06:27 PM   #1
0zMe
Member
 
Registered: Jun 2009
Posts: 85

Rep: Reputation: 15
Question Two sound cards; how to ignore one?


Hello everybody.

I have installed Slackware and I'm really new to it. My problem is, that I have 2 sound cards in my computer. One is onboard (Intel) and the other one is pci (C-Media).

I would like to use my PCI soundcard.
The kernel modules for them are:
Intel: snd-intel8x0
C-Media: snd-cmipci

Everytime if I boot my computer, Slackware chooses the Intel card, but sometimes my C-Media.

I just want to use C-Media.
Everytime if I want to use the C-Media I login as SU and type rmmod snd-intel8x0. After a restart I can enjoy the sound as far as I restart my pc.

What I've done to solve the problem?
Alsaconf; I have already chosen my C-Media.
And everytime rmmod snd-intel8x0.

How can I make it that my system ignores the Intel soundcard?

Thanks for your help.
 
Old 06-25-2009, 06:45 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,043
Blog Entries: 1

Rep: Reputation: 1369Reputation: 1369Reputation: 1369Reputation: 1369Reputation: 1369Reputation: 1369Reputation: 1369Reputation: 1369Reputation: 1369Reputation: 1369
Hi,

Welcome to LQ!

The easy way would be to disable the on-board sound in the BIOS.
 
Old 06-25-2009, 06:52 PM   #3
0zMe
Member
 
Registered: Jun 2009
Posts: 85

Original Poster
Rep: Reputation: 15
Thanks for quick answer.
I've an OEM Bios. Therefore I can't disable the onboard card.

But I'll try it again.
 
Old 06-25-2009, 08:44 PM   #4
kd5zex
LQ Newbie
 
Registered: Dec 2008
Distribution: Slackware
Posts: 28

Rep: Reputation: 15
Wink

Take it out and put it in your desk drawer.
 
Old 06-25-2009, 09:05 PM   #5
0zMe
Member
 
Registered: Jun 2009
Posts: 85

Original Poster
Rep: Reputation: 15
So I was able to disable the onboard soundcard through bios.
Thanks a lot for your help but I still would like to know if there were also a chance to disable or ignore it through Linux.
 
Old 06-25-2009, 10:07 PM   #6
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Add snd-intel8x0 to /etc/modprobe.d/blacklist
 
Old 06-25-2009, 10:10 PM   #7
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
You could try this - take out any references in /etc/modprobe.d/sound to snd-intel8x0 and add this to /etc/modprobe.d/blacklist :
Code:
blacklist snd_intel8x0
This works for me on a VirtualBox setup which loads the intel_8x0 module. Making these changes stops it loading.
 
Old 06-26-2009, 12:22 AM   #8
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 260

Rep: Reputation: 50
I had similar issues with two sound cards:

Have a look at this:
http://www.linuxquestions.org/questi...-audio-604312/

Regards,
Stefan
 
Old 06-26-2009, 05:02 AM   #9
0zMe
Member
 
Registered: Jun 2009
Posts: 85

Original Poster
Rep: Reputation: 15
Many thanks, problem solved.
The topic can be closed.
 
  


Reply

Tags
ignore, soundcard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Isnt it xmms crappy to play sound, like detecting sound cards. Others are all better frenchn00b Linux - General 2 02-11-2008 06:51 PM
No sound w/ Sound Blaster Audigy 2 (and possibly other related cards) fix swiftpaw Mandriva 2 05-08-2006 12:43 PM
Problems getting sound to play under Mandrake w/2 sound cards HGeneAnthony Linux - Hardware 1 07-02-2004 02:19 PM
ignore one of 2 sound cards dukeinlondon Mandriva 4 10-22-2003 05:41 AM
Ethernet Cards and Sound Cards SchizoIV Linux - Newbie 2 07-05-2002 09:10 PM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration