LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-19-2008, 11:43 PM   #16
newtodebian
LQ Newbie
 
Registered: May 2006
Location: On the northern border of USA/Canada.
Distribution: Slackware 12.2 on Toshiba Satelite p105-s6187, kernel 2.6.27.7
Posts: 10

Rep: Reputation: 0

I've searched high and low, but I'm not too experienced with configuring xorg by hand. But, I only have one issue with Slackware and that's the keyboard. I'm using a laptop of course, a Toshiba Satellite P105-S6187. The issue I have is that although the keymapping is correct, the functions on my numeric keypad only function as numbers regardless if NumLock is on or off. But, some of the numbers have double functions. 7 is supposed to double as HOME, 9 as PageUp, 3 as PageDown, 1 as END. So, when NumLock is off the 1 is supposed to function as END and 7 as HOME. Instead, they only function as numbers regardless. Here is my keyboard section from xorg.conf.

Quote:
Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"

Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# Option "LeftAlt" "Meta"
# Option "RightAlt" "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for Xorg
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"

Option "XkbRules" "xorg"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"
Option "XkbVariant" "us"

EndSection

 
Old 12-20-2008, 12:17 AM   #17
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
if it was the num lock code then there was still a active file in the /tmp/ this has been a big issue with me running the gnome and kde together on 12.1. for some reason the start up scrpts were not removing the old session in tmp drove me nuts took me a while to figure this out. and as you know there was some bizarre things that were in my logs. radio the esd stuff if you really want some good trouble shooting put the gnome with the kde in slakware and have fun with a seahorse . I am glad you got it.
thats what it is all about.
 
Old 12-20-2008, 10:12 AM   #18
newtodebian
LQ Newbie
 
Registered: May 2006
Location: On the northern border of USA/Canada.
Distribution: Slackware 12.2 on Toshiba Satelite p105-s6187, kernel 2.6.27.7
Posts: 10

Rep: Reputation: 0
Solved! Here's the new code for my Xorg that fixes the numerical keypad issue, and apparently even my VT Switching now works too. I had a problem where, no matter what runlevel I booted into, the second I started X I lost VT Switching. But now, it works, and all I had to do was comment out THIS line.

Before:
Quote:
Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"

Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# Option "LeftAlt" "Meta"
# Option "RightAlt" "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for Xorg
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"

Option "XkbRules" "xorg"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"
Option "XkbVariant" "us"

EndSection

After:
Quote:
Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"

Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# Option "LeftAlt" "Meta"
# Option "RightAlt" "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for Xorg
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"

Option "XkbRules" "xorg"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"
# Option "XkbVariant" "us"

EndSection
And that fixed the issue.
 
Old 12-20-2008, 01:27 PM   #19
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,442

Rep: Reputation: 70
Quote:
Originally Posted by Woodsman View Post
Mystery Solved But No Solution

(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap


[...]

I ran across a blurb that using NumLockX in KDE was unnecessary because the KDE code essentially was the NumLockX code.
The NumLockX homepage says this on them main page.
Quote:
Originally Posted by http://ktown.kde.org/~seli/numlockx/
Note that KDE and many distributions already use NumLockX (or its older version), so you most probably don't need to care.
Quote:
Originally Posted by Woodsman View Post
The only method that seems to eliminate the error messages was not using Num Lock in any manner.

[...]

There is no solution to eliminate the error messages if a user wants to use Num Lock in KDE.

Well, mystery solved although there is no cure.
How about just pushing the numlock button when you want to use it? I grep'd my logs and have never seen your errors, but my numlock is not on by default.

Either that, or you can just ignore the errors as I mentioned earlier since they are apparently just useless noise in this case.
 
Old 12-20-2008, 02:33 PM   #20
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
How about just pushing the numlock button when you want to use it? I grep'd my logs and have never seen your errors, but my numlock is not on by default.
Yes, that would be one solution.

As I mentioned, the errors do not appear if in KDE Num Lock is set to Off or Leave unchanged. For people who do not use Num Lock they never will see the errors.

Quote:
Either that, or you can just ignore the errors as I mentioned earlier since they are apparently just useless noise in this case.
That was implied in my final statement.

Still is sloppy programming, however.
 
Old 12-20-2008, 08:42 PM   #21
garyg007
Member
 
Registered: Aug 2008
Location: north-east ohio
Distribution: Debian-squeeze/stable;
Posts: 279
Blog Entries: 1

Rep: Reputation: 31
For what its worth, With 12.1 installed numlockx running from /.kde/autostart, worked quit well every time; Since installing 12.2, I thought it did not work, until I found and read this thread; Then I realized that even though the light was not on, numlock was enabled

Last edited by garyg007; 12-20-2008 at 08:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
crazy soundcard problems zytsef Slackware 2 11-07-2007 02:34 PM
apt-get Problems Going CrAzY timgerrlists Ubuntu 7 05-02-2006 09:52 AM
Problems with ./config and installing themes - Newbie going crazy! danksmith Linux - Software 3 12-02-2005 05:56 PM
Crazy sound problems, please help me fix it. Slovak Slackware 2 10-26-2004 06:18 PM


All times are GMT -5. The time now is 06:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration