LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-14-2013, 02:06 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,289

Rep: Reputation: 50
Two machines LAN configuration in Slackware plus internet.


Hi:

The problem: A modem-router, a switch and two computers. The switch is connected to the modem-router and the two computers, and I want the computers to communicate between them and one of them, say computer A, to have access to internet (the modem-router is fed by the ISP). Let the other be computer B.

I've been reading The Linux Network Administrator's Guide, 2nd edition and /usr/doc/Linux-HOWTO/Linux+IPv6-HOWTO, but still can't figure out how to solve this problem.

As I see it, its a case of assigning one IP to A and another to B. This would do for address resolution. And could be done with ifconfig, though I do not know how (yes, I studies the man page).

What I did was to just forget about the modem-router (Motorola Surfboard SB5101i) and join the computers by means of the switch. I did 'ifconfig eth0 xxx.xxx.1.1' and 'ifconfig eth0 xxx.xxx.1.2' on B, where I chose xxx.xxx arbitrarily. Then, I verified with ping. This I did trying to simplify the problem, only to test. However, I was not able to login into the other machine. As you can see, my knowledge on LAN is insufficient, so I would not be entitled to ask for help here. If you think otherwise, please let me know.

net-tools 1.60
ifconfig 1.42 (2001-04-13)
Linux 3.2.29
Slackware 14.0
 
Old 02-14-2013, 02:31 AM   #2
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 401

Rep: Reputation: 41
Quote:
Originally Posted by stf92 View Post
Hi:


What I did was to just forget about the modem-router (Motorola Surfboard SB5101i) and join the computers by means of the switch. I did 'ifconfig eth0 xxx.xxx.1.1' and 'ifconfig eth0 xxx.xxx.1.2' on B, where I chose xxx.xxx arbitrarily. Then, I verified with ping. This I did trying to simplify the problem, only to test. However, I was not able to login into the other machine. As you can see, my knowledge on LAN is insufficient, so I would not be entitled to ask for help here. If you think otherwise, please let me know.

net-tools 1.60
ifconfig 1.42 (2001-04-13)
Linux 3.2.29
Slackware 14.0
it's more easy to designate address via /etc/rc/d/rc.inet1.conf

it contains some like:

# Config information for eth0:
IPADDR[0]="192.168.3.55"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY="192.168.3.254"

edit it with your own settings, save, and restart computer ( or do command: /etc/rc.d/rc.inet1 restart ). if you do not want setting done via manual, as i remeber commands is like ifconfig eth0 192.168.1.2 mask 255.255.255.0
then do add gateway: route add default gw 192.168.1.1
then it be must works. both computer must be in one subnet ( if netmask is 255.255.255.0 ( "c" class netmask, or /24), then ip adress range for both is like a 192.168.1.x, where x= 1 to 254 ) in example, give A computer 192.168.1.1, and B one - 192.168.1.2. netmask on both is 255.255.255.0 after you do that, you must can ping each other from both machines, if it be connected physically with ethernet cable ( crossed, or patch cables connected to ethernet switch).
also you do not want to hide your addresses, if it from 192.168.x.x range - it is "grey" address range for small private networks - it not routed to internet and not showing in global internet. when you connecting to inet, you must have a "real address", some like, for example, 60.50.104.45...
PS. why IPv6? do your cable provider use IPv6 ? :-O

Last edited by WiseDraco; 02-14-2013 at 02:46 AM.
 
Old 02-14-2013, 03:25 AM   #3
Poucket
Member
 
Registered: Dec 2012
Location: California
Distribution: Slackware 14.1
Posts: 38

Rep: Reputation: Disabled
Quote:
PS. why IPv6? do your cable provider use IPv6 ? :-O
Hello stf92,

Wise Draco asks why you are reading a How-To about Linux+IPv6?
If you see in Chapter 2 (2.1) it explains how
IPv6 differs from IPv4.
The addresses you have set for your two
computers are 32-bit IPv4.
 
1 members found this post helpful.
Old 02-14-2013, 03:33 AM   #4
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,289

Original Poster
Rep: Reputation: 50
IPv6 must be an error of mine. Please forget about IPv6. Where do I put that "real address"? With 'ifconfig eth0 xxx.xxx.xxx.xxx'?
 
Old 02-14-2013, 03:38 AM   #5
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,289

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by Poucket View Post
Hello stf92,

Wise Draco asks why you are reading a How-To about Linux+IPv6?
If you see in Chapter 2 (2.1) it explains how
IPv6 differs from IPv4.
The addresses you have set for your two
computers are 32-bit IPv4.
Oh yes. Four 8-bit numbers, that is, binary bbbbbbbbbb.bbbbbbbb.bbbbbbbb.bbbbbbbb or up to 255.255.255.255. You are right. And the computer when booting has trouble with 'IPv6 RAS'. So that was the trouble! But then it takes another course of action and seems to resolve. Otherwise I would not be speaking with you now. Thanks.

EDIT: by the way, when I had just bought the switch, I connected it to the modem and to this computer while the computer was running. And it, the computer, went on running as if nothing had happened. Perfect, said I, this works! Of course the other computer was not connected yet to the switch. However, I could NEVER again repeat these conditions! I wonder how I did it.

But this fact, that I continued having internet, does not say the modem is really a modem-router?

Last edited by stf92; 02-14-2013 at 03:43 AM.
 
Old 02-14-2013, 04:05 AM   #6
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 401

Rep: Reputation: 41
switch is hardware mm...hard to say in english - but switch is like a electric spreader, splitter - it looks up transparent for network. router \ firewall is a bit different things -it in you must configure it, and it works with packet filtration, addr4ess translation and another complex things. do you done configure ip address on both machines, as i describe? after that, it pings each other?
 
Old 02-14-2013, 04:07 AM   #7
Poucket
Member
 
Registered: Dec 2012
Location: California
Distribution: Slackware 14.1
Posts: 38

Rep: Reputation: Disabled
Quote:
Originally Posted by stf92 View Post
But this fact, that I continued having internet, does not say the modem is really a modem-router?
It does not. Your Surfboard sb5101 should be a modem.
 
1 members found this post helpful.
Old 02-14-2013, 04:10 AM   #8
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,289

Original Poster
Rep: Reputation: 50
Yes, the five jacks are connected in parallel, I understand. There are no passive or active elements between the jacks.

pLease, give 5 more minutes.
 
Old 02-14-2013, 04:15 AM   #9
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,289

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by Poucket View Post
It does not. Your Surfboard sb5101 should be a modem.
Then all my posting here in LQ has been in vain! What a pity! It was TobiSGD who told it was a router too.
 
Old 02-14-2013, 04:24 AM   #10
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,289

Original Poster
Rep: Reputation: 50
ifconf eth0 xxxxxxx.1 mask 255.255.255.0 gave 'mask: Host name lookup failure'. I have the same hostnames on both machines.
 
Old 02-14-2013, 04:34 AM   #11
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 401

Rep: Reputation: 41
Quote:
Originally Posted by stf92 View Post
ifconf eth0 xxxxxxx.1 mask 255.255.255.0 gave 'mask: Host name lookup failure'. I have the same hostnames on both machines.
sorry, there have been "netmask" - i configured it many time ago. correct syntax is
ifconfig eth0 xxx.xxx.xxx.xxx netmask 255.255.255.0

on one machine in xxx.xxx.xxx.xxx do a 192.168.0.1, on another - 192.168.0.2
then make sure both of it is be connected to switch, and switch is turn on, and then make a ping 192.168.0.2 from first machine.
 
Old 02-14-2013, 04:48 AM   #12
Poucket
Member
 
Registered: Dec 2012
Location: California
Distribution: Slackware 14.1
Posts: 38

Rep: Reputation: Disabled
Quote:
Originally Posted by stf92 View Post
It was TobiSGD who told it was a router too.
It is complicated. There might be some way for you to use the modem
and switch as was discussed yesterday, but it would better IMHO
to follow the recommendation here.
 
Old 02-14-2013, 04:58 AM   #13
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,289

Original Poster
Rep: Reputation: 50
OK. Both ifconfig done in each machine plus route command on A. After that, I pinged from each machine with no problem. What next?
 
Old 02-14-2013, 05:08 AM   #14
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 401

Rep: Reputation: 41
Quote:
Originally Posted by stf92 View Post
OK. Both ifconfig done in each machine plus route command on A. After that, I pinged from each machine with no problem. What next?
what you want next? i think, it is goal, who you want - network connection between these two machines.
if you need also internet on one of your machines in the same time ( says, on machine A), then
go on /etc/rc.d/rc.local on that machine and write in rc.local new string with /sbin/ifconfig eth0:0 192.168.0.1 netmask 255.255.255.0

in machine B on /etc/rc.d/rc.inet1.conf writes ip 192.168.0.2 and gw 192.168.0.1

in that example means, a internet ( with modem and so) is always connect to machine A.
after reboot both machines you must going to internet from machine A, and ping from A to B, ant vice versa...
it is any another things, who you want?
 
1 members found this post helpful.
Old 02-14-2013, 05:08 AM   #15
Poucket
Member
 
Registered: Dec 2012
Location: California
Distribution: Slackware 14.1
Posts: 38

Rep: Reputation: Disabled
What was your gateway for the route command? Or were you setting a route to B?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
giving SSH access to machines on LAN from internet tkmsr Linux - Server 4 03-09-2011 03:16 AM
Ubuntu server cannot access internet but LAN machines can. librano Linux - Server 2 05-13-2007 02:17 PM
LAN machines unable to connect to Internet through (firewall on )gateway nishi_k_79 Linux - Security 1 11-13-2003 02:30 PM
ssh to multiple lan machines from the internet - How? v00d00101 Linux - Newbie 4 06-20-2003 02:39 PM
Enabling Slackware Configuration on Network Machines deesto Slackware 5 12-22-2002 12:57 AM


All times are GMT -5. The time now is 10:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration