LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Two kde sessions in slackware-current (http://www.linuxquestions.org/questions/slackware-14/two-kde-sessions-in-slackware-current-783215/)

olego 01-19-2010 07:28 AM

Two kde sessions in slackware-current
 
Hello,

I have to run two kde sessions simultaneously. One for me and one for my wife. The first session is started by logging to the terminal with my wife's login and running 'startx'. The second kde session is launched with 'startx -- :1' in the another terminal.
The problem is that in the second KDE session occasionaly stop working all arrow keys in all applications - firefox, OpenOffice, rxvt and so on! All other keys works properly. The first KDE session works like a charm.
I have to restart second KDE session and all works fine for a while (some days or even couple of weeks). This thing is rather annoing for me.

Are there any solutions for this problem? Should I use some specific parameters to startx? I believe this is not KDE related problem because the first session works without any troubles.

Info about my system: Slackware-current, NVidia drivers, kernel 2.6.30-2.6.32. KDE 4.3.0 - 4.3.4.
I set up slackware-13 and encounter this problem. Further I tried to keep slackware-current but with all upgrades (till 2010-01-09) the problem persists.

brixtoncalling 01-19-2010 09:58 AM

Perhaps if you go through KDM and open the second session? I haven't done much of this on Slackware 13.0, but I don't recall having problems with earlier versions.

Lufbery 01-19-2010 12:22 PM

Quote:

Originally Posted by olego (Post 3832115)
Hello,

I have to run two kde sessions simultaneously. One for me and one for my wife. The first session is started by logging to the terminal with my wife's login and running 'startx'. The second kde session is launched with 'startx -- :1' in the another terminal.

So far, so good. That's what we do in my house too.

Quote:

The problem is that in the second KDE session occasionaly stop working all arrow keys in all applications - firefox, OpenOffice, rxvt and so on! All other keys works properly. The first KDE session works like a charm.

I have to restart second KDE session and all works fine for a while (some days or even couple of weeks). This thing is rather annoying for me.
Okay, to be clear, you're saying that after a few days or weeks, the problem rears its ugly head. Is that during continuous running -- as in the computer is running non-stop for a few days or weeks? Or, does the problem only show up intermittently, but you shut down nightly?

Quote:

Are there any solutions for this problem? Should I use some specific parameters to startx? I believe this is not KDE related problem because the first session works without any troubles.

Info about my system: Slackware-current, NVidia drivers, kernel 2.6.30-2.6.32. KDE 4.3.0 - 4.3.4.
I set up slackware-13 and encounter this problem. Further I tried to keep slackware-current but with all upgrades (till 2010-01-09) the problem persists.
One thing I can think to try: Check your Nvidia drivers. I had terrible, random lockups with the Nvidia drivers, but none with the NV drivers in Slackware 12.2. I'm running Slackware 64_13 without an xorg.conf file right now and I'm not having any trouble with multiple X sessions. (I haven't tried the Nvidia drivers yet.) It could be that the NV drivers work fine for you and you won't need an xorg.conf. Of course, you also won't have the cool 3D capabilities of your card, but this could be a good trouble-shooting step.

Good luck,

olego 01-20-2010 12:21 AM

Quote:

Originally Posted by Lufbery (Post 3832416)
Okay, to be clear, you're saying that after a few days or weeks, the problem rears its ugly head. Is that during continuous running -- as in the computer is running non-stop for a few days or weeks? Or, does the problem only show up intermittently, but you shut down nightly?

Some months ago I run my computer 24x7 without nightly shutdowns and problem apeared after few days or weeks of an uninterruptible work. But now I hibernate my computer with TuxOnIce nightly and problem show up every 3-5 days. My computers works from 7am till 11:30pm and problem may occure after 3 or 5 hibernates.

Quote:

Originally Posted by Lufbery (Post 3832416)
One thing I can think to try: Check your Nvidia drivers. I had terrible, random lockups with the Nvidia drivers, but none with the NV drivers in Slackware 12.2. I'm running Slackware 64_13 without an xorg.conf file right now and I'm not having any trouble with multiple X sessions. (I haven't tried the Nvidia drivers yet.) It could be that the NV drivers work fine for you and you won't need an xorg.conf. Of course, you also won't have the cool 3D capabilities of your card, but this could be a good trouble-shooting step.
Good luck,

But how video card's drivers can disable arrow keys!?!?! I think drivers can hang up my OS or computer but I don't believe that some keys may be disabled.
I like wobbling windows, desktop cube, translucent windows and other nice features of KDE4 =) I can try to switch off all nice graphical effects but it is no solution for me. I'd better restart my KDE every 3-5 days than lost all its graphical features and card capabilities.

olego 01-20-2010 12:28 AM

Quote:

Originally Posted by brixtoncalling (Post 3832283)
Perhaps if you go through KDM and open the second session? I haven't done much of this on Slackware 13.0, but I don't recall having problems with earlier versions.

I suppose You mean K-Menu->Leave->Switch user ?
I tried this but never happened! Only screensaver is started and nothing more.

How can I start another KDM session?

brixtoncalling 01-20-2010 01:20 AM

Quote:

Originally Posted by olego (Post 3833075)
I suppose You mean K-Menu->Leave->Switch user ?
I tried this but never happened! Only screensaver is started and nothing more.

How can I start another KDM session?

Log in as root and go to run-level four:
Code:

> init 4
KDM will start up and you can log in as your first user. Now go to K-Menu->Leave-Switch User. Now you will be able to log into the second account. You can't do this unless you initially logged in through KDM. You can also shut down and hibernate directly from KDE, which I don't think you can do if you just use startx.

olego 01-20-2010 02:26 AM

Quote:

Originally Posted by brixtoncalling (Post 3833115)
KDM will start up and you can log in as your first user. Now go to K-Menu->Leave-Switch User. Now you will be able to log into the second account. You can't do this unless you initially logged in through KDM. You can also shut down and hibernate directly from KDE, which I don't think you can do if you just use startx.

OK, thank You very much! I'd better change initdefault to 4 in the /etc/inittab. I'll try this tonight.

Are there any profits to use KDE's hibernate and standby instead of TuxOnIce's ones? TuxOnIce has flexible start/stop scripts, so I can properly stop my WiFi card and network and then start it again.

olego 01-21-2010 12:33 AM

Quote:

Originally Posted by brixtoncalling (Post 3833115)
You can also shut down and hibernate directly from KDE, which I don't think you can do if you just use startx.

I changed initdefault to 4 in the /etc/inittab, and run 'telinit 4' to switch to KDM session manager w/o reboot. All work fine, several parallell sessions work fine. I'll test this thing for several days or weeks.
But when I use KDE's internal standby I encounter problems with my wifi card. I have to properly shutdown network and unload the module before standby, and load the module and start network after resume. But I found no any standby/resume scripts or hooks to run my own scripts. So I have to use TuxOneIce's hibernate. But standby is more-more fast than hibernate. I found place to run custom scripts/programs before KDE start, and before KDE stop, but I suppose this is not related to standby/resume =(
K-Menu->System settings->Advanced->Autostart
I can run custom scripts only in 3 cases: "startup", "shutdown" and "pre-KDE startup". Unfortunately this is not what I need.

brixtoncalling 01-21-2010 06:20 AM

My wifi works fine on resume, but if you need to insert your own hooks, you could do so in /etc/acpi and then hook a call to pm-suspend to the power button. You would also place calls to shutdown and restart network and wifi before and after the pm-suspend.

You'd be bypassing the KDE infrastructure but it's still be a good way to go I think.

olego 01-22-2010 08:20 AM

Quote:

Originally Posted by brixtoncalling (Post 3834828)
My wifi works fine on resume, but if you need to insert your own hooks, you could do so in /etc/acpi and then hook a call to pm-suspend to the power button. You would also place calls to shutdown and restart network and wifi before and after the pm-suspend.

You'd be bypassing the KDE infrastructure but it's still be a good way to go I think.


All arrow keys were unexpectedly disabled in my account tonight. But my wife's KDE session works like a charm. So I decided this problem is related to my KDE configuration. I renamed my $HOME/.kde and started from clean configs. I'll continue experiments...

About scripts - I caught that I should use pm features to organize my own scripts. Thank You!

brixtoncalling 01-22-2010 12:27 PM

Good luck!

olego 02-04-2010 05:55 AM

Quote:

Originally Posted by brixtoncalling (Post 3836766)
Good luck!

So far fo good! In last two weeks I got no any arrow keys freezes! So this problem are considered to be configuration related. I don't know which option leads to this effect, but now all works like a charm!


All times are GMT -5. The time now is 10:08 AM.