LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-08-2012, 02:57 AM   #1
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Turning off wireless power management in wlan0 rc.wireless.conf is ignored


I added the line in the section
Code:
## Pick up any Access Point, should work on most 802.11 cards
*)
    INFO="Any ESSID"
    ESSID="any"
    IWCONFIG="power off"
    ;;
## ---------- END SECTION TO REMOVE ------------
In rc.wireless.conf, but the line has no effect. Power management is turned on by default whenever I reboot.

Is the above command getting executed at all? Should I make rc.wireless.conf executable?

I am using networkmanager with the gnome applet in Xfce. Does that override the settings in rc.wireless.conf?

Last edited by vharishankar; 08-08-2012 at 03:00 AM.
 
Old 08-08-2012, 03:06 AM   #2
Bazzaah
Member
 
Registered: Mar 2007
Distribution: Slackware64-current, Slackware64 14
Posts: 324

Rep: Reputation: 49
rc.wireless.conf is deprecated.

http://alien.slackbook.org/dokuwiki/...onf_deprecated
 
Old 08-08-2012, 03:12 AM   #3
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Original Poster
Rep: Reputation: 121Reputation: 121
Thanks! While it is deprecated, where do I set the iwconfig parameters for power management? I use NetworkManager, so rc.inet1.conf is not used?

I don't want the power management in wireless to be enabled by default. It slows down the connection a lot.
 
Old 08-08-2012, 04:14 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
Indeed, if you use NetworkManager (or WICD) then Slackware's own network initialization scripts are not used.

Eric
 
Old 08-08-2012, 04:17 AM   #5
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Original Poster
Rep: Reputation: 121Reputation: 121
Will it make a difference to add iwconfig wlan0 power off to rc.local? Is that a recommended approach or should this be configured in some other place?
 
Old 08-08-2012, 06:55 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
Quote:
Originally Posted by vharishankar View Post
Will it make a difference to add iwconfig wlan0 power off to rc.local? Is that a recommended approach or should this be configured in some other place?
That's indeed how I would try to achieve this, too.

Eric
 
Old 08-08-2012, 08:50 AM   #7
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Original Poster
Rep: Reputation: 121Reputation: 121
Quote:
Originally Posted by Alien Bob View Post
That's indeed how I would try to achieve this, too.

Eric
Thanks. For some reason now it works even in rc.wireless.conf. I haven't put it in /etc/rc.d/rc.local yet, but since it is deprecated I will use rc.local for this.
 
Old 08-08-2012, 11:36 PM   #8
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Original Poster
Rep: Reputation: 121Reputation: 121
Hm.... marking as unsolved. Guess I spoke too soon.

I changed the /etc/rc.d/rc.local to include iwconfig wlan0 power off and it still doesn't work. I guess NetworkManager is setting the power management to on every time it initializes the interface and thus overriding iwconfig.

Not sure where to change the setting in NetworkManager. It's irritating to have slow connection because of wireless power management.

Last edited by vharishankar; 08-08-2012 at 11:38 PM.
 
Old 09-24-2012, 11:39 AM   #9
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Original Poster
Rep: Reputation: 121Reputation: 121
deleted.

Last edited by vharishankar; 11-02-2012 at 12:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless is turning off vanoy Mandriva 5 02-02-2011 12:05 AM
turning non-wireless router wireless texasone Linux - Networking 3 01-06-2009 11:42 AM
Wireless - correct key in rc.wireless.conf + have to load it with iwconifig camorri Slackware 8 09-23-2008 12:39 PM
Asus laptop turning on wireless? (actual wireless works when on) Mikesoft Fedora 7 01-14-2007 10:30 AM
Broadcom wireless with ndiswrapper: ifconfig wlan0 works; ifup wlan0 fails orangechicken Linux - Wireless Networking 2 04-17-2004 05:39 PM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration