LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Turning off wireless power management in wlan0 rc.wireless.conf is ignored (http://www.linuxquestions.org/questions/slackware-14/turning-off-wireless-power-management-in-wlan0-rc-wireless-conf-is-ignored-4175420956/)

vharishankar 08-08-2012 02:57 AM

Turning off wireless power management in wlan0 rc.wireless.conf is ignored
 
I added the line in the section
Code:

## Pick up any Access Point, should work on most 802.11 cards
*)
    INFO="Any ESSID"
    ESSID="any"
    IWCONFIG="power off"
    ;;
## ---------- END SECTION TO REMOVE ------------

In rc.wireless.conf, but the line has no effect. Power management is turned on by default whenever I reboot.

Is the above command getting executed at all? Should I make rc.wireless.conf executable?

I am using networkmanager with the gnome applet in Xfce. Does that override the settings in rc.wireless.conf?

Bazzaah 08-08-2012 03:06 AM

rc.wireless.conf is deprecated.

http://alien.slackbook.org/dokuwiki/...onf_deprecated

vharishankar 08-08-2012 03:12 AM

Thanks! While it is deprecated, where do I set the iwconfig parameters for power management? I use NetworkManager, so rc.inet1.conf is not used?

I don't want the power management in wireless to be enabled by default. It slows down the connection a lot.

Alien Bob 08-08-2012 04:14 AM

Indeed, if you use NetworkManager (or WICD) then Slackware's own network initialization scripts are not used.

Eric

vharishankar 08-08-2012 04:17 AM

Will it make a difference to add iwconfig wlan0 power off to rc.local? Is that a recommended approach or should this be configured in some other place?

Alien Bob 08-08-2012 06:55 AM

Quote:

Originally Posted by vharishankar (Post 4748771)
Will it make a difference to add iwconfig wlan0 power off to rc.local? Is that a recommended approach or should this be configured in some other place?

That's indeed how I would try to achieve this, too.

Eric

vharishankar 08-08-2012 08:50 AM

Quote:

Originally Posted by Alien Bob (Post 4748867)
That's indeed how I would try to achieve this, too.

Eric

Thanks. For some reason now it works even in rc.wireless.conf. I haven't put it in /etc/rc.d/rc.local yet, but since it is deprecated I will use rc.local for this.

vharishankar 08-08-2012 11:36 PM

Hm.... marking as unsolved. Guess I spoke too soon.

I changed the /etc/rc.d/rc.local to include iwconfig wlan0 power off and it still doesn't work. I guess NetworkManager is setting the power management to on every time it initializes the interface and thus overriding iwconfig.

Not sure where to change the setting in NetworkManager. It's irritating to have slow connection because of wireless power management.

vharishankar 09-24-2012 11:39 AM

deleted.


All times are GMT -5. The time now is 07:33 PM.