LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-02-2007, 10:58 AM   #1
tntcoder
Member
 
Registered: Sep 2003
Distribution: Arch
Posts: 89

Rep: Reputation: 15
Turning off IPv6


Hey guys,

Im using slackware 11, and ive just made a new 2.6.21 Kernel, and my network isnt working and i think its down to IPv6 being used, even though im farily sure i unticked it in the kernel config :s.

When i boot up it hangs on DHCPD : Mac .... for about 30 seconds, then boots up normally with no network. Its an nvida NIC, and I definatly built the drivers in for it. Theres nothing specific in dmesg that I can see either.

So anyone know how to turn ipv6 off? I tried adding
alias net-pf-10 off
alias ipv6 off

to /etc/modprobe.d/blacklist but that hasnt helped, dunno if thats the correct file?

Thanks for any help.
 
Old 05-02-2007, 11:53 AM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
That looks correct.. Though if you have a /etc/modprobe.d/ folder, those files in there will be used before /etc/modprobe.conf.. If so, then make a file inside /modprobe.d called whatever you like, and in it put those lines:
alias ipv6 off
alias net-pf-10 off


Also, to be double sure, in the file /etc/rc.d/rc.inet1.conf, add the line NETWORKING_IPV6="no" and you can be certain you are not using IPv6
 
Old 05-02-2007, 03:24 PM   #3
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
did you build support for your NIC into the kernel or as a module? does ifconfig -a show the interface as being present?
 
Old 06-03-2007, 06:27 PM   #4
JockVSJock
Member
 
Registered: Jan 2004
Posts: 634

Rep: Reputation: 31
I'm getting this too. A module is showing up called ipv6.

Trying to remove, shows that it is in use...AFAIK, i'm only using ipv4.

Anyway to remove this?

thanks
 
Old 06-03-2007, 07:10 PM   #5
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
why not just rebuild the kernel and take out ipv6 support?
 
Old 06-03-2007, 07:17 PM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
I have the same problem - recompiled kernel without v6 support but problem persists...
 
Old 06-03-2007, 07:45 PM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I don't think it is ipv6 that's the problem. Are you sure you setup the network properly (check the slackbook) ... run 'netconfig'.
 
Old 06-04-2007, 09:23 AM   #8
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
For me this started happening after a -current upgrade. I havent changed any network settings at all.

*edit: may have also been after kernel upgrade to 2.6.20

Last edited by dive; 06-04-2007 at 04:07 PM.
 
Old 06-04-2007, 10:10 PM   #9
JockVSJock
Member
 
Registered: Jan 2004
Posts: 634

Rep: Reputation: 31
Quote:
Originally Posted by H_TeXMeX_H
I don't think it is ipv6 that's the problem. Are you sure you setup the network properly (check the slackbook) ... run 'netconfig'.
I set static ips for my machines using 'netconfig.' I think one of the posts is right in that IPv6 got configured into the kernel, and I would have to do some work to get it out of there.

When I do 'ifconfig -a', I get the following:

Code:
root@ladytron:~# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0F:B5:46:70:A2
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:b5ff:fe46:70a2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10372220 errors:10 dropped:0 overruns:0 frame:21
          TX packets:9462228 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:759992729 (724.7 MiB)  TX bytes:2918229220 (2.7 GiB)
          Interrupt:11 Base address:0xe000

eth1      Link encap:Ethernet  HWaddr 00:15:F2:6A:BA:CE
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6935 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6935 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1663050 (1.5 MiB)  TX bytes:1663050 (1.5 MiB)

sit0      Link encap:UNSPEC  HWaddr 00-00-00-00-30-30-30-3A-00-00-00-00-00-00-00-00
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turning 21... scuzzman General 16 01-20-2006 07:03 AM
How to keep the monito from turning off? NewToLinux2005 Linux - Hardware 1 02-17-2005 01:19 AM
Turning off screensaver in 9.2 davemar Suse/Novell 1 01-28-2005 06:36 AM
turning off limewire... pdmackenzie Linux - Software 4 03-15-2004 11:38 PM
turning off dfownz Slackware 1 01-14-2004 08:53 PM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration