LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Turning off IPv6 (http://www.linuxquestions.org/questions/slackware-14/turning-off-ipv6-550656/)

tntcoder 05-02-2007 09:58 AM

Turning off IPv6
 
Hey guys,

Im using slackware 11, and ive just made a new 2.6.21 Kernel, and my network isnt working and i think its down to IPv6 being used, even though im farily sure i unticked it in the kernel config :s.

When i boot up it hangs on DHCPD : Mac .... for about 30 seconds, then boots up normally with no network. Its an nvida NIC, and I definatly built the drivers in for it. Theres nothing specific in dmesg that I can see either.

So anyone know how to turn ipv6 off? I tried adding
alias net-pf-10 off
alias ipv6 off

to /etc/modprobe.d/blacklist but that hasnt helped, dunno if thats the correct file?

Thanks for any help.

GrapefruiTgirl 05-02-2007 10:53 AM

That looks correct.. Though if you have a /etc/modprobe.d/ folder, those files in there will be used before /etc/modprobe.conf.. If so, then make a file inside /modprobe.d called whatever you like, and in it put those lines:
alias ipv6 off
alias net-pf-10 off


Also, to be double sure, in the file /etc/rc.d/rc.inet1.conf, add the line NETWORKING_IPV6="no" and you can be certain you are not using IPv6

mcd 05-02-2007 02:24 PM

did you build support for your NIC into the kernel or as a module? does ifconfig -a show the interface as being present?

JockVSJock 06-03-2007 05:27 PM

I'm getting this too. A module is showing up called ipv6.

Trying to remove, shows that it is in use...AFAIK, i'm only using ipv4.

Anyway to remove this?

thanks

slackhack 06-03-2007 06:10 PM

why not just rebuild the kernel and take out ipv6 support?

dive 06-03-2007 06:17 PM

I have the same problem - recompiled kernel without v6 support but problem persists...

H_TeXMeX_H 06-03-2007 06:45 PM

I don't think it is ipv6 that's the problem. Are you sure you setup the network properly (check the slackbook) ... run 'netconfig'.

dive 06-04-2007 08:23 AM

For me this started happening after a -current upgrade. I havent changed any network settings at all.

*edit: may have also been after kernel upgrade to 2.6.20

JockVSJock 06-04-2007 09:10 PM

Quote:

Originally Posted by H_TeXMeX_H
I don't think it is ipv6 that's the problem. Are you sure you setup the network properly (check the slackbook) ... run 'netconfig'.

I set static ips for my machines using 'netconfig.' I think one of the posts is right in that IPv6 got configured into the kernel, and I would have to do some work to get it out of there.

When I do 'ifconfig -a', I get the following:

Code:


root@ladytron:~# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0F:B5:46:70:A2
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:b5ff:fe46:70a2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10372220 errors:10 dropped:0 overruns:0 frame:21
          TX packets:9462228 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:759992729 (724.7 MiB)  TX bytes:2918229220 (2.7 GiB)
          Interrupt:11 Base address:0xe000

eth1      Link encap:Ethernet  HWaddr 00:15:F2:6A:BA:CE
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6935 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6935 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1663050 (1.5 MiB)  TX bytes:1663050 (1.5 MiB)

sit0      Link encap:UNSPEC  HWaddr 00-00-00-00-30-30-30-3A-00-00-00-00-00-00-00-00
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

thanks again


All times are GMT -5. The time now is 04:51 AM.