LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-19-2006, 10:46 AM   #1
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 316

Rep: Reputation: 30
Turn off monitor? Remove Apache?


My computer has no button to turn off the monitor. Is there a way to turn it off (via the OS/software) so it doesn't burn an image into the screen? I'm half sure there is, since I've seen it done.

And a quick question. How do I fully remove Apache? I removed the package, but I still get Apache related errors on shutdown.

Last edited by Zeno McDohl; 01-19-2006 at 11:16 AM.
 
Old 01-19-2006, 01:20 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
What are the errors? If you've uninstalled the package all of the executables should be gone. Were you seeing something like 'No such file or directory'?

If so, check /etc/rc.d/rc.6 & /etc/rc.d/rc.M for lines containing '/etc/rc.d/rc.httpd'. They should be wrapped in checks to see if the file is executable, but if the check has been removed you'll get an error when the script is run.
 
Old 01-19-2006, 01:33 PM   #3
nilleso
Member
 
Registered: Nov 2004
Location: ON, CANADA
Distribution: ubuntu, RHAS, and other unmentionables
Posts: 372

Rep: Reputation: 31
...and for the monitor use a screensave
xscreensaver
 
Old 01-19-2006, 04:31 PM   #4
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 316

Original Poster
Rep: Reputation: 30
For Apache, I get:
Quote:
/usr/sbin/apachect1 stop: httpd (no pid file) not running
And if I try xscreensaver I get an error:
Quote:
warning: $DISPLAY is not set: defaulting to ":0.0"
Can't open display :0.0
Oh and I don't want a screensaver. I want the monitor 'off' (The power icon turns orange).

Last edited by Zeno McDohl; 01-19-2006 at 05:41 PM.
 
Old 01-21-2006, 08:33 PM   #5
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 316

Original Poster
Rep: Reputation: 30
Okay my monitor turns black after some idle time, so that works. Still can't get that pid Apache error away.
 
Old 01-21-2006, 11:19 PM   #6
Pocketace
LQ Newbie
 
Registered: Nov 2005
Distribution: Slackware 10.2
Posts: 9

Rep: Reputation: 0
On your monitor problem, if you have the acpi stuff running you can try using the xset command. It would look like this: xset dpms force off

that should work.
 
Old 01-21-2006, 11:31 PM   #7
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
You can safely ignore the Apache error - it's trying to close it down but it's not running anyway. To stop it happening though, you can run chmod -x /etc/rc.d/rc.httpd and that should stop it.
 
Old 01-22-2006, 05:59 AM   #8
Oinopion
Member
 
Registered: May 2005
Location: Kraków, PL
Distribution: Slackware
Posts: 33

Rep: Reputation: 15
To shutdown monitor physically you have to have:
Code:
    Option "DPMS"
in xorg.conf in 'Monitor' section.
 
Old 01-22-2006, 12:15 PM   #9
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 316

Original Poster
Rep: Reputation: 30
But isn't that for X? I don't use X because this is a server.
 
Old 01-22-2006, 12:20 PM   #10
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
All the suggestions for your monitor so far have been for X. Does the monitor just blank and not power down? I had the same problem, I think its because, in layman's terms, the kernel doesn't know how to tell your graphics card to signal the monitor to power down, I never found a solution unfortunately
 
Old 01-22-2006, 12:42 PM   #11
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
In my startup scripts I have the following to blank my monitor - I'd forgotten it was even there:

Code:
/bin/setterm -blank 15 -powersave powerdown -powerdown 60
 
Old 01-22-2006, 12:44 PM   #12
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
Yes, its in /etc/rc.d/rc.M by default, still certain graphics cards won't send the monitor to sleep when they're supposed to
 
Old 01-22-2006, 12:53 PM   #13
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
A hot day here without the air conditioning on sends my monitor (and motherboard) to sleep with or without help from the software
 
Old 01-23-2006, 02:51 AM   #14
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
Thank you Oinopion!
I was wondering why the suspend mode only worked with other distros, i was missing Option "DPMS" i had recompiled my kernel and even tried tweaking rc.M and i still didn't know why my viewsonic only went blank, but not suspend. Learning new little things is one of the fun things of running slack
 
Old 01-26-2006, 06:20 PM   #15
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 316

Original Poster
Rep: Reputation: 30
I'm still looking for a way to power off the monitor off via bash. If it idles, the monitor will "black" out but the monitor will still be on and emitting a light.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
monitor turn off jkmartha Linux - Newbie 1 05-03-2005 01:16 AM
Utility that can turn monitor off 3saul Linux - General 2 08-25-2004 02:09 AM
Turn off laptop monitor xushi Slackware 3 01-01-2004 06:17 AM
XScreensaver will not turn monitor off Panzerfrost Linux - Software 8 12-16-2003 03:05 PM
Slack 9.1: Monitor does not turn off. asklepios Slackware 2 10-08-2003 02:29 PM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration