LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-08-2008, 03:48 AM   #1
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Rep: Reputation: 15
tulip driver error, no internet in 12.1


Good morning. I turned on an older slackware box begin making it into a headless slackware 12.1 box. I believe slackware 9.1 or 10 was running on it. Internet always worked on this computer. Nothing has ever been changed, but now I do not have access. Late last year when I last used it I just turned it on, ssh'd into it to transfer media from it to a newer computer. Then I turned it back off until now. I figured upgrading to 12.1 would fix this, but I was wrong. I'm getting relatively the same tulip error message.

In dmesg I see "0000:00:06.0: tulip_stop_rxtx() failed (CSR5 0XFC06C012 CSR6 0XFF97011)"

lspci:

00:06.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)

ifconfig -a:

Doesn't show anything normal. eth0 is mentioned, but no broadcasting address. I would type all of that output, but it's a lot and I'm bound to miss a detail.

route:

loopback * 255.0.0 u 0 0 0 lo

I can ping 127.0.0.1, if that matters.

Through google it looks like a fair amount of people have experienced this , but I don't see any solutions. What's odd is that alot of what I found regarding this is from many years ago. One disturbing post here

http://ubuntuforums.org/showthread.php?t=195106

Mentions that he only got it working by installing a distro called "Breezy." If at all possible, I don't want to learn a new distro, so I'd like to fix this in slackware.

Thanks a lot,
Anithen

P.S. - lsmod shows tulip loaded and used by [1], but I can't tell what's using it and I can't run rmmod to try loading manually.

Last edited by Anithen; 06-08-2008 at 03:51 AM. Reason: additional details
 
Old 06-08-2008, 03:50 PM   #2
jkhg
LQ Newbie
 
Registered: Jan 2006
Distribution: Fedora Core 4, Slackware 12
Posts: 18

Rep: Reputation: 0
I had several cards that used the tulip driver. They never worked in any distro on any machine I tried. I found that I had to unplug the cable from the NIC and then plug it in again once the system was running to make it work. I assume it's a bug in the driver that was never fixed. I read posts from others who had the problem, but never found any solution.

I took the easy way out and got different NICs... Intel cards seem to work fine.
 
Old 06-08-2008, 04:44 PM   #3
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Original Poster
Rep: Reputation: 15
Thanks for letting me know. This computer's pretty old, so compiling a kernel on it is taking time, but that's what I'm doing right now. Turns out that there are about 4 extra options pertaining to the tulip drivers and one of them mentions the rxtx stops somehow being lessened. These options don't point directly to a fix, but it might be a fix in disguise. I'll keep everyone posted, because I enabled all of these options under the tulip section of the stock slackware 12.1 kernel.

There's a lot of stuff this old, headless machine isn't going to need except networking, usb and v4l for webcams, so I ended up disabling a lot of options, too. There's always that feeling that I might've disabled too much... I'll report back on that, too.
 
Old 06-08-2008, 05:26 PM   #4
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Original Poster
Rep: Reputation: 15
The old computer is connected through port 5 of the Hub, and I and now I notice all other computers connecting through the Hub (Linkys Fast Ethernet 10/100 5-Port Hub, model NH1005 or NH1008, version 2) started to experience great lag in browsing and ssh. I got around to pinging the main router (not the Hub) that feeds into the Hub's wan port, and I was surprised to see 52% packet loss. I pinged google and got the same thing. I read the Hub's User Guide, and it said "If you use the uplink port (which I've been calling the Wan) on the 5 port Hub, port 5 will be disabled, and if you use the uplink port on the 8 port Hub, Port 8 will be disabled." I guess they forgot to mention that if you leave the 5th or the 8th port connected to anything it will cause great packet loss for all of the other ports I hope this helps those who run into this. All of the pinging and packet loss was being experienced on computers that do not use the tulip driver. The one older computer that the post is intended for is still having the problem. It actually doesn't have a port of its own anymore, so since I now have an extra hub, I'll be plugging it into port 4 of this Hub, and connecting the old computer to it's uplink or wan input. I just need one more ethernet cable now...

As for whether or not the switch fix will fix the tulip error, I'm not sure. The kernel is still compiling, and last night I already tried plugging a working cable to the back of it and got the same thing. I'm not sure if I power cycled everything, though. After the kernel compile I'll experiment with other cables that already work.
 
Old 06-09-2008, 11:57 AM   #5
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Original Poster
Rep: Reputation: 15
Solved: network conditions can cause the aforementioned tulip error.

I don't have much time to type, but I want to say that the tulip errors I reported are because of the 5th port on Linkys Fast Ethernet 10/100 5-Port Hub, model NH1005 or NH1008, version 2. I got an extra HUB and connect it through the Linkys Fast Ethernet 10/100 5-Port Hub, model NH1005 or NH1008, version 2's 4th port, and everything's find now.

Hope this helps someone one day.
 
Old 06-09-2008, 10:50 PM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,473
Blog Entries: 4

Rep: Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525
Hi,

Do you have a faster computer that you can build your new kernel on? If so you would just move/copy the kernel, modules files to the slower platform. I cross platform all the time without trouble. I use the newer systems to bench anything so I don't have to wait on slower but useful equipment.
 
Old 06-10-2008, 11:44 AM   #7
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Original Poster
Rep: Reputation: 15
That's a good idea, onebuck. I'll definitely try that in the future if I want to customize the kernel in 12.1 and 12. I need to google for how kernel compiles differ in 12 and 12.1, because with slackware 11 I did this to compile:
$ make clean
$ make xconfig
$ make modules
$ make bzImage

Then as rood I'd use this little script:

cp arch/i386/boot/bzImage /boot/$1
rm /boot/System.map
cp System.map /boot/$2
ln -s /boot/$2 /boot/System.map
vim /etc/lilo.conf
lilo

Is this still how we compile? Thanks.
 
Old 06-10-2008, 04:32 PM   #8
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Quote:
Originally Posted by Anithen
That's a good idea, onebuck. I'll definitely try that in the future if I want to customize the kernel in 12.1 and 12. I need to google for how kernel compiles differ in 12 and 12.1, because with slackware 11 I did this to compile:
$ make clean
$ make xconfig
$ make modules
$ make bzImage

Then as rood I'd use this little script:

cp arch/i386/boot/bzImage /boot/$1
rm /boot/System.map
cp System.map /boot/$2
ln -s /boot/$2 /boot/System.map
vim /etc/lilo.conf
lilo

Is this still how we compile? Thanks.
That is correct, yes. See here for a GREAT 2.6 kernel-building guide.
 
Old 06-10-2008, 10:49 PM   #9
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Original Poster
Rep: Reputation: 15
Thanks for that info. I see a couple of differences between the way the article's author compiles and my own, so that might be where my problem lies. We basically compile and install identically, except I am getting the panic errors that he suggests using initrd to get around.

I know I compiled reiserfs in, but I might've modulated the ext3 fs. I also don't remember what I did with the jbd driver, so I'll check the config to see what VFS-avoiding tweaks I can make. To add to all this, I never even heard of downloading special a "Slackware kernel config file," these are all things I might be able to correct on the path of more lean kernels.

Last edited by Anithen; 06-11-2008 at 03:03 AM. Reason: Misspelling
 
Old 06-10-2008, 11:15 PM   #10
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Quote:
Originally Posted by Anithen
To add to all this, I never even heard of downloading special a "Slackware kernel config file," these are all things I might be able to correct on the path of more lean kernels.
The config file is really just used as a base to remove/enable options. You don't need to use one (you can just go through every option, enabling or disabling [or modularizing] every option you need), but it provides a nice working base file that you can start from. For example, if you want to make SURE that the kernel will work, don't change anything except the specific option (or few options) that you want to change and compile that. That way, you know everything else is working (because it is the default configuration that Slackware uses) and you can see if the new options make a difference. Basically, it prevents you from missing out on some obscure option that may make your system not bootable. If you know the kernel inside and out, you probably don't need this -- but I know I sure don't know about every option, so it's nice to have a working base configuration.
 
Old 06-11-2008, 11:42 PM   #11
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Original Poster
Rep: Reputation: 15
I see what you mean. I would surely like a base config, too. With this new info, I think I'll try compiling on 12+ again.

Thanks,
 
  


Reply

Tags
eth0, internet, linksys, tulip


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing internet connection Slack 10 Kernel 2.6.7 tulip driver EdwardA Linux - Networking 0 07-03-2004 09:55 AM
Two identical eth cards (tulip driver error) pgmer6809 Linux - Hardware 1 04-20-2004 01:43 AM
Tulip driver in 2.6 kernels allroy Linux - Software 2 03-17-2004 11:04 PM
tulip driver ok on Slackware 7.1 but not 9.1 geoffd3 Linux - Networking 4 12-25-2003 11:54 AM
Getting the Tulip driver working again jim64 Linux - Hardware 15 07-14-2003 05:46 AM


All times are GMT -5. The time now is 12:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration