LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2003, 02:18 PM   #1
fooforon
Member
 
Registered: Sep 2003
Posts: 37

Rep: Reputation: 15
Unhappy HELP!! trying to to join a LAN/Internet


trying to to join a LAN/Internet

so far I have downloaded and installed the NIC drivers with the command "make install" then I install the kernel module with the command "insmod 3c2000.o" then use i "lsmod" to make sure its up and it is. after thatI use "ifconfig eth0:0 192.168.1.8 netmask 255.255.255.0 route default gw 192.168.1.1" to set up my seeting but got this error

route: Host name lookup failure
ifconfig: `--help' gives usage information.

I can ping my win2k machine and I can ping the router
but I cant get onto the net .Also I would to make it so I dont have to go through this everytime i restart do I have to do this by recompling my kernel if so. what would I change this includes setting up my drivers.

well I greatly appericate any help thanks

Jamie
p.s. route and ifconfig info below


this is my route table the but it doesn't look right and Im having problems changeing it

route

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo

ifconfig

eth0 Link encap:Ethernet HWaddr 00:0C:6E:47:05:76
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:2810 (2.7 Kb) TX bytes:1558 (1.5 Kb)
Interrupt:10

eth0:0 Link encap:Ethernet HWaddr 00:0C:6E:47:05:76
inet addr:192.168.1.9 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3316 (3.2 Kb) TX bytes:3316 (3.2 Kb)

Last edited by fooforon; 09-03-2003 at 03:31 PM.
 
Old 09-03-2003, 07:41 PM   #2
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Quote:
Also I would to make it so I dont have to go through this everytime i restart do I have to do this by recompling my kernel if so. what would I change this includes setting up my drivers.
No, thankfully you don't need to recompile your kernel everytime... that would be a major pain!

Edit your /etc/rc.d/rc.modules file and insert the insmod 3c2000.o bit in it (on a line of its own).

To automatically set your eth0:1 IP, you can insert this line...

ifconfig eth0:1 192.168.1.8 netmask 255.255.255.0 route default gw 192.168.1.1

...at the end of your /etc/rc.d/rc.inet1 file.

As for not able to access the net problem, its most likely you didn't set IP resolve correctly, I'd suggest you take a look at your /etc/resolv.conf... By the way can you ping 216.239.33.99? That's the ip address for www.google.com, if you can then it's definitely a resolv.conf issue.

Hope this helps

Last edited by Azmeen; 09-03-2003 at 08:19 PM.
 
Old 09-03-2003, 07:46 PM   #3
wallison
Member
 
Registered: Jul 2003
Location: MD USA
Distribution: Slackware
Posts: 136

Rep: Reputation: 18
I've never seen an eth0:0. Even on my router that has two NICs the first one is eth0 and the second eth1. You may want to try "netconfig" as root. If that doesn't work I've set up cards before with the ifconfig and route commands as you have with a couple of minor differences. Those being in your case:

ifconfig eth0 192.168.1.8 netmask 255.255.255.0 up <enter>
route add default gw 192.168.1.1 <enter>

Then you'd have to edit your /etc/resolv.conf to include your DNS servers, and restart networking.

Last edited by wallison; 09-03-2003 at 07:53 PM.
 
Old 09-03-2003, 08:25 PM   #4
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Quote:
Originally posted by wallison
I've never seen an eth0:0. Even on my router that has two NICs the first one is eth0 and the second eth1. You may want to try "netconfig" as root. If that doesn't work I've set up cards before with the ifconfig and route commands as you have with a couple of minor differences. Those being in your case:

ifconfig eth0 192.168.1.8 netmask 255.255.255.0 up <enter>
route add default gw 192.168.1.1 <enter>

Then you'd have to edit your /etc/resolv.conf to include your DNS servers, and restart networking.
eth0:x is assigning multiple IPs to a single interface...

eg: To set interface eth0 to have IPs of 192.168.1.8 (with netmask 255.255.255.0) as well as 10.151.24.128 (with netmask 255.255.254.0) you can do this:

ifconfig eth0 192.168.1.8 netmask 255.255.255.0 up
ifconfig eth0:1 10.151.24.128 netmask 255.255.254.0 up


Then run ifconfig, you can see that your eth0 interface is now multihomed... try pinging the ip addresses you just put up.

What's the use? Ermm... maybe virtual hosts? Being a gateway to different subnets?

Hope this helps you in future implementations
 
Old 09-03-2003, 08:43 PM   #5
wallison
Member
 
Registered: Jul 2003
Location: MD USA
Distribution: Slackware
Posts: 136

Rep: Reputation: 18
Cool, thanks for the info. Not sure how I'll use it, but good to know!
 
Old 09-03-2003, 08:51 PM   #6
fooforon
Member
 
Registered: Sep 2003
Posts: 37

Original Poster
Rep: Reputation: 15
thank for the help guys I really appeciate
 
Old 09-03-2003, 09:01 PM   #7
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
No prob guys... fooforon, I assume you can now access the net?
 
Old 09-03-2003, 09:20 PM   #8
fooforon
Member
 
Registered: Sep 2003
Posts: 37

Original Poster
Rep: Reputation: 15
that was on my win machine but this in on my slack box im not sure if these setting will save for reboot but im just glad this problem is fix thanks
for adding the insmod line in can i add it at the bottom does it matter?
and same for the inet1 file?
thank again
 
Old 09-03-2003, 10:19 PM   #9
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
You can add it anywhere in the file as long as it is on its own line (ie. not appended to any existing lines). At the end of the file is good, easier for you to find also.

If should run on startup as well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help using 'net join' to join a windows domain Wapo Linux - Networking 1 04-28-2006 02:30 AM
No Internet but LAN and VPN connect LAN work fine??? xavior Suse/Novell 7 11-09-2005 01:14 PM
How to join live presentations on Internet with Linux box satimis Linux - Software 0 06-07-2005 07:06 AM
help to join 2 network ID PCs in single LAN cranium2004 Linux - Networking 2 10-27-2004 02:58 AM
Internet through LAN bajte Linux - Newbie 6 09-23-2004 07:06 AM


All times are GMT -5. The time now is 01:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration