LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-02-2012, 06:31 PM   #1
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Rep: Reputation: 36
trying to get pxe boot working, but fail when setting up tftp server


Hello everyone,
i am attempting to setup a boot server as per Alien's wiki but fail to set up the tftp server.

my /tftpboot folder contains:

Quote:
root@stargaze:~# ls -l /tftpboot/
total 46717
-r-xr-xr-x 1 root root 831 Aug 3 01:34 f2.txt*
-r-xr-xr-x 1 root root 5866144 Aug 3 01:11 huge64.s*
-r-xr-xr-x 1 root root 5719840 Aug 3 01:10 hugesmp.s*
-r-xr-xr-x 1 root root 20034257 Aug 3 01:07 initrd.img*
-r-xr-xr-x 1 root root 16133793 Aug 3 01:07 initrd64.img*
dr-xr-sr-x 6 root root 288 Aug 3 01:41 kernels/
-r-xr-xr-x 1 root root 835 Aug 3 01:35 message.txt*
-rw-r--r-- 1 root root 16466 May 13 18:36 pxelinux.0
drwxr-sr-x 2 root root 104 Aug 3 01:38 pxelinux.cfg/
my /etc/inetd.conf has the tftp line uncommented. and i always get the
TFTP E32 open timeout error.

In a bold move , I tried to run the tftp outside of inetd. so I commented the line, restarted inetd, verified udp port 69 wasn't used and started the tftp server as:

Quote:
in.tftpd -s /tftpboot -r blksize -l #th is small letter L
verified with netstat that port udp 69 was indeed occupied this time, and restarted my pxe client..
still the same error!

Finally, I did something more, i killed this tftp server, I renamed the /tftpboot folder and added a new empty /tftpboot folder in its place.Then i restarted the standalone server and I'd still get the E32 error!!!! how is this possible from an empty folder??

Thank you for your help!
 
Old 08-02-2012, 07:17 PM   #2
OldHolborn
Member
 
Registered: Jul 2012
Distribution: Slackware!
Posts: 32

Rep: Reputation: 10
Hi,

do you have a line in your hosts.allow for in.tftpd?

in.tftpd: 192.168.0.

for example?

Last edited by OldHolborn; 08-02-2012 at 07:19 PM.
 
Old 08-02-2012, 07:30 PM   #3
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,953

Rep: Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727
Be sure your /etc/dhcpd.conf is set up correctly, that error is a PXE (client) error, not a TFTP server error.

Are the DHCP and TFTP on the same machine?

[EDIT]
Other possibilities - are you sure the client is getting its DHCP data from the right machine?

Can you connect via tftp from another machine:
tftp
connect tftp-machine
get f2.txt
quit

If so it would mean that the PXE boot machine is simply not finding the TFTP machine.
[/EDIT]

Last edited by astrogeek; 08-02-2012 at 07:43 PM.
 
Old 08-02-2012, 07:42 PM   #4
OldHolborn
Member
 
Registered: Jul 2012
Distribution: Slackware!
Posts: 32

Rep: Reputation: 10
http://www.bootix.com/support/proble...n_timeout.html

It's not getting an answer from the tftp server, so either like you say, it's not looking in the right place, or it's got its fingers in its ears
 
Old 08-02-2012, 08:48 PM   #5
jefro
Guru
 
Registered: Mar 2008
Posts: 11,722

Rep: Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439
Test tftp locally and remotely from command line. Does it work?
 
Old 08-03-2012, 03:09 AM   #6
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
Hello everyone thank you for the responses.

tftp works, I can log in from another slackware in the same intranet, and get a file (like pxelinux.0 or f2.txt) from command line tftp client.

the dhcp should also be correctly setup:


Quote:
subnet 192.168.112.0 netmask 255.255.255.0 {
....more dhcp options....
allow bootp;
if substring (option vendor-class-identifier, 0, 9) = "PXEClient" {
filename "pxelinux.0";
}
next-server 192.168.122.112;
I have also tried filename "/pxelinux.0" , but it didn't make any difference.

DHCP and boot server are on the same slackware64 machine, and there is no other dhcp server on my intranet.

OldHolborn, I don't have such a line in hosts.allow, but I don't have it in hosts.deny either, so I don't think I need to place it in hosts.allow. Or am I wrong?

What do you make of all this info, docs ?
 
Old 08-03-2012, 04:08 AM   #7
OldHolborn
Member
 
Registered: Jul 2012
Distribution: Slackware!
Posts: 32

Rep: Reputation: 10
subnet 192.168.112.0
next-server 192.168.122.112;

is that a typo or deliberate?

Your DHCP is listening on one class C, the tftp server you are directing it to is on another
 
1 members found this post helpful.
Old 08-03-2012, 04:38 AM   #8
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
AAAARGGHHH
that's why I shouldn't be trying things on linux past midnight...
ok i'll go hide in a hobbit house and never come out again

I changed the value of next server - its a class C home network..

i'll verify this tonight, but i'll pretty confident that this was the problem.

Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help setting up my PXE boot server Bradj47 Linux - General 2 09-23-2011 11:10 PM
PXE Boot: tftp, ftp or http? xzased Linux - Server 3 07-29-2010 11:51 PM
HELP with Kickstart Fedora 10 NFS TFTP PXE boot server brendon_mitre Fedora 2 02-25-2009 09:53 AM
PXE, DHCP, TFTP, Working - Bootable image not!?!? almcneill Linux - Networking 4 07-25-2008 03:06 PM
PXE Boot issues - TFTP? xiaodown Linux - Server 8 07-08-2008 06:19 PM


All times are GMT -5. The time now is 10:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration