LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2007, 07:44 AM   #1
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Trying to get compiz working in Slack 12: "Another window manager"


I am trying to get compiz working on Slackware 12 in KDE. When I compiz --replace I get this error:
Quote:
compiz: Another window manager is already running on screen: 0
compiz: No manageable screens found on display :0.0
It gives me that error whether I am running kwin or not.

Can anyone help? I have already added the options to my xorg.conf.
 
Old 07-21-2007, 04:17 PM   #2
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
Same problem. Have googled much and all queries about it were not answered -- just silence. Seems like everybody is asking about a very common thing, but there is no answer could be found.
 
Old 07-21-2007, 04:56 PM   #3
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
Hi
Try
Code:
compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom kde-window-decorator &
 
Old 07-22-2007, 05:41 AM   #4
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
Yes we re speaking about this command. Exact this comand causes and error:
Code:
compiz: Another window manager is already running on screen: 0
compiz: No manageable screens found on display :0.0
And is should be run separate:
Code:
compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom && kde-window-decorator &
 
Old 07-22-2007, 10:20 AM   #5
AriciU
Member
 
Registered: Jul 2007
Location: Bucharest, Romania
Distribution: Ubuntu 7.04, Slackware 12
Posts: 87

Rep: Reputation: 15
If using XFCE, right click on desktop / settings / window manager tweaks and disable Compositing.

If there is no compositing menu or not running xfce check xorg.conf for the line

Section "Extensions"
Option "Composite" "Enable"
EndSection

Add it to the end if it's not present. I'm running fusion without any problems but didn't use the older Compiz that comes with Slack so i can't really help more then this.
 
Old 07-22-2007, 02:44 PM   #6
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
I am using KDE, not XFCE. Is there an option for that?

Like I said, I added the lines to xorg.conf.
 
Old 07-22-2007, 05:25 PM   #7
AriciU
Member
 
Registered: Jul 2007
Location: Bucharest, Romania
Distribution: Ubuntu 7.04, Slackware 12
Posts: 87

Rep: Reputation: 15
Yeah, there is probably a compositing option in KDE that is enabled and it can't be overridden by compiz i guess. That's the case with XFCE's compositing option anyway. I never used KDE so i can't tell you where it is but search the forums or search for it and you'll find it sooner or later...

Found some pictures some time ago with KDE with transparency enabled and stuff like that so there must be a composite option somewhere in there.
 
Old 07-23-2007, 01:35 PM   #8
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
AriciU, there is a KDE compositing program called kompmgr. I tried compiz both with it disabled and enabled and neither work, I still get the same message.
 
Old 07-23-2007, 02:41 PM   #9
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
Same with me.
 
Old 07-23-2007, 04:13 PM   #10
AriciU
Member
 
Registered: Jul 2007
Location: Bucharest, Romania
Distribution: Ubuntu 7.04, Slackware 12
Posts: 87

Rep: Reputation: 15
Try doing "compiz --replace ccp". That's the command used for the newer compiz fusion... maybe it'll work.
 
Old 07-23-2007, 06:56 PM   #11
hollywoodb
Member
 
Registered: Aug 2003
Location: Minnesota, U.S.A.
Distribution: Debian, openSUSE
Posts: 400

Rep: Reputation: 30
Once you've got your xorg.conf set up properly (make sure Composite and AIGLX are enabled and say so in /var/log/Xorg.0.log) you can use these scripts to start compiz:

http://files.offbeatlounge.com/compiz/

They're very simple bash scripts, you can run the commands manually as well. They have a "LIBGL_ALWAYS_INDIRECT=TRUE" in them which afaik is only necessary for some Intel cards like the i915.

In order to use the KDE script and have Compiz work with KDE you need to get rworkman's packages:

http://www.slackware.com/~rworkman/compiz/

kde-window-decorator is NOT part of the stock slackware packages. gtk-window-decorator is.

Last edited by hollywoodb; 07-23-2007 at 06:57 PM.
 
Old 07-23-2007, 07:40 PM   #12
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by hollywoodb
In order to use the KDE script and have Compiz work with KDE you need to get rworkman's packages
It should work without any patches. I refer you to this thread:
http://www.linuxquestions.org/questi...d.php?t=567635

While compiz is nice to look at, I found that it quickly became annoying.
 
Old 07-23-2007, 07:41 PM   #13
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
OK, I enabled AIGLX. I have added these lines to xorg.conf:

Code:
Section "Device"
        Option      "RenderAccel" "true"
        Option      "AllowGLXWithComposite" "true"
        Option      "DRI"     "true"
        Option      "XAANoOffscreenPixmaps" "true"
        Option      "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        DefaultDepth 24
        Option "AllowGLXWithComposite" "true"
        Option "DisableGLXRootClipping" "true"
        Option "AddARGBGLXVisuals" "true"
EndSection

            Section "Extensions"
        Option "Composite" "enable"
EndSection

Section "DRI"
        Group 0
        Mode 0666
EndSection

Section "ServerFlags"
        Option  "AIGLX" "on"
EndSection
I still get the same error. Should I conclude that using compiz with KDE is not possible?
 
Old 07-23-2007, 07:43 PM   #14
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by Wynd
Should I conclude that using compiz with KDE is not possible?
Well if it's not possible, I must have been dreaming...
 
Old 07-24-2007, 07:16 AM   #15
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by rkelsen
Well if it's not possible, I must have been dreaming...
Haha, you must have posted that right after I left.

I tried the stuff in that thread, but still no luck. I noticed someone in there had the same problem as me, but I didn't see any answers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
download manager "Kget" not working after i removed some pkgs b0nd Slackware 9 01-04-2006 06:53 AM
"The KDE Window Manager" box keeps poping up at the top left... HELP HOLLYW00D Suse/Novell 2 04-23-2005 11:26 AM
Adding a window manager to "choose a session" menu in Fedora jon_k Linux - Software 0 10-17-2004 01:53 PM
Mandrake 9.1 hangs at "Building Window Manager Sessions" Aadilya Linux - Distributions 1 02-27-2004 04:07 AM
"Windows Like" Window Manager muah Linux - General 10 01-23-2004 12:06 PM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration