LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2006, 08:15 PM   #1
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Unhappy trouble with the way man pages are displayed


i'm having an issue with the way my man pages are displaying from my xterm... they seem to display fine from a console (runlevel 3), but when i'm in X11, and i look at a man page from my xterm, they display in an awkward manner... for example, here's a snippet of what a "man diff" looks like:
Code:
DIFF(1)                          User Commands                         DIFF(1)

NAME
iff - compare files line by line

SYNOPSIS
diffOPTION]... FILES

DESCRIPTION
ompare files line by line.

       -i--ignore-case
gnore case differences in file contents.

       --ignore-file-name-case
gnore case when comparing file names.
see how the text is like cut off to the left and stuff??

i'm sure i messed something up somewhere but i can't figure-out what, and i'm not exactly sure where to look... so far i've recompiled man, groff, and x11 with no luck...

any guidance you could give me with this issue would be most appreciated...

thanks in advance...
 
Old 04-09-2006, 08:50 PM   #2
edavis
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.0
Posts: 8

Rep: Reputation: 0
Does this happen in any other terminal emulators such as aterm, rxvt, konsole or gnome-terminal?
 
Old 04-09-2006, 08:53 PM   #3
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
i just tried with xfterm4 and yeah, it happens there also...
 
Old 04-09-2006, 09:07 PM   #4
edavis
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.0
Posts: 8

Rep: Reputation: 0
I'd suggest removepkg man groff and installpkg'ing those again from Pat's vanilla packages. Something could of gotten screwy. Have you updated anything big lately? Does this happen in all man pages or just a select few?
 
Old 04-09-2006, 09:36 PM   #5
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
okay, i might test with patrick's packages in a minute...

meanwhile, i'm am starting to suspect that libtermcap might have something to do with this... any thoughts on that?? i uninstalled it a few days ago during a cleanup... so right now i installed libtermcap again and i recompiled groff and man but still no luck... however, if the problem is with the terminals themselves (and not groff/man) then perhaps i need to recompile X11 (xterm) in order for it to work?? hmmm, well, i'm gonna do some googling before i recompile X11 again cuz on my box it takes about an hour and 15 minutes to compile X11... hehe...

in response to your questions: yeah, i've updated lots of stuff during the past weeks, but i can't remember exactly when the man pages started getting messed-up...

and yeah, it seems to happen to all man pages... here's some more snippets for your enjoyment :

Code:
NAME
quid - proxy caching server

SYNOPSIS
squid  -dhsvzCDFNRVYX [ -lfacility ] [ -fconfig-file ] [ -[ au
       port ] [ -ksignal

DESCRIPTION
squids a high-performance proxy caching server for web clients,  sup-
       porting FTP, gopher, and HTTP data objects.  Unlike traditional caching
       software, squidandles all requests in a  single,  non-blocking,  I/O-
       driven process.

       squideeps meta data and especially hot objects cached in RAM, caches
       DNS lookups, supports non-blocking DNS lookups, and implements negative
       caching of failed requests.
Code:
NAME
p - copy files and directories

SYNOPSIS
cp[options]file path
       cp[options]file... directory

       POSIX options: [-fiprR][--]

dditional POSIX 1003.1-2003 options: [-HLP]

NU file-utils 4.0 options (shortest form):
       [-abdfilprsuvxPR][-SSUFFIX][-V{numbered,existing,simple}]
[--backup=CONTROL][--sparse=WHEN][--help][--version][--]

dditional GNU file-utils 4.1 options (shortest form):

Code:
NAME
etstat  - Print network connections, routing tables, interface statis-
       tics, masquerade connections, and multicast memberships

SYNOPSIS
netstataddress_family_options]  [--tcp-t   [--udp-u   [--raw-w
       [--listening-l [--all-a [--numeric-n [--numeric-hosts[umeric-
       ports]--numeric-ports   [--symbolic-N    [--extend-e--extend-e]
       [--timers-o [--program-p [--verbose-v [--continuous-c]

netstat--route-r              [address_family_options]
       [--extend-e--extend-e]  [--verbose-v  [--numeric-n  [--numeric-
hosts[umeric-ports]--numeric-ports [--continuous-c]

netstat--interfaces-i [iface] [--all-a [--extend-e--extend-e]
       [--verbose-v      [--program-p      [--numeric-n      [--numeric-
hosts[umeric-ports]--numeric-ports [--continuous-c]
BTW, thanks for your input!!!
 
Old 04-09-2006, 10:18 PM   #6
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
okay, well, i was thinking bash itself might have something to do with it... so after installing libtermcap i went ahead and recompiled bash to see if it made any difference... the man page problem still happens, but i can see that, at least, bash enjoyed the libtermcap install:
Code:
bash-3.1$ ldd /bin/bash 
        libtermcap.so.2 => /lib/libtermcap.so.2 (0x4001e000)
        libdl.so.2 => /lib/libdl.so.2 (0x40022000)
        libc.so.6 => /lib/libc.so.6 (0x40027000)
        /lib/ld-linux.so.2 (0x40000000)
UPDATE: just tried with patrick's groff/man packages for 10.2 and no luck...

Last edited by win32sux; 04-09-2006 at 10:43 PM.
 
Old 04-09-2006, 10:50 PM   #7
edavis
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.0
Posts: 8

Rep: Reputation: 0
Some greps in /var/log/packages/ shows that libtermcap.so.2 is actually installed in the aaa_elflibs package. I don't know libtermcap well enough, so maybe this is normal but even after I removepkg libtermcap I was able to view man pages and run bash without a hitch. So I don't believe libtermcap is the problem. I still think it has something to do with groff and/or man (maybe even less for all I know). I'm still sticking to my suggestion of removing man and groff and just installing them again. You shouldn't have to recompile X. If it was only happening in xterm then I'd suggest it but if the problem is terminal emulator neutral then it's something with the programs they're calling. Just my two cents, good luck.

UPDATE: Just read your edit, so nevermind about my suggestion. I'll keep poking around google but I don't have a clue anymore.

Last edited by edavis; 04-09-2006 at 10:54 PM.
 
Old 04-10-2006, 01:25 AM   #8
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
yeah, recompiling X11 didn't help... i also recompiled XFCE just in case... nothing... well, i'm wasted for today... i'll keep at it tomorrow though... i'll keep you posted... if you think of anything please do post... once again, thanks for all your help...
 
Old 04-10-2006, 06:09 AM   #9
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
What is TERM variable set to?
echo $TERM
Try changing it, e.g. if it is set to xterm then change it to linux or visa-versa.

<edit> You can also try turning on or off the auto-margin by adding -am or -nam to the $TERM variable for auto-margin or no-auto-margin respectivly.

http://www.linuxmanpages.com/man7/term.7.php

Last edited by /bin/bash; 04-10-2006 at 06:11 AM.
 
Old 04-10-2006, 10:26 AM   #10
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by /bin/bash
What is TERM variable set to?
echo $TERM
Try changing it, e.g. if it is set to xterm then change it to linux or visa-versa.

<edit> You can also try turning on or off the auto-margin by adding -am or -nam to the $TERM variable for auto-margin or no-auto-margin respectivly.

http://www.linuxmanpages.com/man7/term.7.php
thanks man!!! that seems to have been it!!!

if i do a
Code:
TERM=linux
then the pages display properly...

if i then go back to what i had (xterm) with a:
Code:
TERM=xterm
then the pages display in the awkward manner again...

so now i'm reading the link you posted in an effort to understand what might have caused this change on my system in the first place, and of course how to change it back permanently and stuff...

thanks a million!!!
 
Old 04-10-2006, 10:54 AM   #11
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
when you guys open an xterm and do a:
Code:
echo $TERM
what do you get??

after a fresh boot, i get "linux" when i do it at a console (runlevel 3) but i get "xterm" when i do it from my xterm in X11 (runlevel 4)...

Last edited by win32sux; 04-10-2006 at 10:57 AM.
 
Old 04-10-2006, 12:13 PM   #12
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
been tryin' to figure-out how to change the value of $TERM to "linux" for X11 sessions on a system-wide level but no luck... i'd like to make it so that it gets set for all users... could you show me how to do this?? which file must i edit??
 
Old 04-10-2006, 01:25 PM   #13
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
well i think i found out how to change $TERM to "linux" for all X11 sessions... i did it by opening the /usr/X11/bin/startx file and changing this:
Code:
clientargs=""
to this:
Code:
clientargs="-tn linux"
from "man xterm":
Quote:
-tn name
This option specifies the name of the terminal type to be set
in the TERM environment variable. It corresponds to the
termName resource. This terminal type must exist in the termi-
nal database (termcap or terminfo, depending on how xterm is
built) and should have li# and co# entries. If the terminal
type is not found, xterm uses the built-in list ``xterm'',
``vt102'', etc.
the problem is that it apparently made X11 load without a window manager... so it was quite a weird and interesting sight indeed... hehe... kinda like a stripped-down version of twm...

so i guess this kinda thing isn't set for the entire X11 session... i can always start an xterm within X11 by using "xterm -tn linux" and then it works fine, though... i just thought it would be more kosher to make it so that whenever a user executes "xterm" they will have that term open with a $TERM value of "linux" so that everything displays properly (specially man pages)...

Last edited by win32sux; 04-10-2006 at 01:58 PM.
 
Old 04-10-2006, 01:43 PM   #14
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
That's strange. I have TERM set as xterm and everything works normally in xterm (man pages too). Just tried for curiosity.
 
Old 04-10-2006, 01:47 PM   #15
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
okay, i came-up with a cheap/stupid work-around...

basically, i created a shell script ( /usr/bin/xterm ) which contains the following:
Code:
#!/bin/bash
/usr/bin/X11/xterm -tn linux "$@" &
so now when someone executes "xterm", that script will get run and it will run the real xterm with the -tn linux option... hence, the xterm will open with the $TERM variable set to "linux"...

Last edited by win32sux; 04-10-2006 at 02:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
web pages displayed on one machine but not other phoenixenigma Linux - Software 3 02-23-2006 02:54 PM
man pages? synaptical Debian 4 06-13-2005 09:16 PM
trouble with man pages buffed317 Linux - General 9 02-28-2005 06:10 PM
Trouble Accessing man pages John Parsons Linux - Newbie 10 02-04-2005 05:16 PM
can't see man pages Elbolton Linux - Newbie 5 03-07-2002 12:14 AM


All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration