LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2014, 09:48 PM   #1
Ztcoracat
Senior Member
 
Registered: Dec 2011
Distribution: Slackware, CentOS & Android
Posts: 3,250
Blog Entries: 1

Rep: Reputation: Disabled
Trouble with the /etc/wpa_supplicant.conf file


Hi:

I installed Slackware 14 on my desktop pc following along with this video.
https://www.youtube.com/watch?v=JnggjPFtRCQ

In that video the man did not choose DHCP instead he choose Network Manager so I did too. (thinking it was the right thing to do)

I'm reading this documentation to configure my WPA wireless network.
http://docs.slackware.com/slackbook:wifi

Upon using vi or nano to edit the /etc/wpa_supplicant.conf file I only have these 2 arguments:
ctrl-interface=/var/run/spa_supplicant
ctrl-interface-group=root

This example is one the page I linked so I'm using this-

Code:
#WPA protected network, supply your ESSID & WPAPSK
network={
scan ssid=1
ssid= (type in my network name)
key-mgnt=WPA-PSK
PSK=(my passphrase)
This information (above in code tags)is not in my file. Do I need to type this into the file?

Last edited by Ztcoracat; 04-30-2014 at 09:51 PM. Reason: Type code in bold
 
Old 04-30-2014, 11:45 PM   #2
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,629
Blog Entries: 15

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
NetworkManager will do this for you through the UI. Just enter the information and it'll use the appropriate files.
 
Old 05-01-2014, 12:07 AM   #3
Ztcoracat
Senior Member
 
Registered: Dec 2011
Distribution: Slackware, CentOS & Android
Posts: 3,250
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
When I click on the Network Manager it's not accessible. (it doesn't launch)

I found the RTL8191SE Realtek driver for my chipset but it's not installed. (have to learn how)

Maybe that's why Network Manager isn't working?
 
Old 05-01-2014, 12:21 AM   #4
Ztcoracat
Senior Member
 
Registered: Dec 2011
Distribution: Slackware, CentOS & Android
Posts: 3,250
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Good news. I don't know what I did but my wireless is working now.-

I didn't have to edit the /etc/wpa_supplicant.conf file at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble increasing screen resolution to 1024x800 in Ubuntu - no xorg.conf file! Theruchet Linux - Newbie 8 03-08-2011 01:15 AM
How do I configure wpa_supplicant.conf? xpto09 Linux - Networking 2 08-09-2009 10:27 AM
wpa_supplicant.conf build an0nymous Linux - Networking 3 07-06-2009 09:13 AM
How do I modify wpa_supplicant.conf JibberingJ Slackware 2 04-15-2009 08:07 AM
where is wpa_supplicant.conf? rshields9093 Ubuntu 1 09-14-2006 01:10 AM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration