LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Trouble with New Wireless Config Files After Upgrade to 14.0 (http://www.linuxquestions.org/questions/slackware-14/trouble-with-new-wireless-config-files-after-upgrade-to-14-0-a-4175450389/)

derstephen 02-16-2013 02:39 AM

Trouble with New Wireless Config Files After Upgrade to 14.0
 
Hello,

Just a warning: This is yet another wireless question. I did a quick search in this forum for my particular problem and tried some of the suggestions in other threads, but I haven't gotten any further.

I've just finished upgrading from Slackware64 13.37 to Slackware64 14.0 on my laptop (Lenovo V570 with Intel Wireless_N + WiMax 6150 Network Controller). Everything looks fine so far except my wireless configuration no longer seems to work. I noticed that in Pat's small script in the UPGRADE.TXT for installing the new config files and renaming the old ones *.bak (which I used), the rc.inet1.conf.new is explicitly excluded from it. This seems to suggest that there is a separate protocol for upgrading that config file, but I can't find a how-to for it.

I went into the rc.inet1.conf.new and uncommented the same lines that were uncommented in my old one and renamed it to just rc.inet1.conf. But with the new wpa_supplicant.conf I noticed that it only had two lines: ctrl_interface=/var/run/wpa_supplicant and ctrl_interface_group=root. These were literally the only two lines in the file as opposed to the old one, which had many fields including the two I used: the ssid and psk fields. So now I'm wondering: is wpa_supplicant now deprecated?

Right now I have debugging enabled in rc.inet1.conf, and /var/log/messages reveals that whatever connection dhcpcd establishes gets dropped right away (alternating "carrier acquired" and "carrier lost" messages) and NetworkManager saying my "supplicant interface state" for wlan0 is "disconnected -> inactive" (this is the contents after I run "/etc/rc.d/rc.inet1 wlan0_restart").

"iwlist wlan0 scan" does see my network, along with the surrounding ones.

With 13.37 all I had to do with my chipset was uncomment a few lines in rc.inet1.conf (along with providing the ssid) and fill in a couple of fields in wpa_supplicant.conf and I was good to go, so I'm pretty sure this isn't a hardware issue. I'm assuming I did something wrong with replacing the config files. Thank you for any help and let me know if you would like any more info.

derstephen 02-16-2013 03:14 PM

Still at it.

Just in the interest of providing more info, these are the uncommented lines in my /etc/rc.d/rc.inet1.conf (the same ones that worked for me on 13.37):

Code:

IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]="Home"
WLAN_WPA[4]="wpa_supplicant"

And this is my /etc/wpa_supplicant.conf (after following the steps in /usr/docs/wpa_supplicant-1.0/README.slackware):
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root

network={
  scan_ssid=0
  proto=WPA
  key_mgmt=WPA_PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40

  ssid="Home"
  #psk="<my-network-password>"
  psk=<hex-version-of-network-password-from-wpa_passphrase-command>
}

The five lines in the "network={" section were copied directly from /usr/docs/wpa_supplicant-1.0/README.slackware, as directed.

I've also been looking at some debugging output using commands found in Alien Bob's guide.

Running "wpa_supplicant" with debugging in a separate terminal while start my interface yields a repeated "CTRL_IFACE - wlan0 - wait for monitor to attach" every second or two until I stop the interface again.

I also tried this:
Code:

#: wpa_cli -i wlan0 status
wpa_state-SCANNING

When I reboot the machine, I can see that dhcpcd finds an address (probably from some other network in my area) and leases it (although I still can't actually use a web browser or ping anything).

derstephen 02-16-2013 06:37 PM

Last update before I officially run out of ideas:

I started up the interface and ran wpa_cli, and at the prompt I get a bunch of repetitive output:
Code:

<3>WPS-AP-AVAILABLE
<3>Trying to associate with 58:6d:8f:23:fb:38 (SSID='Home' freq=2462 MHz)
<3>Associated with 58:6d:8f:23:fb:38
<3>CTRL-EVENT-DISCONNECTED bssid=58:6d:8f:23:fb:38 reason=0

Those same four lines print themselves out every second or so until I close wpa_cli or stop the interface.

I've untarred my pre-upgrade /etc directory that I backed up before the upgrade to verify that my new config files match the old ones, and they do.

I think I've pretty much exhausted any general procedures I could find on the Internet that look like that are at least remotely related to my issue. I still have my Windows partition to boot into if I need WiFi, and I can still try Slackware at a public hotspot to see if the problem is indeed limited to the updated wpa_supplicant (as I suspect it is) or perhaps the iwlwifi driver.

Everything else looks fine after the upgrade though...

Marcelo_Belfalas 02-16-2013 06:59 PM

Well, if you're using both rc.inet1 and NetworkManager the problem probably is that both are conflicting, try to disable one of them.

For example, try to comment back the lines in rc.inet1.conf or stop the service and connect only through NetworkManager.

derstephen 02-16-2013 09:23 PM

Wow...I killed the NetworkManager process and restarted my interface and it worked!

I checked my old rc.M.bak script and saw that it didn't start NetworkManager, just inetd, so I decided to comment out the part of the new script that starts wicd and NetworkManager to give inetd free reign over my connection since I'm more familiar with it than with NetworkManager. I rebooted and everything's running smoothly now.

So a big thank you to you Marcelo!

And out of curiosity...why does the rc.M script start both of these programs if they don't work together? Or is it just something peculiar to my particular chipset?

psionl0 02-16-2013 11:07 PM

Quote:

Originally Posted by derstephen (Post 4893386)
And out of curiosity...why does the rc.M script start both of these programs if they don't work together? Or is it just something peculiar to my particular chipset?

The rc.M script only starts wicd or NetworkManager if rc.wicd or rc.networkmanager are executable so you don't need to delete them from the script - just chmod -x the scripts.

Didier Spaier 02-16-2013 11:14 PM

Quote:

Originally Posted by derstephen (Post 4893386)
And out of curiosity...why does the rc.M script start both of these programs if they don't work together?

It doesn't. If rc.wicd is executable it won't probe rc.networkmanager.

Marcelo_Belfalas 02-17-2013 07:11 AM

Actually, he's talking about inet1 and networkmanager, the rc.M starts both, but it isn't a bug since inet1 can be used to configure wireless and lan cards, maybe Patrick should add a warning in rc.inet1 to show that it conflicts with networkmanager and wicd.

Didier Spaier 02-17-2013 08:06 AM

Quote:

Originally Posted by Marcelo_Belfalas (Post 4893590)
Actually, he's talking about inet1 and networkmanager

You are right, I didn't read carefully enough, my bad.

Besides that, in Slackware 14 'netconfig' suggests:
Quote:

You may also select 'NetworkManager' if you would like to have the NetworkManager daemon automatically handle your wired and wireless network interfaces (this is simple and usually works). Which type of network setup would you like?
Of course if the user chooses the NetworkManager option, 'netconfig' will take care of the configuration and there will be no conflict.

The problem actually arose because here the user upgraded from 13.37 thus didn't run 'netconfig'.

A warning about that *could* have been included in UPGRADE.TXT or CHANGES_AND_HINTS.TXT, but there are probably to many possible issues during an upgrade to list them exhaustively in one of these files.

allend 02-17-2013 08:25 AM

Quote:

The problem actually arose because here the user upgraded from 13.37 thus didn't run 'netconfig'.
Actually the problem here arose because the user did not read the mail to root from Patrick Volkerding with the header "Welcome to Linux (Slackware 14.0)!" after the upgrade.
Quote:

With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.

allend 02-17-2013 08:25 AM

Duplicate post

Didier Spaier 02-17-2013 08:38 AM

Quote:

Originally Posted by allend (Post 4893617)
Actually the problem here arose because the user did not read the mail to root from Patrick Volkerding with the header "Welcome to Linux (Slackware 14.0)!" after the upgrade.

You are right, but I guess that the probability for an average user to have read this mail is close to the one for him or her to have read this old tweet from Patrick Volkerding which triggered a heated discussion recently ;)

allend 02-17-2013 08:52 AM

Pour Slackware, c'est la vie!


All times are GMT -5. The time now is 05:49 AM.