LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-05-2012, 03:44 AM   #1
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
trouble running amaya slackbuild


I got an error running the amaya slackbuild script from slackbuilds.org.

Here are the last few lines before the error:

Code:
Amaya11.3.1/freetype/src/autofit/afhints.h
Amaya11.3.1/freetype/vms_make.com
Amaya11.3.1/freetype/autogen.sh
patching file src/gtk/gsockgtk.cpp
patching file Amaya/thotlib/base/platform.c
patching file Amaya/amaya/HTMLedit.c
./amaya.SlackBuild: line 83: ../configure: Permission denied
In the amaya.SlackBuild script, the area where the error occurs:

Code:
mkdir -p Amaya/build
cd Amaya/build
  CFLAGS="$SLKCFLAGS" \
  CXXFLAGS="$SLKCFLAGS" \
  ../configure \
    --prefix=/opt/ \
    --libdir=/usr/lib${LIBDIRSUFFIX} \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --mandir=/usr/man \
    --docdir=/usr/doc/$PRGNAM-$VERSION \
    --with-gl \
    --with-wxsrcdir=../../wxWidgets/ \
    --enable-system-raptor \
    --build=$ARCH-slackware-linux
  make wxwidgets || exit 1
  make all || exit 1
  make install DESTDIR=$PKG || exit 1
cd ..
I am running this as root. Any idea what would cause the permission eror?
 
Old 09-05-2012, 04:04 AM   #2
sorinm
Member
 
Registered: Jul 2012
Location: RO
Distribution: Slackware64-14.0
Posts: 65

Rep: Reputation: Disabled
chmod +x amaya.SlackBuild
 
Old 09-05-2012, 04:09 AM   #3
414N
Member
 
Registered: Sep 2011
Location: Italy
Distribution: Slackware
Posts: 609

Rep: Reputation: 180Reputation: 180
The configure script inside the source tarball probably lacks the executable permission.
Try prepending it with sh to force the shell to read it:
Code:
sh ../configure [...]
 
Old 09-05-2012, 05:08 AM   #4
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Original Poster
Rep: Reputation: 157Reputation: 157
Quote:
Originally Posted by sorinm View Post
chmod +x amaya.SlackBuild
The script already has execute permission bit turned on.

Quote:
Originally Posted by 414N View Post
The configure script inside the source tarball probably lacks the executable permission.
Try prepending it with sh to force the shell to read it:
Code:
sh ../configure [...]
That worked a little. It got further before it died.

Code:
Amaya11.3.1/freetype/src/autofit/afglobal.h
Amaya11.3.1/freetype/src/autofit/afhints.h
Amaya11.3.1/freetype/vms_make.com
Amaya11.3.1/freetype/autogen.sh
patching file src/gtk/gsockgtk.cpp
patching file Amaya/thotlib/base/platform.c
patching file Amaya/amaya/HTMLedit.c
checking build system type... i486-slackware-linux-gnu
checking host system type... i486-slackware-linux-gnu
checking target system type... i486-slackware-linux-gnu
checking whether make sets $(MAKE)... yes
checking for bison... bison -y
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
Here is the relevant section from config.log

Code:
configure:2400: gcc -v >&5
Reading specs from /usr/lib/gcc/i486-slackware-linux/4.5.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.5.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.5.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-boo
tstrap --enable-languages=ada,c,c++,fortran,java,objc,lto --enable-threads=posix --enable-checking=release --with-system-zlib --with-pytho
n-dir=/lib/python2.6/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbo
se --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.5.2 (GCC) 
configure:2403: $? = 0
configure:2410: gcc -V >&5
gcc: '-V' option must have argument
configure:2413: $? = 1
configure:2436: checking for C compiler default output file name
configure:2463: gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
configure:2466: $? = 0
configure:2504: result: a.out
configure:2521: checking whether the C compiler works
configure:2531: ./a.out
../configure: line 2532: ./a.out: Permission denied
configure:2534: $? = 126
configure:2543: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.

I wonder if this is being caused by my recent change to how /tmp is mounted? That's where the SBo directory is located. I added this line to fstab and rebooted right before running this SlackBuild.

Code:
tmpfs            /tmp             tmpfs       defaults,noexec,nosuid,mode=1777         0   0
I believe I'll have to reboot to remove the noexec and nosuid.

In the meantime, I changed the TMP and OUTPUT directories in the SlackBuild script to point to another directory instead of to /tmp, and that worked. So it does seem that either the noexec or nosuid or the fact that I added /tmp to fstab (it wasn't there before) caused the problem.

Thank you all for your help.
 
Old 09-05-2012, 05:17 AM   #5
sorinm
Member
 
Registered: Jul 2012
Location: RO
Distribution: Slackware64-14.0
Posts: 65

Rep: Reputation: Disabled
You don`t have glibc installed.
 
Old 09-05-2012, 05:22 AM   #6
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Original Poster
Rep: Reputation: 157Reputation: 157
glibc is installed. See my previous post. The problem must be related to my addition of /tmp to fstab. I got it to work by changing the TMP and OUTPUT directories in the SlackBuild to point them outside of /tmp.

Code:
i@am:/var/log/packages$ ls -al glibc*
-rw-r--r-- 1 root root 316709 Sep  4 18:07 glibc-2.13-i486-6_slack13.37
-rw-r--r-- 1 root root 228163 Sep  4 18:08 glibc-i18n-2.13-i486-6_slack13.37
-rw-r--r-- 1 root root   1015 Sep  4 18:08 glibc-profile-2.13-i486-6_slack13.37
-rw-r--r-- 1 root root   7827 Sep  4 18:06 glibc-solibs-2.13-i486-6_slack13.37
-rw-r--r-- 1 root root  69769 Sep  4 18:08 glibc-zoneinfo-2.13-noarch-6_slack13.37

Last edited by Z038; 09-05-2012 at 05:23 AM.
 
Old 09-05-2012, 06:29 AM   #7
414N
Member
 
Registered: Sep 2011
Location: Italy
Distribution: Slackware
Posts: 609

Rep: Reputation: 180Reputation: 180
Quote:
Originally Posted by Z038 View Post
I wonder if this is being caused by my recent change to how /tmp is mounted? That's where the SBo directory is located. I added this line to fstab and rebooted right before running this SlackBuild.

Code:
tmpfs            /tmp             tmpfs       defaults,noexec,nosuid,mode=1777         0   0
I believe I'll have to reboot to remove the noexec and nosuid.

In the meantime, I changed the TMP and OUTPUT directories in the SlackBuild script to point to another directory instead of to /tmp, and that worked. So it does seem that either the noexec or nosuid or the fact that I added /tmp to fstab (it wasn't there before) caused the problem.

Thank you all for your help.
There's little to wonder about, you denied executable permissions under /tmp...
 
Old 09-05-2012, 05:34 PM   #8
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Original Poster
Rep: Reputation: 157Reputation: 157
That must be it. The configure file was copied to a directory under /tmp, then the SlackBuild attempted to execute it there.

I've come across a number of recommendations for giving /tmp the noexec attribute, but I think it will cause me more problems than it solves, so I'm going to take it back off. I could avoid using /tmp for SlackBuilds, but there may be other things that use it for executables.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware64 wysiwyg web page editor / Amaya running ? bgeddy Slackware 8 03-11-2010 10:45 AM
errors running a slackbuild. garyg007 Linux - Software 5 01-12-2009 11:26 AM
trouble with slackbuild madwifi--file does not end in .tgz madwida Slackware 19 10-09-2008 04:44 AM
Slackbuild MPlayer trouble installing DaveXensen Linux - Desktop 1 02-13-2007 02:29 PM
Trouble with my first SlackBuild script Yalla-One Slackware 6 06-10-2006 02:03 PM


All times are GMT -5. The time now is 07:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration