LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Triple boot lilo problem Win7, fedora, slackware (http://www.linuxquestions.org/questions/slackware-14/triple-boot-lilo-problem-win7-fedora-slackware-911724/)

tamtam 11-03-2011 02:35 PM

Triple boot lilo problem Win7, fedora, slackware
 
Hi Guys,

Searched the forums for the answer to this. No luck I am afraid. Trying to boot Windows and Fedora from lilo in slackware.

First disk /dev/sda contains Windows split into two partitions.
Quote:

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x9cbbc58a

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 810807295 405402624 7 HPFS/NTFS/exFAT
/dev/sda2 810807296 1250263039 219727872 7 HPFS/NTFS/exFAT

Second disk contains both Fedora and Slackware. Fedora root is on first partition sdb1, second is swap sdb2, third is fedora /home sdb3, fourth is slackware root sdb5, sixth is slackware /home sdb6 and finally sdb7 is shared data.

Quote:

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000ed43c

Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 61442047 30720000 83 Linux
/dev/sdb2 61442048 66562047 2560000 82 Linux swap
/dev/sdb3 66562048 271362047 102400000 83 Linux
/dev/sdb4 271362048 976773167 352705560 5 Extended
/dev/sdb5 271362111 329951102 29294496 83 Linux
/dev/sdb6 329951166 622912442 146480638+ 83 Linux
/dev/sdb7 622912506 976773167 176930331 83 Linux

Here is the relevant bits of lilo.conf
Quote:

# End LILO global section
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = /dev/sda
# Windows bootable partition config ends
# Slackware bootable partition config begins
image = /boot/vmlinuz
root = /dev/sdb5
label = Slackware
read-only
# Slackware bootable partition config ends
# Fedora bootable partition config begins
other = /dev/sdb1
label = Fedora
# table = /dev/sdb
# Fedora bootable partition config ends
I am able to boot into Slackware and Windows no problem, but not able to boot into Fedora. Slackware lilo is configured on the MBR of sda and Fedora is configured on the MBR of sdb1.

If I change the boot order after rebooting I can load Fedora so it does boot okay. Only not from lilo.

Output of running lilo from the terminal with the above configuration file in slackware.
Quote:

xxx@xxxx:/home/xxx# lilo
Warning: LBA32 addressing assumed
Warning: The boot sector and map file are on different disks.
Added Windows *
Added Slackware
Added Fedora
2 warnings were issued.

colorpurple21859 11-03-2011 02:55 PM

for fedora mount the fedora root partiiton to /mnt and modify /etc/lilo.conf for fedora to look something like this, I don't use fedora so I don't know its kernel naming convention and or if an initrd is used.
Quote:

image = /mnt/boot/vmlinuz
initrd = /mnt/boot/initrd.img
root = /dev/sdb1
label = fedora
read-only
for windows the entry will be similar to this
Quote:

other = /dev/sda1
label = Windows
chainloader +1
If you have grub installed some where from your fedora installation you can also chainload to it to boot fedora

tamtam 11-04-2011 07:34 AM

Okay - have tried various different things to try and add fedora to lilo.conf and to boot from lilo. First attempt screwed up Fedora so much that a reinstall was required.
Prior to breaking Fedora Fedora's boot directory contained the following
Quote:

-rw-rw-r--. 1 root root 13938797 Nov 3 15:01 initramfs-2.6.38.6-26.rc1.fc15.i686.img
-rw-r--r--. 1 root root 14586153 Nov 3 16:37 initramfs-2.6.40.6-0.fc15.i686.img
-rwxr-xr-x. 1 root root 3804304 May 9 21:48 vmlinuz-2.6.38.6-26.rc1.fc15.i686
-rwxr-xr-x. 1 root root 3914176 Oct 4 01:56 vmlinuz-2.6.40.6-0.fc15.i686
Plus grub directory and others.

After a reinstall of Fedora with the same discs, vmlinuz-2.6.40.6-0.fc15.i686 and initramfs-2.6.40.6-0.fc15.i686.img were no longer present in the Fedora boot directory.
Quote:

-rw-r--r--. 1 root root 120086 May 9 21:48 config-2.6.38.6-26.rc1.fc15.i686
drwxr-xr-x. 3 root root 4096 May 13 20:45 efi
-rw-r--r--. 1 root root 179044 Mar 15 2011 elf-memtest86+-4.10
drwxr-xr-x. 2 root root 4096 Nov 4 00:49 grub
-rw-rw-r--. 1 root root 13938917 Nov 4 00:49 initramfs-2.6.38.6-26.rc1.fc15.i686.img
-rw-r--r--. 1 root root 177368 Mar 15 2011 memtest86+-4.10
-rw-------. 1 root root 1852227 May 9 21:48 System.map-2.6.38.6-26.rc1.fc15.i686
-rwxr-xr-x. 1 root root 3804304 May 9 21:48 vmlinuz-2.6.38.6-26.rc1.fc15.i686
Fedora now boots with the default vmlinuz-2.6.38.6-26.rc1.fc15.i686 where previously it booted with vmlinuz-2.6.40.6-0.fc15.i686
Current option in grub...
Quote:

kernel /boot/vmlinuz-2.6.38.6-26.rc1.fc15.i686 ro root=UUID=c7fc6e08-c698-473e-8ce4-134153a4f362 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet

initrd /boot/initramfs-2.6.38.6-26.rc1.fc15.i686.img
I am able to access the the Fedora partition in Slackware from KDE window as an available drive. I can also view the files in the terminal in the /media directory. When I try to add it to lilo (lilo.conf below)
Quote:

# Fedora alternative bootable partition config begins
image = /media/_Fedora-15-i686-/boot/vmlinuz-2.6.38.6-26.rc1.fc15.i686
initrd = /media/_Fedora-15-i686-/boot/initramfs-2.6.38.6-26.rc1.fc15.i686.img
root = /dev/sdb1
label = Fedora
read-only
# Fedora alternative partition config ends
Where "_Fedora-15-i686-" is the label that appears in Slackware for the Fedora root partition.

Windows as is works and boots from lilo, so no problem there

Output from running lilo is as follows...
Quote:

root@floyd:/media# lilo
Warning: LBA32 addressing assumed
Warning: The boot sector and map file are on different disks.
Added Windows *
Added Slackware
Fatal: Setup length exceeds 31 maximum; kernel setup will overwrite boot loader
Anyone have any ideas? Has anyone managed to dual boot Fedora with lilo.

I prefer lilo and would rather use this rather going down the grub root.

Cedrik 11-04-2011 08:29 AM

Make sure grub is installed in /dev/sdb1

Boot from fedora install CD/DVD and run: grub

grub>root (hd1,0)
grub>setup (hd1,0)
grub>quit

then eject CD/DVD, reboot in slackware and add entry in lilo.conf:

# Fedora bootable partition config begins
other = /dev/sdb1
label = Fedora
# Fedora bootable partition config ends

run: lilo -v

tamtam 11-04-2011 11:18 AM

Thanks Cedrik, will try that out.

Just starting out with a fresh install of both OSes. Tinkered around so much now that I starting afresh would seem the best thing to do.

Installed Slackware with out installing lilo, what is the command to run it after the install?

Plan is to install lilo on the second hard drive, sdb. Install Fedora, then allow grub to install on the MBR of sda. Try and chainload (do not know if it is the right word for lilo) Fedora grub from there.

Cedrik 11-04-2011 12:51 PM

In this case, the best plan is to install fedora in last imho

This way you install grub from the fedora installer

Also if you install grub, you don't need Lilo at all

colorpurple21859 11-04-2011 03:28 PM

Quote:

liloconfig
will set up lilo initially then after that any changes are made by editing the /etc/lilo.conf file and the run
Quote:

lilo

tamtam 11-04-2011 04:10 PM

Thanks colorpurple21859, managed to install lilo on sdb1 (second disk). Installed Fedora, with grub loading from within the MBR.

Can now boot the three operating systems from Grub, and thanks to Cedrik I can also boot the three from lilo now.

For refernce here is lilo.conf mount points now.
Quote:

# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = /dev/sda
# Windows bootable partition config ends
# Slackware bootable partition config begins
image = /boot/vmlinuz
root = /dev/sdb1
label = Slackware
read-only
# Slackware bootable partition config ends
# Fedora chainload attempt bootable partition config begins
other = /dev/sda
label = Fedora
# Fedora chainload attempt bootable partition config ends
Fedora for some reason doesnot like installing grub on the second disk (sdb) unless you stipulate it during the install procedure as the primary disk. Hence root (hd0, 0). At least that's the way it seems to me. Anyway, as a failsafe I can boot the second disk for lilo during the bios boot if grub get's corrupt at some point.

Over to the Fedora forums now for help with a couple of things. Also to find out how to edit grub2 so I can increase the timeout period.


All times are GMT -5. The time now is 06:54 AM.