LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-23-2003, 03:44 AM   #1
Wonderer
Member
 
Registered: Oct 2003
Location: London, UK
Distribution: Slackware 9.0
Posts: 58

Rep: Reputation: 15
Help: Tiny font in KDE


Hi

I am having problem [can't see] with the tiny fonts in KDE.

I have tried the Font utility but it has not helped.

I have changed dpi in X but did not help [everything got bigger but in comparison text remained tiny].

All menus, header etc displays are OK and legible [set to size 12 in font utility].

But the text content of windows are extremely small [looks like 7px].

As an example, kwrite menus are fine but the text displays is tiny.
It is the same with any other text editor or browser or anything else showing text like Help. In Help the menu items on the left and top are OK but the right text display is tiny.

KDE Konsole has very large font size [looks like 14px].

How can I fix this as I can hardly read anything?

TIA


Info: Slack 9.0 KDE 3.1.4

Last edited by Wonderer; 10-23-2003 at 03:45 AM.
 
Old 10-23-2003, 09:52 AM   #2
dhrivnak
Member
 
Registered: Oct 2003
Location: USA
Distribution: Slackware 9.1
Posts: 50

Rep: Reputation: 15
Try the KDE control center --> look and feel --> fonts...

You should see about 7 different font options; one for each case: titles, windows, panel, general, etc.

Hope that helps!
 
Old 10-23-2003, 10:08 AM   #3
Wonderer
Member
 
Registered: Oct 2003
Location: London, UK
Distribution: Slackware 9.0
Posts: 58

Original Poster
Rep: Reputation: 15
Tnx.

I have been there but it did not help.



ps.
I have changed every single settigns but did not change the content.
I have since set the kwrite font to 14 Courier which is a the same [visual] size as 10 courier on windows at 1024x768.

To be honest, screen feels like 1280x1024 on a 17 inch and that would make everything small although it is set to 1024x768 in Xconfig. My monitor does nto support 1280x1024.



Last edited by Wonderer; 10-23-2003 at 02:54 PM.
 
Old 10-23-2003, 12:45 PM   #4
littleking
Member
 
Registered: Jun 2003
Location: New Albany, OH
Posts: 190

Rep: Reputation: 30
im having the totally opposite problem, everything in my kde session seems to be "zoomed" larger...i have all fonts set to 10pt and yet everything takes up half of my 1680x1050 screen...


any ideas?
 
Old 12-06-2003, 03:38 PM   #5
rol1
LQ Newbie
 
Registered: May 2003
Location: Las Vegas
Posts: 8

Rep: Reputation: 0
I would like to have a larger type in the k-help windows. I have changed as much as I could find in fonts and appearance settings. Think it may be a default setting somewhere like lynx or runoff or such.
 
Old 02-10-2004, 01:54 AM   #6
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 31
I was just wondering if you found the solution to this problem. I have the same dilemma. All my fonts are tiny in the menu bars.
 
Old 02-10-2004, 08:22 AM   #7
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally posted by Linux~Powered
I was just wondering if you found the solution to this problem. I have the same dilemma. All my fonts are tiny in the menu bars.
Look in the /etc/kde3/kdm/Xservers and check for a line similar to this:
Code:
:0 local@tty1 /usr/X11R6/bin/X :0 -dpi 100 -nolisten tcp vt7
And change to 100 if the line says 75 and you can check in the xconfig file as well on Debian this is /etc/X11XF86Config-4 and look for lines like this:
Code:
  FontPath      "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
And change the 75 line(s) to be below the 100 one(s) then you restart the X server and KDE with (again on Debian) /etc/init.d/kdm restart you would need to find the correct files for Slack and make the changes all steps as root and best done from a console login.
 
Old 02-10-2004, 05:47 PM   #8
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 31
i don't have a /etc/kde3/kdm/Xservers and i did move the 100 above the 75 here is my config... i didn't post all of it. just what i thought was important


# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the Type1 and FreeType font modules
Load "type1"
Load "speedo"
# Load "freetype"
# Load "xtt"

# This loads the GLX module
# Load "glx"
# This loads the DRI module
# Load "dri"

EndSection

# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
# If you don't have a floating point coprocessor and emacs, Mosaic or other
# programs take long to start up, try moving the Type1 and Speedo directory
# to the end of this list (or comment them out).
#

FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
# FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
# FontPath "/usr/X11R6/lib/X11/fonts/freefont/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"


# The module search path. The default path is shown here.

# ModulePath "/usr/X11R6/lib/modules"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to cause a core dump at the spot where a signal is
# received. This may leave the console in an unusable state, but may
# provide a better stack trace in the core dump to aid in debugging

# Option "NoTrapSignals"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12). This allows clients to receive these key
# events.

# Option "DontVTSwitch"

# Uncomment this to disable the <Crtl><Alt><BS> server abort sequence
# This allows clients to receive this key event.

# Option "DontZap"

# Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
# sequences. This allows clients to receive these key events.

# Option "Dont Zoom"

# Uncomment this to disable tuning with the xvidtune client. With
# it the client can still run and fetch card and monitor attributes,
# but it will not be allowed to change them. If it tries it will
# receive a protocol error.

# Option "DisableVidModeExtension"

# Uncomment this to enable the use of a non-local xvidtune client.

# Option "AllowNonLocalXvidtune"

# Uncomment this to disable dynamically modifying the input device
# (mouse and keyboard) settings.

# Option "DisableModInDev"

# Uncomment this to enable the use of a non-local client to
# change the keyboard or mouse settings (currently only xset).

# Option "AllowNonLocalModInDev"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

# Option "Protocol" "Xqueue"

Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# Option "LeftAlt" "Meta"
# Option "RightAlt" "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for XFree86
# Option "XkbRules" "xfree86"
# Option "XkbModel" "pc101"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"

Option "XkbRules" "xfree86"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"

EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************
 
Old 02-10-2004, 06:33 PM   #9
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
That would be the file name in Debian then, there must be a similar file in Slack somewhere that is how the font size gets set you should check in the configuration directory for KDE on your install for it or do you not have kdm installed and just use startx from a console.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tiny font problem munkie_poo Linux - Software 0 01-31-2005 05:06 AM
Tiny Font size after log out of X windows wylie1001 Linux - Software 2 11-03-2004 04:59 PM
super tiny font at FC2 login screen dwuolu Fedora 4 10-06-2004 07:47 PM
tiny font with fc2 login screen dwuolu Linux - Newbie 3 07-20-2004 06:10 PM
tiny font GAIM StonedZealot Linux - Software 1 05-15-2003 04:08 AM


All times are GMT -5. The time now is 11:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration