LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-06-2011, 06:18 AM   #1
bassplayer69
Member
 
Registered: Jul 2007
Location: In a van down by the river...
Distribution: Slackware64 14.1 Multi-Lib
Posts: 125

Rep: Reputation: 22
Timezone EDT -> EST issue with 13.37?


Either KDE or Slackware failed to fall back an hour this morning.

Dump of /etc/localtime:

Code:
/etc/localtime  Sun Nov  6 05:59:59 2011 UTC = Sun Nov  6 01:59:59 2011 EDT isds
t=1 gmtoff=-14400
/etc/localtime  Sun Nov  6 06:00:00 2011 UTC = Sun Nov  6 01:00:00 2011 EST isds
t=0 gmtoff=-18000
output of the date command:

Code:
# date
Sun Nov  6 08:13:08 EST 2011
actual date: Sun Nov 6 07:13:08 EST 2011

The time didn't fall back one hour.

That's interesting. I executed tzselect and received the following results for TZ='America/Detroit'

Code:
The following information has been given:

	United States
	Eastern Time - Michigan - most locations

Therefore TZ='America/Detroit' will be used.
Local time is now:	Sun Nov  6 08:17:54 EST 2011.
Universal Time is now:	Sun Nov  6 13:17:54 UTC 2011.
Is the above information OK?
1) Yes
2) No
#?
Which is not correct since its 07:17:54 EST

Slackware 13.37 64bit

ntp is not setup.

KDE version - whatever is shipped with Slackware 13.37
 
Old 11-06-2011, 06:46 AM   #2
jmccue
Member
 
Registered: Nov 2008
Location: US
Distribution: slackware
Posts: 133

Rep: Reputation: 35
Hi,

EDIT: sorry, did not see you did what was below, does Mich use a different time that NY, what is below is for NY:

Worked for me
Give this a try, it will tell you about your default timezone settings:

/usr/sbin/zdump -v /etc/localtime | grep 2011

for EST/EDT I get, and if it does not match what you get maybe you have a old timezone db

/etc/localtime Sun Mar 13 06:59:59 2011 UTC = Sun Mar 13 01:59:59 2011 EST isdst=0 gmtoff=-18000

/etc/localtime Sun Mar 13 07:00:00 2011 UTC = Sun Mar 13 03:00:00 2011 EDT isdst=1 gmtoff=-14400

/etc/localtime Sun Nov 6 05:59:59 2011 UTC = Sun Nov 6 01:59:59 2011 EDT isdst=1 gmtoff=-14400

/etc/localtime Sun Nov 6 06:00:00 2011 UTC = Sun Nov 6 01:00:00 2011 EST isdst=0 gmtoff=-18000


Jack

Last edited by jmccue; 11-06-2011 at 06:49 AM.
 
Old 11-06-2011, 07:36 AM   #3
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 161

Rep: Reputation: 20
I'm in Ontario and use EST5EDT as my timezone when setting machines up. Fallback happened as expected this morning.
 
Old 11-06-2011, 08:38 AM   #4
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,075

Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
Quote:
...does Mich use a different time that NY...
The four counties of Dickinson, Gogebic, Iron and Menominee, in the western Upper Peninsula, are in the Central Time Zone; the rest of the state (most of it) is in the Eastern Time Zone, same time as New York. That's the "Michigan" setting for those four counties, otherwise you'd choose Eastern.

Hope this helps some.

Last edited by tronayne; 11-06-2011 at 08:39 AM.
 
Old 11-06-2011, 01:36 PM   #5
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,516

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
What glibc-zoneinfo package do you have installed?

Mine (which worked correctly) is glibc-zoneinfo-2.13-noarch-4
 
Old 11-06-2011, 02:16 PM   #6
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
Set the Hardware Clock to the current System Time:

# hwclock --systohc
 
Old 11-06-2011, 06:24 PM   #7
bassplayer69
Member
 
Registered: Jul 2007
Location: In a van down by the river...
Distribution: Slackware64 14.1 Multi-Lib
Posts: 125

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by Richard Cranium View Post
What glibc-zoneinfo package do you have installed?

Mine (which worked correctly) is glibc-zoneinfo-2.13-noarch-4
I have glibc-zoneinfo-2.13_multilib-noarch-4alien
 
Old 11-06-2011, 06:27 PM   #8
bassplayer69
Member
 
Registered: Jul 2007
Location: In a van down by the river...
Distribution: Slackware64 14.1 Multi-Lib
Posts: 125

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by tronayne View Post
The four counties of Dickinson, Gogebic, Iron and Menominee, in the western Upper Peninsula, are in the Central Time Zone; the rest of the state (most of it) is in the Eastern Time Zone, same time as New York. That's the "Michigan" setting for those four counties, otherwise you'd choose Eastern.

Hope this helps some.

Not so. when I run tzselect I have the two Michigan options:

Code:
 2) Eastern Time - Michigan - most locations
14) Central Time - Michigan - Dickinson, Gogebic, Iron & Menominee Counties
I selected 2 since I'm not in the U.P.


BTW: I manually fixed it by using the "date -s" command.

I'll have to see if it moves forward next spring.
 
Old 11-06-2011, 07:44 PM   #9
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,516

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
Quote:
Originally Posted by bassplayer69 View Post
I have glibc-zoneinfo-2.13_multilib-noarch-4alien
Hmm. Has anyone else running multilib seen a problem? (I don't expect the OP to answer this one. )
 
Old 11-06-2011, 09:26 PM   #10
kfritz
Member
 
Registered: Aug 2006
Distribution: Slackware, OpenBSD
Posts: 73

Rep: Reputation: 20
I go through this every 6 months or so. I google, I search linuxquestions, I listen to my wife say "It works fine on Windows", then I set the time manually and promise myself to solve it, and then forget.

Running 3 Slackware, home workstation (13.37, 64-bit), laptop (current, 32), and an always-on crufty old PIII (current, 32). Only the PIII has the correct time right now.

So I have a theory: having the hardware clock set to local time (the default) means that you have to have the machine running during the time-change to work correctly. My workstation and laptop were off last night.

Right? Wrong? Should I just switch to UTC hw clock to solve this?
 
1 members found this post helpful.
Old 11-06-2011, 10:30 PM   #11
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,260

Rep: Reputation: 645Reputation: 645Reputation: 645Reputation: 645Reputation: 645Reputation: 645
Quote:
Originally Posted by kfritz View Post
So I have a theory: having the hardware clock set to local time (the default) means that you have to have the machine running during the time-change to work correctly. My workstation and laptop were off last night.

Right? Wrong? Should I just switch to UTC hw clock to solve this?
I believe this is correct unless you use a properly configured ntpd (and set it to start at boot time via /etc/rc.d/rc.ntpd), which, in Slackware, is set to allow the first adjustment to be big.
 
Old 11-07-2011, 10:07 AM   #12
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 161

Rep: Reputation: 20
got this here glibc-zoneinfo-2.13_multilib-noarch-4alien and the laptop was in "suspend to ram" and it came up fine with the correct time on Sunday
 
Old 11-07-2011, 10:13 AM   #13
bassplayer69
Member
 
Registered: Jul 2007
Location: In a van down by the river...
Distribution: Slackware64 14.1 Multi-Lib
Posts: 125

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by kfritz View Post
I go through this every 6 months or so. I google, I search linuxquestions, I listen to my wife say "It works fine on Windows", then I set the time manually and promise myself to solve it, and then forget.

Running 3 Slackware, home workstation (13.37, 64-bit), laptop (current, 32), and an always-on crufty old PIII (current, 32). Only the PIII has the correct time right now.

So I have a theory: having the hardware clock set to local time (the default) means that you have to have the machine running during the time-change to work correctly. My workstation and laptop were off last night.

Right? Wrong? Should I just switch to UTC hw clock to solve this?
Exactly. The Windows 7 VM I have worked fine. So, during the transition from EDT to EST and EST to EDT we're supposed to leave the computers on over night so it works? That's pretty lame... Just saying...

I don't mind setting the correct time twice a year, but this is the 21st century after all.
 
Old 11-07-2011, 12:06 PM   #14
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,048

Rep: Reputation: 170Reputation: 170
Couldn't this issue be resolved by running /etc/rd.d/rc.ntpd, as mentioned in T3slider's post?

Doesn't windows automagically update its time settings because there's a time server running?

cheers,
 
Old 11-07-2011, 02:11 PM   #15
bassplayer69
Member
 
Registered: Jul 2007
Location: In a van down by the river...
Distribution: Slackware64 14.1 Multi-Lib
Posts: 125

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by mrclisdue View Post
Couldn't this issue be resolved by running /etc/rd.d/rc.ntpd, as mentioned in T3slider's post?

Doesn't windows automagically update its time settings because there's a time server running?

cheers,
I was planning on setting up the ntpd information as suggested, but with my Windows 7 VM, no, I don't have it set to go query a time server for the date/time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EST of Australian timezone does not work freemanl Linux - Newbie 2 10-21-2011 03:32 PM
How to change the timezone from EDT to PDT using Ntpd AjiNIMC Linux - Server 1 05-28-2007 01:55 PM
Changing the date to EST shiroh_1982 Programming 2 07-17-2006 02:06 AM
Linux IRC chat, tonight at 9PM EST. testforechozero General 1 07-14-2004 07:08 PM
change UTC to EST time zone. brian_eye Linux - Newbie 1 10-27-2003 05:08 PM


All times are GMT -5. The time now is 12:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration