LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-24-2005, 08:36 PM   #1
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 339

Rep: Reputation: 27
Time zone stuck in UTC - how to change?


Slackware 10.0. My time zone is stuck in UTC, no matter what I do. I run KDE, click on clock, select Adjust Date and Time. I change time zone to America/Los Angeles, click apply. Time zone shows PDT like it should. Time is correct. Click OK. Go back in, and it shows UTC again. I have several servers that are logging time in the logs as 7 hours off because of this. How can I force this box to PST and make it stick?
 
Old 04-24-2005, 09:36 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
one thing you could try doing is:

open a terminal...

become root...

execute pkgtool...

go into "setup"...

select "timeconfig" and hit okay...

select "Harware clock is set to local time"...

hit okay and then exit...
 
Old 04-24-2005, 10:55 PM   #3
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
I wouldn't set the hardware clock to local time unless dualbooting with windows. The following should work:

open a terminal window and su to root and then do

ln -sf /usr/share/zoneinfo/America/Los_Angeles /etc/localtime

This will tell the system that the machine is in LA's time zone. If you don't like LA, just look in the /usr/share/zoneinfo for a place that suits you and create a symlink /etc/localtime to there.

Now do
hwclock --hctosys

check that the system time is correct with
date
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting system time to UTC triley Linux - General 2 08-25-2009 07:56 PM
Wrong UTC time sundaraz Linux - Newbie 4 10-21-2005 10:45 PM
Re: UTC Time unixfreak Linux - Newbie 2 08-30-2004 02:09 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 03:25 PM
change UTC to EST time zone. brian_eye Linux - Newbie 1 10-27-2003 05:08 PM


All times are GMT -5. The time now is 11:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration