LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-11-2007, 01:49 PM   #31
rcpao
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0

Quote:
Originally Posted by The GNUinator
This didn't work for me. Obtained tzdata2007c.tar.gz from elsie.
...
Would someone in this forum get "tzdata2007c.tar.gz" from elsie and see if it works for you?
I did the following:

mkdir tz
cd tz
wget 'ftp://elsie.nci.nih.gov/pub/tz*.tar.gz'
gzip -dc tzcode*.tar.gz | tar -xf -
gzip -dc tzdata*.tar.gz | tar -xf -

# Edit Makefile to use "US/Pacific" and changed from nawk to awk.

make
make install
# This will install to /usr/local/{etc,bin} by default as
# specified in the Makefile.

# Prior to this, zdump did not exist on my old slackware.
# I can now run 'zdump -v /etc/localtime | grep 2007'.
zdump -v /etc/localtime | grep 2007
/etc/localtime Sun Apr 1 09:59:59 2007 UTC = Sun Apr 1 01:59:59 2007 PST isdst=0 gmtoff=-28800
/etc/localtime Sun Apr 1 10:00:00 2007 UTC = Sun Apr 1 03:00:00 2007 PDT isdst=1 gmtoff=-25200
/etc/localtime Sun Oct 28 08:59:59 2007 UTC = Sun Oct 28 01:59:59 2007 PDT isdst=1 gmtoff=-25200
/etc/localtime Sun Oct 28 09:00:00 2007 UTC = Sun Oct 28 01:00:00 2007 PST isdst=0 gmtoff=-28800
# Note that this is how the incorrect listing will look.
# Substitute PST & PDT with your own time zone, but the dates when ?ST & ?DT change will be the same.

mv /etc/localtime /etc/localtime-original
# Choose whatever timezone you are in and soft link it to /etc/localtime. Use the localtime-original above as reference.
ln -s /usr/local/etc/zoneinfo/US/Pacific /etc/localtime

# At this point, your zdump should look like the following.
zdump -v /etc/localtime | grep 2007
/etc/localtime Sun Mar 11 09:59:59 2007 UTC = Sun Mar 11 01:59:59 2007 PST isdst=0 gmtoff=-28800
/etc/localtime Sun Mar 11 10:00:00 2007 UTC = Sun Mar 11 03:00:00 2007 PDT isdst=1 gmtoff=-25200
/etc/localtime Sun Nov 4 08:59:59 2007 UTC = Sun Nov 4 01:59:59 2007 PDT isdst=1 gmtoff=-25200
/etc/localtime Sun Nov 4 09:00:00 2007 UTC = Sun Nov 4 01:00:00 2007 PST isdst=0 gmtoff=-28800

# Run 'date' to verify your local time is now correct.
date
Sun Mar 11 11:32:41 PDT 2007
 
Old 03-11-2007, 08:33 PM   #32
jerryvb
Member
 
Registered: Nov 2003
Location: Jerryland
Distribution: Debian
Posts: 59

Rep: Reputation: 16
Quote:
Originally Posted by Pierre Forget
Hi,

In Slackware I use:

/usr/sbin/netdate time.nrc.ca time-nw.nist.gov (from my main server located in Canada)

Pierre Forget

I'm running Slackware 11.0, with all updates installed. But my box still didn't update until I ran Pierre's command. Now it's right, even after a shutdown and restart.

Thank you Pierre!!!
 
Old 03-12-2007, 07:09 AM   #33
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by jerryvb
I'm running Slackware 11.0, with all updates installed. But my box still didn't update until I ran Pierre's command. Now it's right, even after a shutdown and restart.

Thank you Pierre!!!
One more time, from the top with feeling......


Please, please, PLEASE DO NOT POINT AT SPECIFIC TIME SERVERS FOR PERSONAL USE. Please use the pool servers, which are more than adequate for everyday and do not run the risk of having the tier 1 servers removed from general access.
 
Old 03-12-2007, 07:25 AM   #34
jerryvb
Member
 
Registered: Nov 2003
Location: Jerryland
Distribution: Debian
Posts: 59

Rep: Reputation: 16
Quote:
Originally Posted by Hangdog42
One more time, from the top with feeling......


Please, please, PLEASE DO NOT POINT AT SPECIFIC TIME SERVERS FOR PERSONAL USE. Please use the pool servers, which are more than adequate for everyday and do not run the risk of having the tier 1 servers removed from general access.

Hmmm, does it really hurt that much to run that command ONCE?
 
Old 03-12-2007, 07:40 AM   #35
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Pat sent out emails indicating he had a patch for the DST thing for releases below 11 a few weeks ago.
 
Old 03-12-2007, 08:21 AM   #36
drumz
Member
 
Registered: Apr 2005
Location: Scottsdale, AZ, USA
Distribution: Slackware
Posts: 188

Rep: Reputation: 33
Quote:
Originally Posted by jerryvb
Hmmm, does it really hurt that much to run that command ONCE?
Is one raindrop responsible for a flood?
 
Old 03-12-2007, 11:50 AM   #37
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by jerryvb
Hmmm, does it really hurt that much to run that command ONCE?

An interesting read

Another interesting read

The Wikipedia entry with plenty of horror stories


When it comes to time servers, there is really no such things as "just once", and that is the problem. As you'll see if you read these articles, servers are already being removed from service, or having their access GREATLY restricted. If you want to have time servers to use, you'll mind your manners and use the pool system.
 
Old 03-12-2007, 12:33 PM   #38
jerryvb
Member
 
Registered: Nov 2003
Location: Jerryland
Distribution: Debian
Posts: 59

Rep: Reputation: 16
Quote:
Originally Posted by drumz
Is one raindrop responsible for a flood?

I do offer my sincere apologies for misusing the system. I was unaware of the sensitivity of this issue. (No, I didn't read the whole thread. My bad.)
 
Old 03-12-2007, 11:50 PM   #39
diskoe
Member
 
Registered: Nov 2006
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by masonm
Pat sent out emails indicating he had a patch for the DST thing for releases below 11 a few weeks ago.
Exactly. Not sure who subscribes to Slackware's lists. I do, it's a good idea to, if you don't. This came out on 2/18. Use the patch and not any of the home grown fixes (even though they work). I just wished Pat released this much earlier than 2/18.

Code:
From: Slackware Security Team <security@slackware.com>
To: slackware-announce@slackware.com
Subject: [slackware-announce]  glibc-zoneinfo US Daylight Savings Time changes
Date: Sun, 18 Feb 2007 14:36:02 -0800 (PST)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

[slackware-announce]  glibc-zoneinfo US Daylight Savings Time changes

New glibc-zoneinfo packages are available for Slackware 8.1, 9.0, 9.1,
10.0, 10.1, 10.2, and 11.0 to update the timezone information to
account for the extention of Daylight Savings Time (DST) in the US.
This is an important update as any machine in the US (in an area using
DST) running Slackware 10.2 or earlier will otherwise have a system
clock off by one hour for a month starting on March 11.  It is strongly
suggested to upgrade this package before March 11, 2007.

Slackware 11.0 is not affected by this particular US DST issue, but
an update to the latest zoneinfo database is provided anyway.

NOTE:  All these packages are the *same*, but with different package
names.  If you're not concerned about that, you may use any one of
these packages to upgrade all your Slackware boxes, 8.1 or newer.


Here are the details from the Slackware 11.0 ChangeLog:
+--------------------------+
patches/packages/glibc-zoneinfo-2.3.6-noarch-7_slack11.0.tgz:
  Updated with tzdata2007b for impending Daylight Savings Time
  changes in the US.
+--------------------------+

Where to find the new packages:
+-----------------------------+

HINT:  Getting slow download speeds from ftp.slackware.com?
Give slackware.osuosl.org a try.  This is another primary FTP site
for Slackware that can be considerably faster than downloading
from ftp.slackware.com.

Thanks to the friendly folks at the OSU Open Source Lab
(http://osuosl.org) for donating additional FTP and rsync hosting
to the Slackware project!  :-)

Also see the "Get Slack" section on http://slackware.com for
additional mirror sites near you.

Updated package for Slackware 8.1:
ftp://ftp.slackware.com/pub/slackwar...386-3_slack8.1.
tgz

Updated package for Slackware 9.0:
ftp://ftp.slackware.com/pub/slackwar...5_slack9.0.tgz

Updated package for Slackware 9.1:
ftp://ftp.slackware.com/pub/slackwar...2_slack9.1.tgz

Updated package for Slackware 10.0:
ftp://ftp.slackware.com/pub/slackwar..._slack10.0.tgz

Updated package for Slackware 10.1:
ftp://ftp.slackware.com/pub/slackwar..._slack10.1.tgz

Updated package for Slackware 10.2:
ftp://ftp.slackware.com/pub/slackwar..._slack10.2.tgz

Updated package for Slackware 11.0:
ftp://ftp.slackware.com/pub/slackwar..._slack11.0.tgz


MD5 signatures:
+-------------+

Slackware 8.1 package:
9ee701e7d8c6d4a2569dcbc653937d4d  glibc-zoneinfo-2.2.5-i386-3_slack8.1.tgz

Slackware 9.0 package:
9ee701e7d8c6d4a2569dcbc653937d4d  glibc-zoneinfo-2.3.1-noarch-5_slack9.0.tgz

Slackware 9.1 package:
9ee701e7d8c6d4a2569dcbc653937d4d  glibc-zoneinfo-2.3.2-noarch-2_slack9.1.tgz

Slackware 10.0 package:
9ee701e7d8c6d4a2569dcbc653937d4d  glibc-zoneinfo-2.3.2-noarch-7_slack10.0.tgz

Slackware 10.1 package:
9ee701e7d8c6d4a2569dcbc653937d4d  glibc-zoneinfo-2.3.4-noarch-2_slack10.1.tgz

Slackware 10.2 package:
9ee701e7d8c6d4a2569dcbc653937d4d  glibc-zoneinfo-2.3.5-noarch-7_slack10.2.tgz

Slackware 11.0 package:
9ee701e7d8c6d4a2569dcbc653937d4d  glibc-zoneinfo-2.3.6-noarch-7_slack11.0.tgz

Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg glibc-zoneinfo-2.3.6-noarch-7_slack11.0.tgz


+-----+

Slackware Linux Security Team
http://slackware.com/gpg-key
security@slackware.com

+------------------------------------------------------------------------+
| To leave the slackware-security mailing list:                          |
+------------------------------------------------------------------------+
| Send an email to majordomo@slackware.com with this text in the body of |
| the email message:                                                     |
|                                                                        |
|   unsubscribe slackware-security                                       |
|                                                                        |
| You will get a confirmation message back containing instructions to    |
| complete the process.  Please do not reply to this email address.      |
+------------------------------------------------------------------------+
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFF2NQkakRjwEAQIjMRAtXbAJ0VD/jXxS/qYqRoMc577lQgpOCmkwCeMOQQ
prIYmra7XMEPCkjqpKscSPk=
=oLML
-----END PGP SIGNATURE-----

Last edited by diskoe; 03-12-2007 at 11:55 PM.
 
Old 03-13-2007, 06:59 AM   #40
ehedetniem
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Rep: Reputation: 0
Question Does cron need to be restarted?

Having a problem - we updated our servers using the correct patch.
/usr/sbin/./zdump -v /etc/localtime | grep 2007 shows the correct time and so does the date command. The problem is that our cron jobs are starting 1 hour later. We've tried updating the system time to the hwclock but that hasn't work. What needs to be done to have the cron jobs run at the correct time. Does cron need to be stopped and restarted?
Thanks.
 
Old 03-13-2007, 11:35 AM   #41
cereal83
Member
 
Registered: Feb 2004
Location: Canada
Distribution: Slackware
Posts: 478

Rep: Reputation: 30
Quote:
Originally Posted by ehedetniem
Having a problem - we updated our servers using the correct patch.
/usr/sbin/./zdump -v /etc/localtime | grep 2007 shows the correct time and so does the date command. The problem is that our cron jobs are starting 1 hour later. We've tried updating the system time to the hwclock but that hasn't work. What needs to be done to have the cron jobs run at the correct time. Does cron need to be stopped and restarted?
Thanks.

We had the exact same problems. The fix for that from what we saw was to re-run cron with "crontab /var/spool/cron/crontab/root" and that fixed the issue, you could also restart crond. Also this issue didn't happen on all of our boxes, only a couple of them.
 
Old 03-13-2007, 12:52 PM   #42
ehedetniem
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by cereal83
We had the exact same problems. The fix for that from what we saw was to re-run cron with "crontab /var/spool/cron/crontab/root" and that fixed the issue, you could also restart crond. Also this issue didn't happen on all of our boxes, only a couple of them.

Thank you very much for your response. Did some more investigating and found out that all service that rely on /etc/localtime need to be restarted such as crond, syslogd, etc... /etc/localtime is only read once when the application starts up, and any changes to that file are not picked up until the application is restarted. Another suggestion was to reboot system to make sure all services are restarted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot set time/date to other time zone than UTC (Kubuntu) jamangold Ubuntu 1 12-23-2005 05:42 PM
Time Zone cherukuri_sr Linux - Newbie 2 02-02-2005 11:20 AM
Display the date and time from another time zone lothario Linux - Software 4 07-31-2004 03:27 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 03:25 PM
time zone exigent Linux - General 4 09-17-2002 03:41 PM


All times are GMT -5. The time now is 07:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration