LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   TIME STAMP swap's or offsets between OS's (http://www.linuxquestions.org/questions/slackware-14/time-stamp-swaps-or-offsets-between-oss-4175479213/)

BW-userx 10-01-2013 09:53 AM

TIME STAMP swap's or offsets between OS's
 
sorry don't read I fixed it -- sorry for wasted HD space on server for this question --

ok I got Slackware 14 and XP dual boot my time keeps swapping to different times when ever I boot into the other OS.

if in XP I set it to the correct time then boot into Linux it is off by about five hours exmp. it's 9:40 AM now set XP to show current time boot to Linux it shows 4:40 AM set correct time in linux by

1) use timeconfig set it to use the PC local time it does not change it to the right BIOS time

date time still shows - Tue Oct 1 04:46:13 CDT 2013 when it is 09:46

if I do date --set 'Tue Oct 1 09:46 CDT 2013' it sets it then when I go to XP the time is changed or offset by approx 5 hours (as I don't want to boot to XP to get the correct offset as i am writing this now in Linux)

after I do the date --set 'Tue Oct 1 09:46 CDT 2013' then do >#date it shows the changes I made then I do a >#hwclock --show it shows Tue 01 Oct 2013 05:00:48 AM CDT -0.376926 seconds like the hardware clock is not setting before I checked the BIOS time and it is set to the current correct time not that the >#hwclock --show command shows what gives, and how do I sync the two to show the correct time ?

is it not suppose to be pulling time date time off of the BIOS? or network somewhere depending on how it is setup? what is this extra time from hwclock?

michaelk 10-01-2013 10:54 AM

Thanks for posting back that you fixed it. You can mark this thread as solved by using the thread tools at the top.
It would also be a good idea to post the fix in case others have the same problem.

BTW the time offset between CDT and UTC is 5 hours. Basically windows expects the hardware clock to be set to local time. linux does not care but you have to setup the configuration files correctly.

NoStressHQ 10-02-2013 12:39 AM

Quote:

Originally Posted by BW-userx (Post 5038005)
sorry for wasted HD space on server for this question

How cute... :)

Welcome to Slackware Forums !

Cheers


All times are GMT -5. The time now is 08:53 AM.