LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-28-2006, 12:03 PM   #1
Crobat
Member
 
Registered: Dec 2005
Distribution: Slackware 10.2, Slackware 11.0
Posts: 135

Rep: Reputation: 15
Time keeps slowing


For some reason, I've just noticed this, but the time on my system keeps slowing down. I use it pretty often, and I happened to be late for work 15 minutes one day. A week later, it was 20 minutes behind. I manually set it back to the right time, but it continues to slow down. Any ideas?
 
Old 02-28-2006, 12:07 PM   #2
SaintsOfTheDiamond
Member
 
Registered: Jan 2006
Location: Lexington, KY
Distribution: Arch and a little Slack
Posts: 139

Rep: Reputation: 15
Do you leave it running all the time? If you turn it off you may need to replace the battery on the motherboard (I forget the fancy name for it )
 
Old 02-28-2006, 02:38 PM   #3
edM
Member
 
Registered: Nov 2003
Location: U.K.
Distribution: Slackware-12
Posts: 137

Rep: Reputation: 15
check in the BIOS for the system and see if its running behind as well, reset the time and switch it for 30 mins, check the BIOS again. if it is 9/10 then the CMOS bat is dying.

*keep a note of all your important BIOS settings before going onto the next step*

open the case and check the battery is seated properly, or there isnt lots of dust lying over the battery.

then do the time test again.

if you still have the same problem as final test you even check that the polarity of the bat has come mis-aligned. check your mobo book for the polarity for the bat on the mobo. it may just have a + sign on the direction. make sure the + on your bat is aligned that way.

i have come across all 3 of those problems when fixing PCs in the past.


replacement CMOS button batteries cost nothing can be picked up at any computer specialists.
 
Old 02-28-2006, 07:17 PM   #4
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Rep: Reputation: 222Reputation: 222Reputation: 222
Quote:
(I forget the fancy name for it )
I think the technical term would be CMOS battery, but its just nomenclature. Battery for the bios gets the point across as well.
 
Old 02-28-2006, 11:27 PM   #5
lodragan
LQ Newbie
 
Registered: Jan 2006
Location: USA
Distribution: Slackware 13.1, Windows 7 (on game box only), Mac OSX
Posts: 18

Rep: Reputation: 4
Thumbs up

You should think about loading/activating ntpd (network time protocol daemon).

You can use that to syncronize with another machine on your network, and ideally a machine on your network can sync with a stratum clock periodically to keep everything ship-shape.

Most computer clocks drift to some extent - ntp corrects the drift - and allows you to have piece of mind (and correct time-stamps across your network).
 
Old 03-01-2006, 11:54 AM   #6
Widgeteye
Member
 
Registered: Mar 2005
Posts: 117

Rep: Reputation: 17
Here's what I do and is a great way to keep perfect time on your system.

I have a script called "Time"

in that script I have the following 2 lines.

/usr/sbin/ntpdate time-a.nist.gov
/sbin/hwclock -w

The first line gets the time from the governemts atomic clock
the next line writes it to cmos.

I set this little script up to be called once a day from the crontab and my
computer's time is always perfect.

Has to be root owned and run.

Have fun
 
Old 03-02-2006, 10:31 AM   #7
Crobat
Member
 
Registered: Dec 2005
Distribution: Slackware 10.2, Slackware 11.0
Posts: 135

Original Poster
Rep: Reputation: 15
Ahh there we go. That two liner script worked.

How would I go about setting that up to run automatically? Would I use the daemon that lodragon suggested?

Thanks again for the help.
 
Old 03-02-2006, 04:27 PM   #8
dsojat10
LQ Newbie
 
Registered: Nov 2003
Distribution: Fedora 5
Posts: 16

Rep: Reputation: 0
Time keeps slowing

Quote:
Originally Posted by Crobat
Ahh there we go. That two liner script worked.

How would I go about setting that up to run automatically? Would I use the daemon that lodragon suggested?

Thanks again for the help.
To answer the question;
Save the script in /root with chmod of 700 then as root enter the command crontab -e.

Now the best method though is;
edit the file /etc/ntp.conf with something like;

server whatever.com

It is best to have at least one stratum 1 server and a couple of stratum 2 servers. Find a time server near you at the following url http://ntp.isc.org/bin/view/Servers/WebHome

Then create the following script;

#!/bin/sh
#
# /etc/rc.d/rc.ntpd
#
# Start/stop/restart the Network Time Protocol Service.
#
# To make Apache start automatically at boot, make this
# file executable: chmod 755 /etc/rc.d/rc.httpd
#

case "$1" in
'start')
/usr/sbin/ntpd -l /var/log/ntpd.log -p /var/run/ntpd.pid ;;
'stop')
kill -9 `cat /var/run/ntpd.pid ` ;;
'restart')
kill -HUP `cat /var/run/ntpd.pid ` ;;
*)
echo "usage $0 start|stop|restart" ;;
esac

This ntp service will constantly run each time that the server is booted. As a final bonus configure your spouses/kids M$ boxes to obtain the time from your server.

You can check the status of the ntpd periodically by running the command as root; ntpq

You can find additional information about ntp at http://www.cis.udel.edu/~mills/ntp/html/

Ciao
 
Old 03-03-2006, 10:08 AM   #9
Crobat
Member
 
Registered: Dec 2005
Distribution: Slackware 10.2, Slackware 11.0
Posts: 135

Original Poster
Rep: Reputation: 15
Alrighty. I'll give it a go. Thanks!
 
Old 03-03-2006, 06:59 PM   #10
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
Or you could just save Widgeteye's 2 line script in /etc/cron.daily (make sure it's executable)
 
Old 03-05-2006, 09:53 PM   #11
Crobat
Member
 
Registered: Dec 2005
Distribution: Slackware 10.2, Slackware 11.0
Posts: 135

Original Poster
Rep: Reputation: 15
I edited cron/daily to include the time script. I'll let you know if it works. Thanks again guys!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network is slowing down my PC iZvi Linux - Networking 2 03-20-2005 10:27 AM
clock slowing down ZaphyR Linux - Newbie 3 08-13-2004 06:15 PM
Third Parties Slowing You Down? Crashed_Again LQ Suggestions & Feedback 5 05-06-2003 07:37 AM
ksoftirqd_cpu0 slowing down RH 8 DrGeks Linux - General 14 02-21-2003 04:05 AM
PC slowing down hardigunawan Linux - General 2 06-03-2002 10:56 PM


All times are GMT -5. The time now is 07:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration