LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-26-2012, 02:03 AM   #1
botzko
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 14.1 64bit
Posts: 24

Rep: Reputation: 0
Time is changed when use kernel 3.5.0


I compiled kernel 3.5.0 and everything works fine but after every reboot I must correct the time. If I boot the default kernel 2.6.37.6 time is correct.
System clock is set to localtime and /etc/hardwareclock is set to localtime too, so the problem is in my new kernel. The new kernel "thinks" that system clock is set to UTC.

Can you tell me what is the problem?
 
Old 07-26-2012, 03:54 AM   #2
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Maybe you can diff the config files for the two kernels to check if a timer setting is different in the new kernel?
 
Old 07-26-2012, 04:44 AM   #3
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,970

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Hi,

Check if you have rtc-cmos compiled as a module or built-in:
Code:
CONFIG_RTC_DRV_CMOS=y
Regards
 
1 members found this post helpful.
Old 07-26-2012, 05:55 AM   #4
botzko
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 14.1 64bit
Posts: 24

Original Poster
Rep: Reputation: 0
OK. CONFIG_RTC_DRV_CMOS is not compiled but if I compile it I need to choose a driver. I do not know which one. I will search in google but if you know what I must choose for Acer Aspire 5920G you can tell me.
 
Old 07-26-2012, 06:00 AM   #5
botzko
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 14.1 64bit
Posts: 24

Original Poster
Rep: Reputation: 0
Oh there is 'PC-Style CMOS' so I will compile with it and will see what will happen.
 
Old 07-26-2012, 01:40 PM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
make sure to also enable:

Code:
  ┌──────────── Set system time from RTC on startup and resume ─────────────┐
  │ CONFIG_RTC_HCTOSYS:                                                     │  
  │                                                                         │  
  │ If you say yes here, the system time (wall clock) will be set using     │  
  │ the value read from a specified RTC device. This is useful to avoid     │  
  │ unnecessary fsck runs at boot time, and to network better.              │  
  │                                                                         │  
  │ Symbol: RTC_HCTOSYS [=y]                                                │  
  │ Type  : boolean                                                         │  
  │ Prompt: Set system time from RTC on startup and resume                  │  
  │   Defined at drivers/rtc/Kconfig:20                                     │  
  │   Depends on: RTC_CLASS [=y]                                            │  
  │   Location:                                                             │  
  │     -> Device Drivers                                                   │  
  │       -> Real Time Clock (RTC_CLASS [=y])                               │  
  │                                                                         │  
  ├─────────────────────────────────────────────────────────────────( 99%)──┤
 
1 members found this post helpful.
Old 07-27-2012, 08:37 AM   #7
botzko
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 14.1 64bit
Posts: 24

Original Poster
Rep: Reputation: 0
After recompile there is no problem with the clock.

Thank you guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
time frequently changed in fedora 12 somlinux Linux - Software 8 07-05-2010 01:25 AM
Checking when system time was changed last time pgb205 Red Hat 1 03-05-2010 02:31 PM
after reboot computer time is changed powah Linux - General 2 03-16-2009 01:40 PM
system time suddenly changed selva_pondy Linux - Hardware 7 10-28-2007 12:44 PM
OH NO _ Help - My clock has changed to New York Time!! shazam75 Linux - Security 1 03-12-2005 07:23 AM


All times are GMT -5. The time now is 09:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration