LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-03-2013, 06:45 PM   #1
bruinshockey
LQ Newbie
 
Registered: Dec 2010
Location: Chilliwack, BC
Distribution: Slackware64 current
Posts: 29

Rep: Reputation: 8
TigerVNC Server over ssh


I'm having a strange issue with tigervnc and connecting via ssh

i'm running the command vncserver -localhost

which creates a connection on port 5901 which is exactly what i need.

i've configured putty as it should be L5901 192.168.1.99:1

now when i try to connect via localhost:1 through ultravnc it comes back with the error

"Connection failed - End of Stream

Possible causes: another user is already listening on this id"

Last edited by bruinshockey; 12-03-2013 at 07:15 PM. Reason: Fixed the issue
 
Old 12-03-2013, 09:11 PM   #2
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware-64, Crux-64, NetBSD-64
Posts: 560

Rep: Reputation: 270Reputation: 270Reputation: 270
Quote:
Originally Posted by bruinshockey View Post
I'm having a strange issue with tigervnc and connecting via ssh

i'm running the command vncserver -localhost

which creates a connection on port 5901 which is exactly what i need.

i've configured putty as it should be L5901 192.168.1.99:1

now when i try to connect via localhost:1 through ultravnc it comes back with the error

"Connection failed - End of Stream

Possible causes: another user is already listening on this id"
If your SSH server is running on the same machine as your VNC server then the tunnel you create in PuTTY should be configured as follows:

source port = 5901
(I usually pick a high port. For example, 55901);
destination = 127.0.0.1:5901 (the port here - 5901 - must be the same port as that reported when you start the VNC server).

You would use the IP address 192.168.1.xxx only if your SSH server is, for example, running on a separate firewall machine and you are forwarding VNC to a client behind the firewall on the LAN.

Having configured the settings I have outlined above, you would start PuTTY, and when your SSH tunnel comes up you would use the following address in your VNC client to connect to the remote VNC server:

127.0.0.1:55901

If indeed you are running your SSH and VNC servers on separate machines then you would create your tunnel as follows:

L55901 192.168.1.99:5901

You would then connect using the following address in your VNC client:

127.0.0.1:55901

Finally, I am not familiar with TigerVNC but with the TightVNC server there is no need to specify localhost when you are starting your VNC server. It is sufficient just to issue the command as follows:

vncserver


That will report the port the VNC server has created (for example, 5901) which you should use when you are configuring the destination settings in your PuTTY tunnel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tigervnc-server-1.1.0-5.el6.x86_64 for REL 6.4 (Santiago) bhakme Red Hat 0 11-30-2013 01:45 PM
tigervnc server only give me bluescreen vxwo0owxv Linux - Newbie 0 10-18-2013 08:44 AM
2 errors with TigerVNC server Altiris Linux - Newbie 2 08-21-2013 11:49 AM
No cursor seen in VNC viewers when connecting to TigerVNC server picnik Linux - Newbie 3 06-15-2011 04:07 AM
Passwordless SSH with SSH commercial server and open ssh cereal83 Linux - General 7 04-18-2006 01:34 PM


All times are GMT -5. The time now is 02:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration