LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-19-2013, 09:33 PM   #1
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 195

Rep: Reputation: 40
TigerVNC - No password configured for VNC Auth


I am currently running Slackware64 14.0 with TigerVNC 1.1.0. I had this working previously, but I can not connect to my computer via my Android tablet within my own network. When I try to connect I get an error : "No password configured for VNC Auth".

I checked in my /home/*user*/.vnc directory and I see the passwd file there. I have deleted, I've used vncpasswd to recreate the passwd file, I have deleted it again, ran vncserver again to put in a new password...but when I try to connect I continue to get the same error.

What am I missing?
 
Old 10-19-2013, 11:44 PM   #2
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
Are you using x0vncserver? If so, you need to explicitly specify the password file.

Code:
$ x0vncserver -display=:0 -PasswordFile=/home/username/.vnc/passwd

Last edited by Z038; 10-19-2013 at 11:50 PM.
 
Old 10-20-2013, 09:54 AM   #3
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 195

Original Poster
Rep: Reputation: 40
I was just using vncserver. I will try your suggestion and see if it works.
 
Old 10-20-2013, 10:07 AM   #4
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 195

Original Poster
Rep: Reputation: 40
When I try to run x0vncserver I get the following error:

Code:
unable to bind listening socket: Address already in use (98)
Checking with what is listening, nothing is listening on 5900. Only this :

Code:
bash-4.2$ lsof -i -n | grep LISTEN
ssh     5437 jamesgt    4u  IPv6  85296      0t0  TCP [::1]:socks (LISTEN)
ssh     5437 jamesgt    5u  IPv4  85297      0t0  TCP 127.0.0.1:socks (LISTEN)
 
Old 10-21-2013, 01:06 AM   #5
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
You may need to run the command as root. Use su or sudo.

Try this also:

Code:
# netstat -tulpn
 
1 members found this post helpful.
Old 10-24-2013, 07:36 PM   #6
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 195

Original Poster
Rep: Reputation: 40
Code:
# netstat -tulpn
[/QUOTE]

That tells me X itself is listening on 5900. Where do I stop that from happening?
 
Old 10-24-2013, 07:47 PM   #7
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 195

Original Poster
Rep: Reputation: 40
Ok, I found it. In xorg.conf was "load vnc", deleted the line, restarted X and now tigervnc works as it should. Awesome! Thank you very much!
 
Old 10-25-2013, 12:38 AM   #8
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
You're welcome. I'm glad you were able to find it.
 
Old 10-07-2014, 04:36 AM   #9
cstent
LQ Newbie
 
Registered: Oct 2014
Posts: 2

Rep: Reputation: Disabled
no password configured for vnc auth

Hi,
I can connect to my server through windows and linux, but I cannot connect from a specific windows machine to the server. The strange thing is that I get this message, although vnc works fine. Any ideas.
 
Old 10-08-2014, 05:44 AM   #10
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 710

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
If you like VNC (despite it's "dirtiness) you might well love https://www.nomachine.com/
 
Old 10-08-2014, 06:39 AM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,308

Rep: Reputation: Disabled
Quote:
Originally Posted by cstent View Post
Hi,
I can connect to my server through windows and linux, but I cannot connect from a specific windows machine to the server. The strange thing is that I get this message, although vnc works fine. Any ideas.
First of all:

Next time, create your own new thread instead of digging up an old closed thread, it is considered to be against LinuxQuestions etiquette.
Your case is different, only the error message is the same.

Check https://confluence.slac.stanford.edu...roubleshooting for some causes for this specific error.

Eric
 
Old 10-08-2014, 07:32 AM   #12
cstent
LQ Newbie
 
Registered: Oct 2014
Posts: 2

Rep: Reputation: Disabled
Message taken

Ok, thank you for the reply.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"no password configured for VNC auth" Rizzter Linux - Newbie 3 10-11-2013 08:41 PM
No cursor seen in VNC viewers when connecting to TigerVNC server picnik Linux - Newbie 3 06-15-2011 03:07 AM
i have configured squid proxy with NCSA Auth and is running fine. aloknet21 Linux - Newbie 1 02-05-2009 07:02 PM
no password configured for vnc auth sidra Red Hat 4 03-25-2008 07:57 PM


All times are GMT -5. The time now is 09:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration