LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-17-2008, 07:44 PM   #1
warpman
Member
 
Registered: Apr 2005
Posts: 71

Rep: Reputation: 17
Thunderbird slow to respond


I'm running slackware 12 and thunderbird-2.0.0.14. I have the same settings of thunderbird on windows xp pro on the same laptop but different partition. I have notice that thunderbird is very, very slow to download messages. But on the winxp partition this doesn't seem to be the case. Anything I might be able to modify on TB on my slackware partition to make it go faster? What I have is an old sony vaio 550mhz processor and 256mb of memory. Any help would be appreciated.
 
Old 05-17-2008, 07:53 PM   #2
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,160

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
What desktop environment are you running? I'm running Slackware 12.1 on a Plll 667 IBM with 256 MB RAM using XFce 4.4.2. I suggest that you use Xfce or Fluxbox. KDE will be sluggish on that unit.
 
Old 05-17-2008, 08:27 PM   #3
warpman
Member
 
Registered: Apr 2005
Posts: 71

Original Poster
Rep: Reputation: 17
I use xfce or enlightenment. I doesn't matter what desktop I use it does the samething on all of them.
 
Old 05-17-2008, 08:59 PM   #4
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,160

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
Quote:
Originally Posted by warpman View Post
I use xfce or enlightenment. I doesn't matter what desktop I use it does the samething on all of them.
Weird. TBird is responsive when I use XFce or Fluxbox on my Plll. Do your pages load quickly in Firefox?
 
Old 05-18-2008, 02:39 AM   #5
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 659

Rep: Reputation: 38
Compacting your folders will probably help:
http://kb.mozillazine.org/Thunderbir...acting_Folders

If not, how many add-ons have you got installed?
 
Old 05-18-2008, 06:16 PM   #6
warpman
Member
 
Registered: Apr 2005
Posts: 71

Original Poster
Rep: Reputation: 17
The web pages download OK. I get the impression that my internet connection is a little bit faster on the winxp partition compare to my linux partition.
Compacting doesn't help and I don't have any add-ons on my TB. Thanks for your help.
 
Old 05-19-2008, 05:10 AM   #7
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 659

Rep: Reputation: 38
Have you also removed your .msf files from your profilefolder?
And compact again when that's done?
 
Old 06-30-2008, 01:18 PM   #8
warpman
Member
 
Registered: Apr 2005
Posts: 71

Original Poster
Rep: Reputation: 17
Adriv, no I didn't. I'm going to give it a new try. Thanks.
 
Old 06-30-2008, 04:20 PM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0/14.1
Posts: 3,482

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
I used to run Firefox in a dual boot setup. When I ran into issues like this I always diffed (compared) my prefs.js and user.js files. There are some expected differences because of the difference in operating systems, but this trick often would disclose configuration problems.

One additional note, is your TB in Slackware configured to enable ipv6? In Firefox that option is network.dns.disableIPv6. Probably the same or similar in TB. Just a wild guess with this setting....
 
Old 07-20-2008, 10:15 PM   #10
warpman
Member
 
Registered: Apr 2005
Posts: 71

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Woodsman View Post
I used to run Firefox in a dual boot setup. When I ran into issues like this I always diffed (compared) my prefs.js and user.js files. There are some expected differences because of the difference in operating systems, but this trick often would disclose configuration problems.

One additional note, is your TB in Slackware configured to enable ipv6? In Firefox that option is network.dns.disableIPv6. Probably the same or similar in TB. Just a wild guess with this setting....
I was able to locate the prefs.js but not the user.js. I might have to backup my email data and recreate the accounts so that a new prefs.js file can be recreated. I notice that there are some lines oointing to a printer that I no longer have connected to my computer.
I was able to locate the network.dns.disableIPv6 option which is false. Should this option be true? Those the IPv6 affects my TB as well? if so how do I check the TB IPv6 option?
Thanks for your help.
 
Old 07-20-2008, 11:13 PM   #11
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0/14.1
Posts: 3,482

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
Quote:
I was able to locate the prefs.js but not the user.js.
With both TB and Firefox (and Seamonkey), you have to manually create the user.js file. The settings in that file are merged into prefs.js each time you start TB or Firefox and override any settings in prefs.js. I use user.js to ensure that every time I start Firefox my browser is configured the way I want regardless of how I might have changed settings during a browse session.

Quote:
I was able to locate the network.dns.disableIPv6 option which is false.
Try setting to true. This option is/was a known problem causing slow browsing. Perhaps with TB too, I don't know.

Quote:
I notice that there are some lines [p]ointing to a printer that I no longer have connected to my computer.
You can delete all of those lines.

Caveat: Make sure TB is not running when you manually edit prefs.js.
 
Old 07-21-2008, 12:08 AM   #12
warpman
Member
 
Registered: Apr 2005
Posts: 71

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Woodsman View Post
With both TB and Firefox (and Seamonkey), you have to manually create the user.js file. The settings in that file are merged into prefs.js each time you start TB or Firefox and override any settings in prefs.js. I use user.js to ensure that every time I start Firefox my browser is configured the way I want regardless of how I might have changed settings during a browse session.


Try setting to true. This option is/was a known problem causing slow browsing. Perhaps with TB too, I don't know.


You can delete all of those lines.

Caveat: Make sure TB is not running when you manually edit prefs.js.
Thanks I turned the IPv6 to true but didn't any change. I'm going to have to do some reading about the user.js and the prefs.js files. Thanks for your information.
 
Old 07-21-2008, 04:11 PM   #13
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 659

Rep: Reputation: 38
Find the Mail folder in your profile, how big is it (MB's)?
Do you use the same profile as on your WXP?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using thunderbird inbox folders with kmail - thunderbird on linux too slow mtess Linux - Software 1 03-12-2008 10:34 AM
port is slow to respond, please be patient cccc Debian 3 01-22-2007 12:48 PM
ata2 slow respond at boot lucaluca Linux - General 1 01-09-2007 07:36 PM
telnet / ftp slow to respond sanjeevkumark Linux - Networking 1 10-05-2005 08:31 AM
XMMS Slow Respond Arkas Linux - Software 1 04-13-2004 05:08 PM


All times are GMT -5. The time now is 08:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration