LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Thunderbird and SSL (http://www.linuxquestions.org/questions/slackware-14/thunderbird-and-ssl-4175467003/)

tamtam 06-22-2013 11:19 AM

Thunderbird and SSL
 
Having trouble setting up Thunderbird email accounts. Seems that it defaults to none for SSL/TLS. When I select SSL/TLS it cannot verify the accounts settings.

Tried this with couple of my email providers. Know the credentials and such are fine.

I tried the same settings on Fedora and it seems to activate the accounts fine.

Any ideas?

tronayne 06-22-2013 02:42 PM

Using Thunderbird for Gmail' pop server, pop.gmail.com, requires Port 995 with SSL/TLS connection security enabled and normal password for authentication method.

The outgoing server (smtp.googlemai.com) requires port 465, your email address, normal password and SSL/TLS connection security.

You'll need to know the appropriate settings for whatever server you're using (they're not the defaults in Thunderbird).

Hope this helps some.

tamtam 06-23-2013 04:08 AM

Thank you for the reply tronayne.

Quote:

Originally Posted by tronayne (Post 4976728)
Using Thunderbird for Gmail' pop server, pop.gmail.com, requires Port 995 with SSL/TLS connection security enabled and normal password for authentication method.

The outgoing server (smtp.googlemai.com) requires port 465, your email address, normal password and SSL/TLS connection security.

You'll need to know the appropriate settings for whatever server you're using (they're not the defaults in Thunderbird).

Hope this helps some.

I do know the settings and the port. It may well work for gmail but it does not work for any of the accounts I need to set up.

There may be others who are having the same problem, as I tried setting up the same accounts on a different machine also running slackware. I can also set up the accounts in other distros fine.

tamtam 06-23-2013 04:50 AM

Tried a workaround which worked. Thunderbird could not verify the account with SSL. So activated the account with no encryption. Then manually enabled SSL/TLS from Edit > Account Settings.

cmyster 06-23-2013 04:51 AM

Hi,
A little explanation about the "autoconfig": https://developer.mozilla.org/en-US/...oconfiguration
Furthermore, as long as the ports are open and the client can reach the server and ask it for settings, you should be fine.
Personally I have seen cases that settings up Google IMAP (for my personal account) took a few tries.
If however the same application with the same application version that is compiled with the same version of the email provider database constantly succeeds on Fedora and constantly fails on Slack then it is a different case.

tronayne 06-23-2013 05:51 AM

Sorry, I forgot to mention that the automagic set up in Thunderbird doesn't, and I've needed to manually edit the settings (just haven't done it in a long time). Seems like you got it, though, so all should be well that ends, eh? It was a lot easier just doing it manually to begin with before they stuck that "tool" in there, but such is the world of click-'n'-drool, I suppose.

Glad you got it going.


All times are GMT -5. The time now is 09:36 PM.