LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Thunderbird 17.0.3 & Firefox 19.0 Issue (http://www.linuxquestions.org/questions/slackware-14/thunderbird-17-0-3-and-firefox-19-0-issue-4175451028/)

Mobile1 02-20-2013 08:08 PM

Thunderbird 17.0.3 & Firefox 19.0 Issue
 
I know this has been covered a million times, but I am at a loss as to resolve it for the millionth time, since the latest upgrades : )

Everytime an upgrade of Thunderbird / Firefox happens, links in email no longer open in the browser. I have tried all the hacks and fixes I can find, but since TB 17.0.3 & FF 19.0 those hacks and fixes do not work.

What else should I be trying? Thanks for any direction.

bosth 02-20-2013 11:16 PM

I don't use Thunderbird, so I can't say for sure this will solve your problem, but try checking ~/.local/share/applications and clear out the Firefox ones. You might also want to clean up mimeapps.list if it has references to the files you deleted.

tronayne 02-21-2013 07:37 AM

In Thunderbird, click Edit, Preferences, Attachments. In the list three should be an entry for http and https, both those should say Use firefox (which is the default) -- you can click on the line and edit the Action.

Just updating Thunderbird does not cause those setting to change -- unless you're removing your ${HOME}/.thunderbid directory for some reason?

Hope this helps some.

Mobile1 02-21-2013 09:40 AM

tronayne: There are no entries in Thunderbird in the Attachments Dialogue Box. Everytime an upgrade comes out, I upgrade, the links stop working again. Normally I manually make the entries in about:config - but they don't seem to stick in 19.0, or just https will show up.

tronayne 02-21-2013 11:04 AM

OK, I got that the first time -- I upgraded to 17.0.3 yesterday at 08:02 and nothing changed in ~/.thunderbird (the dates are all over the map).

What's the mask of .thunderbird? it should be
Code:

drwxr-xr-x  4 YOURID users    4096 May  3  2011 .thunderbird/
and the directory should look like
Code:

ls -al .thunderbird
total 36
drwxr-xr-x  4 YOURID users  4096 May  3  2011 ./
drwxr-xr-x 103 YOURID users 20480 Feb 21 10:41 ../
drwx------  2 YOURID users  4096 Oct 12 08:30 Crash\ Reports/
drwxr-xr-x  14 YOURID users  4096 Feb 21 11:36 kadbhve8.default/
-rw-r--r--  1 YOURID users    94 Feb  5  2009 profiles.ini

and all that stuff sits in .thunderbird/kadbhve8.default/mimeTypes.rdf (your gobbledygook directory will be a different name). Is there such a file in .thunderbird?

I do upgrades as root (well, su -) using upgradepkg mozilla-thunder*.t?z, I do not edit anything manually in .thunderbird, I do not edit anything in /usr/lib64/thunderbird-17.0.3, and I never fiddle with editing using about:config.

Which leads to a question: have you added local configuration files for Thunderbird anywhere?

The problem you describe has never occurred on my systems -- and, given that I have no add-ins or plug-ins or local configuration files, well... maybe there's a place to look?

Mobile1 02-21-2013 02:38 PM

Tronayne:

I have the following in the .thunderbird folder:

esbhrdhv.default
profiles.ini

I uninstalled Firefox, and reinstalled hoping it would solve the problem...but no. I have no other configuration files that I can see anywhere. I don't see anything like "mimeTypes.rdf" or anything referring to mime types in the folder.

adriv 02-21-2013 03:57 PM

My son had the same complaint (on the same SW box) and after some digging, I found that he did not have that crucial mimeType.rdf file.
So I copied mine to his profile en chown'ed it.
I'm quite sure this has to do with the default browser. Make sure that Firefox is set as default (in your system settings as well as in Firefox -and perform that default browser check).

Mobile1 02-21-2013 04:00 PM

adriv:

Oh it is set to be default, that's the first thing I check, not sure why I don't have a mimeType.rdf file but will see if I have one in a backup of .thunderbird folder : )

adriv 02-21-2013 04:05 PM

What might help too is to set another browser to default and then later on change it back again.
I know that on Windows this sometimes can be a solution.

Mobile1 02-21-2013 05:17 PM

adriv:

It was the fact there was no mimeType.rdf - I had one from previous install (a backup) copied the file into the .thunderbird folder and BAM! No the links in email open in browser : ) The two http & https show up in the Attachment TAB in thunderbird as well.

Thanks for your help.


All times are GMT -5. The time now is 03:00 AM.