LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Thunar install on Slackware 10.2 kernel 2.6.16.19 (http://www.linuxquestions.org/questions/slackware-14/thunar-install-on-slackware-10-2-kernel-2-6-16-19-a-451829/)

brooky9999 06-05-2006 12:27 PM

Thunar install on Slackware 10.2 kernel 2.6.16.19
 
Hi all,

I'm having problems trying to install Thunar on Slackware 10.2.

I've downloaded Thunar 0.3.0 Beta 1 and libexo 0.3.1.6 Beta 1 from http://thunar.xfce.org/download.html.

I've unpacked both, and as per the instructions on http://thunar.xfce.org/pwiki/documentation/installation tried to install libexo first.

The compiling fails telling me that my intltool is too old, and that I need 0.31 or later.

I have downloaded and installed intltool 0.33 from http://www.linuxfromscratch.org/blfs.../intltool.html
but still it gives me the same error. From what I can tell from the install, intltool was installed to /usr/local/share/intltool.

Am I missing something? Does anyone know an easier way to install Thunar?

Many thanks,


Mark.

egag 06-05-2006 01:27 PM

did you uninstall the old intltool package ?
if not, do so.
( and after that reinstall the newer one.)

egag

brooky9999 06-05-2006 01:37 PM

Hi egag,

If you mean 'package' as by one that I can remove by pkgtool, then I didn't have one installed.

I'm pretty sure that the only one I have installed is the one I did myself (0.33). That is now in /usr/local/share/intltool.


Mark.

egag 06-05-2006 02:01 PM

----------------
The compiling fails telling me that my intltool is too old
----------------

" to old" or "not there" ?
it's one of both.

what does " ls /var/log/packages/intltool* " give back ?

egag

brooky9999 06-05-2006 03:27 PM

Hi egag,

It gives back:

Quote:

ls: /var/log/packages/intltool*: No such file or directory.
I think that's because I don't have it as an installed package, but because I installed and compiled the source for 0.33.

Is that what you mean?

Thank you for helping me with this BTW.


Mark.

egag 06-05-2006 03:43 PM

that's what i mean.
so it's just not there as a package.

if you have installed to /usr/local, the binaries are in /usr/local/bin.
is that dir (/usr/local/bin) in your PATH ?
( check with "echo $PATH ")

and check "ls /usr/local/bin/intltool*" .
the last one should return "intltool-extract" and a few others.

if all that is ok, you "should" be ready to go.

egag

brooky9999 06-05-2006 04:08 PM

Hi egag,

If I run:

Code:

ls /usr/local/bin/intltool*
I get:

Code:

-rwxr-xr-x  1 root root 13942 2006-06-05 18:20 /usr/local/bin/intltool-extract
-rwxr-xr-x  1 root root 34090 2006-06-05 18:20 /usr/local/bin/intltool-merge
-rwxr-xr-x  1 root root  8667 2006-06-05 18:20 /usr/local/bin/intltool-prepare
-rwxr-xr-x  1 root root 26943 2006-06-05 18:20 /usr/local/bin/intltool-update
-rwxr-xr-x  1 root root  8920 2006-06-05 18:20 /usr/local/bin/intltoolize

if I run:
Code:

echo $PATH
I get:
Code:

/usr/local/sbin:/usr/local/bin:/usr/sbin:/bin:/usr/bin
But yet when I try to run ./configure --prefix="/usr/local" for libexo, it still moans that my Intltool is still too old.

Also, if I run:
Code:

/usr/local/bin/intltoolize --version
I get:
Code:

intltoolize (GNU intltool) 0.33
What am I missing?


Mark.

egag 06-05-2006 04:25 PM

it's a shit-script.
maybe it's only looking in /usr/bin

the simplest thing to try is move the files from /usr/local/bin to /usr/bin
( to do that :"mv /usr/local/bin/intltool* /usr/bin" )

if that still won't work, i would change the config-script.

egag

egag 06-05-2006 04:49 PM

oh....btw: what command do you use to start the configure-script ?

egag

brooky9999 06-05-2006 04:55 PM

egag,

I'm using:

Code:

./configure --prefix="/usr/local"
As laid out in http://thunar.xfce.org/pwiki/documentation/installation.

What do you reckon is the best thing to do?

Again, thanks for the time you're spending helping me on this.


Mark.

egag 06-05-2006 05:23 PM

can you try without the quoting-marks ( "" ) around /usr/local ?

egag

brooky9999 06-05-2006 05:54 PM

Hi egag,

Nah, still the same error. It's also the case if I leave off the --prefix options altogether.

Which do you think I should do now - move the intltool files or modify the configure script?


Mark.

gnashley 06-06-2006 01:46 AM

do make uninstall on your compiled intltool.
Then reconfigure using --prefix=/usr and re-install


All times are GMT -5. The time now is 03:15 PM.