LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Thinkpad T500 fan control, what is best way to control (http://www.linuxquestions.org/questions/slackware-14/thinkpad-t500-fan-control-what-is-best-way-to-control-811770/)

11thhour 06-02-2010 02:53 PM

Thinkpad T500 fan control, what is best way to control
 
Hello,

I have had my thinkpad for just a few short months and, it must be that we are heading into summer, but I am starting to finally run into some overheating issues especially when compiling software for awhile, i.e. kernel.

My question would be, "Is it best to let the built in thermal management take care of the issue, and I just need to know what to tweak, or to put on a script solution such as the tp-fancontrol script?

The computer takes about 5-10 minutes to overheat and the message I get in /var/log/messages is "logger: ACPI group thermal_zone / action THM1 is not defined" then it shuts down.

So, any pointers in the right direction would be appreciated.

I am running slackware-current x86_64 on a Lenovo Thinkpad T500.

Thanks for your help,

Troy

Didier Spaier 06-02-2010 04:06 PM

Please post the output of following commands:
Code:

ls -1 /proc/acpi/thermal_zone/THM1
cat /proc/acpi/thermal_zone/THM1/*

Also:
What is you Slackware version ?
Which kernel do you use ?
Is this kernel shipped with Slackware or compiled by yourself ?

[EDIT]And yes, you can try one of the scripts proposed on this page. Some people are not happy with built-in thermal management and try either to slow down their CPU and/or GPU or to accelerate their fan.

11thhour 06-02-2010 04:16 PM

Sure Didier,

Here is the output
Quote:

ls -1 /proc/acpi/thermal_zone/THM1
===
cooling_mode
polling_frequency
state
temperature
trip_points
Quote:

cat /proc/acpi/thermal_zone/THM1/*
===
<setting not supported>
<polling disabled>
state: ok
temperature: 60 C
critical (S5): 100 C
passive: 96 C: tc1=5 tc2=4 tsp=600 devices=CPU0 CPU1
As far as kernel I am running 2.6.33.5 using .config from 2.6.33.4-huge, compiled myself from instructions in slackbook, however had same behavior on 2.6.33.4 stock from slackware, actually just upgraded today

Also, running slackware current x86_64 up to date from 5/19, so I guess right at the moment slackware 13.1

Also, I have the most current bios installed as well.

Thanks,

Troy

Didier Spaier 06-02-2010 04:33 PM

Well, I have the same output on my Thinkpad T61 (very similar to T500 only older), but the temperature (45) but that's normal as my machine is almost idle.

Only to make sure, please send output of following command too:
Code:

zcat /proc/config.gz|grep CONFIG_ACPI
FYI here is mine:
Code:

bash-4.1$ zcat /proc/config.gz|grep CONFIG_ACPI
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROCFS_POWER=y
CONFIG_ACPI_POWER_METER=m
CONFIG_ACPI_SYSFS_POWER=y
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m
CONFIG_ACPI_DOCK=y
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_HOTPLUG_CPU=y
CONFIG_ACPI_PROCESSOR_AGGREGATOR=m
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_PCI_SLOT=m
CONFIG_ACPI_CONTAINER=m
CONFIG_ACPI_HOTPLUG_MEMORY=m
CONFIG_ACPI_SBS=m
CONFIG_ACPI_HED=m
CONFIG_ACPI_APEI=y
CONFIG_ACPI_APEI_GHES=m
CONFIG_ACPI_APEI_EINJ=m
CONFIG_ACPI_WMI=m
CONFIG_ACPI_ASUS=m
CONFIG_ACPI_TOSHIBA=m
CONFIG_ACPI_CMPC=m


11thhour 06-02-2010 05:14 PM

Didier,
Looks mostly similar. Here is mine:
Quote:

bash-4.1$ zcat /proc/config.gz|grep CONFIG_ACPI
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROCFS_POWER=y
CONFIG_ACPI_POWER_METER=m
CONFIG_ACPI_SYSFS_POWER=y
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m
CONFIG_ACPI_DOCK=y
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_HOTPLUG_CPU=y
CONFIG_ACPI_PROCESSOR_AGGREGATOR=m
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_PCI_SLOT=m
CONFIG_ACPI_CONTAINER=m
CONFIG_ACPI_HOTPLUG_MEMORY=m
CONFIG_ACPI_SBS=m
CONFIG_ACPI_WMI=m
CONFIG_ACPI_ASUS=m
CONFIG_ACPI_TOSHIBA=m
CONFIG_ACPI_CMPC=m
The only lines that you have that I do not are:
Quote:

CONFIG_ACPI_HED=m
CONFIG_ACPI_APEI=y
CONFIG_ACPI_APEI_GHES=m
CONFIG_ACPI_APEI_EINJ=m
Would these make a difference?

Thanks,

Troy

Didier Spaier 06-02-2010 05:47 PM

I have theses lines and you don't only because some features are available only on kernel newer than yours (I'm running 2.6.35-rc1 at present) so that's normal.

I'm running out of ideas so may be you could try one of those scripts.

Maybe you can check fan speed first to see if it increases when temperature does.

You can "cat /proc/acpi/ibm/fan" for that.

dive 06-02-2010 07:38 PM

I use tp_fancontrol script on my T42 BUT it doesn't say it supports anything like T500 so be very very careful what you run or you could kill your cpu.

11thhour 06-03-2010 03:07 AM

Didier,

Thanks for the suggestion. Running a kernel compile and watching the tmp of TMP1 and the speed in the fan file, even as the temperature reaches 96 degrees the fan has only gone up 50 rpm. At it seems to hover around 3000 and 3050 rpm, which obviously is not going fast enough.

When I add
Quote:

options thinkpad_acpi fan_control=1
to a file in the /etc/modprobe.d directory, reboot and then run
Quote:

echo level 7 > /proc/acpi/ibm/fan
the processor will stay in the 75-77 degree area during the middle of a compile. But, of course that is from my understanding overriding the BIOS control.

Dive, thanks for the suggestion, that is why I am trying to avoid doing any scripts because I don't see where the T500 is directly supported by any of them.

I was just hoping for any suggestions from anyone that may have it working without having to resort to the scripts out there, with summer and code needing to be written, might not be any other option.

Hopefully somebody else may have a suggestion. Thanks so far for the ones I have received.

--Troy

dive 06-03-2010 07:44 AM

Do you have the fan module loaded?


All times are GMT -5. The time now is 03:19 AM.