LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2012, 09:52 AM   #1
dsplayer14
Member
 
Registered: Nov 2011
Distribution: Arch Linux and Slackware 13.37
Posts: 127

Rep: Reputation: 1
Think you can help me with getting Slackware to recognize my 2nd monitor?


OK, I am trying to get Slackware to recognize my 2nd monitor, and, as a new guy, I am having some difficulties. My first monitor is connected to my ATI Radeon 6670 graphics card, and I have my second monitor connected to my (I'm assuming) onboard graphics card. Well, I did SEVERAL google searches (however, I might not have searched for the right thing...) with no help. So, if you can, I need some help. My actual problem is that the monitor is not doing anything. Power and VGA is plugged in, and that is all I know...
 
Old 09-23-2012, 09:53 AM   #2
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
In most cases, using a video card disables the onbaord video.

Try using the 6670 for both monitors.
 
Old 09-23-2012, 09:55 AM   #3
dsplayer14
Member
 
Registered: Nov 2011
Distribution: Arch Linux and Slackware 13.37
Posts: 127

Original Poster
Rep: Reputation: 1
Thanks for the quick reply. But, my 6670 has only 1 VGA port. I dont understand how I could use both of them on the card. I do have an adapter that I can use to plug in the VGA cable from my second monitor into a USB slot I have. Anyway I can use that, incase I can use my graphics card?

Last edited by dsplayer14; 09-23-2012 at 10:03 AM.
 
Old 09-23-2012, 10:07 AM   #4
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
It might (should AFAIK) work with a DVI-VGA adapter.
 
Old 09-23-2012, 10:13 AM   #5
dsplayer14
Member
 
Registered: Nov 2011
Distribution: Arch Linux and Slackware 13.37
Posts: 127

Original Poster
Rep: Reputation: 1
Connecting that to the DVI port on my card will work then? Ok, I suppose I could go to Best Buy and pick one up... Getting ahead of myself, but when I get the monitor connected, will I need to edit any files? I probably need to edit xorg.conf, right?
 
Old 09-23-2012, 10:23 AM   #6
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
First, what kind of video card is your integrated one? Are the modules loaded for both? If you have them both plugged in, try something like
Code:
xrandr --output VGA-0 --noprimary --left-of LVDS --mode 1680x1050 --output LVDS --mode 1280x800
but substitute for your needs. To find out what displays are available, do
Code:
xrandr
and you should get some output like this:
Code:
Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 8192 x 8192
VGA-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      59.9*+
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
LVDS connected 1280x800+1680+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4
 
Old 09-23-2012, 10:27 AM   #7
dsplayer14
Member
 
Registered: Nov 2011
Distribution: Arch Linux and Slackware 13.37
Posts: 127

Original Poster
Rep: Reputation: 1
The output of xrandr
Code:
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 1440 x 1440
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
CRT1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900       59.9*+
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1280x800       60.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9
I guess it recognizes only one monitor?
I cant find my integrated card when I used lspci... Or maybe I just dont know what it is called
Code:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation 2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation 6 Series Chipset Family LPC Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 6 Series Chipset Family 4 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series Chipset Family SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 6 Series Chipset Family 2 port SATA IDE Controller (rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 6758
01:00.1 Audio device: ATI Technologies Inc Device aa90
04:00.0 PCI bridge: Device 1b21:1080 (rev 01)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
 
Old 09-23-2012, 10:30 AM   #8
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Do you have the integrated one disabled in the bios by any chance?
 
Old 09-23-2012, 10:40 AM   #9
dsplayer14
Member
 
Registered: Nov 2011
Distribution: Arch Linux and Slackware 13.37
Posts: 127

Original Poster
Rep: Reputation: 1
I checked through my BIOS, I didn't find anything that suggested that is was disabled.
 
Old 09-23-2012, 10:45 AM   #10
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Is this a machine you put together, or one from someplace like Dell? If the latter, try looking up the model number to get what the onboard VGA device is.
 
Old 09-23-2012, 10:52 AM   #11
dsplayer14
Member
 
Registered: Nov 2011
Distribution: Arch Linux and Slackware 13.37
Posts: 127

Original Poster
Rep: Reputation: 1
Custom built PC. ASUS motherboard and an Intel chipset. If it is easier, I would like to try the VGA to DVI adapter to see if that works. I'll reply back once I give it a shot.
 
Old 09-23-2012, 10:55 AM   #12
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
No onboard video in the lspci, I'm confident saying that its disabled...either from a setting in the BIOS or from installing a video card.

You really dont want to be using the onboard video if your card is capable of displaying to as many monitors as you want/need. Onboard video almost always uses system RAM and I/Os, and i the case of the 'sandy bridge' and newer 'intel HD video' it uses the CPU cache as well.

Quote:
Originally Posted by dsplayer14 View Post
Connecting that to the DVI port on my card will work then? Ok, I suppose I could go to Best Buy and pick one up... Getting ahead of myself, but when I get the monitor connected, will I need to edit any files? I probably need to edit xorg.conf, right?
Depends on your setup.

Seeing how your video device is listed in lpci as 'VGA compatible controller: ATI Technologies Inc Device 6758' I'd say that your xorg version is older than the video card. That can make things more difficult.

You could try installing the AMD closed drivers, and running 2 monitors from the AMD display drivers GUI.

*edit- its farily common to get a DVI-VGA adapter with most video cards with a DVI output. If you built the machine yourself, check the video card box before you buy one. If you had it built for you, try asking whoever built it for a the adapter.

Last edited by cascade9; 09-23-2012 at 10:58 AM.
 
Old 09-23-2012, 11:03 AM   #13
dsplayer14
Member
 
Registered: Nov 2011
Distribution: Arch Linux and Slackware 13.37
Posts: 127

Original Poster
Rep: Reputation: 1
The driver I am using is the proprietary one, and I used the aticonfig command to create my xorg.conf, if you would like, I can upload it for you. I don't think it is "old" since I used the command given to me by the driver. However, I am not very experienced with these kinds of things so I may be wrong.
 
Old 09-23-2012, 12:23 PM   #14
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,489

Rep: Reputation: 662Reputation: 662Reputation: 662Reputation: 662Reputation: 662Reputation: 662
Quote:
Originally Posted by dsplayer14 View Post
Thanks for the quick reply. But, my 6670 has only 1 VGA port. I dont understand how I could use both of them on the card. I do have an adapter that I can use to plug in the VGA cable from my second monitor into a USB slot I have. Anyway I can use that, incase I can use my graphics card?
If you want to use two monitors without the hassle, go for el cheapo NVidia cards. NVidia GT 210 on PCI express slots, GeForce 6200 chipset on older AGP ports. Install the proprietary drivers, and then:

Code:
# nvidia-xconfig --twinview
This gives you a workable configuration, which you may want to fine-tune by starting X and then launching the graphical NVidia configuration tool, as root in a graphical Terminal.
 
Old 09-23-2012, 07:08 PM   #15
Lirey
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 32

Rep: Reputation: 5
Before you buy an adapter, check what type of DVI port you have on the video card. A lot of the newer AMD video cards have DVI-D ports, which are not easy to adapt to VGA.

A DVI port can have pins for analog signals (DVI-A), digital signals (DVI-D), or both (DVI-I). Most ports are DVI-D or DVI-I (I've never seen a DVI-A), and the type of adapter you'll need depends on the DVI port type. The analog signals are VGA, so you can use a cheap adapter that just brings the correct pins to a VGA jack. Most cards with DVI-I ports used to come with one of these adapters thrown in for free, and if you have to buy one they cost $5 US or less. If the port is a DVI-D, it only has digital signals and will need a digital to analog video converter, which are harder to find and can cost more than some low end video cards.

If your card has an HDMI port, you may be able to get an HDMI to VGA converter for less than a DVI-D to VGA converter.

Unfortunately, more and more video cards have DVI-D ports, since most of the newer monitors are all digital. Support for VGA is rapidly disappearing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
where to find information as how to get freespire too recognize my 2nd hard drive don spaulding Linux - Newbie 1 06-13-2010 07:28 PM
Dual Monitor: 2nd monitor not coming up -- xorg.conf missing something? Hewson Linux - Hardware 3 10-20-2009 11:24 AM
howto: synaptic recognize 2nd CD-drive ? stu7 Debian 3 07-18-2008 04:31 PM
Slackware as 2nd os on 2nd hdd chd_lad Linux - Newbie 7 04-05-2008 03:43 PM
Can you use a tv as a 2nd monitor caleb star Linux - Hardware 3 08-10-2004 08:21 AM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration